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 Introduction

 

Welcome to the new and exciting world of DHTML pull-down 
menus!

It has been proven that the easiest way to navigate the different options of any 
interface is through the use of menus. Operating systems and most software 
use menus to allow the user to navigate and find his way around.

So... why shouldn't your web site use menus, too?

DHTML Menu Builder not only creates menus, it creates beautiful menus 
composed of thousands of lines of code compatible with all the major browsers 
and platforms. But don't worry, you don't have to know anything about the 
code that DHTML Menu Builder produces. You can just concentrate on using it 
to spice up your navigation system. Let DHTML Menu Builder do the hard work!

From plain, text-based menus to complex graphical menus loaded with the 
latest DHTML and CSS standards, DHTML Menu Builder can deliver professional-
looking menus that work and feel as if you were using some program on your 
computer.

DHTML Menu Builder's feature-rich options will let you build a navigation 
system just the way you want  it. With support for any kind of web site 
configuration–including sites that use frames, sites that use pre-processor 
languages (such as ASP or PHP), and sites built with any HTML authoring 
application, DHTML Menu Builder is the ultimate site navigation solution.

Did we mention that the menus look cool? The menus created by DHTML Menu 
Builder can be highly customized so that the user will not even notice that the 
navigation system is made up of standard HTML elements!

This documentation will guide you through all of the different parts of DHTML 
Menu Builder and will also help you master the basics needed to easily add 
menus to your existing web site. Please read it carefully... there's a lot of 
important information that will help you set up your navigation system in a 
couple of minutes.
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 Getting Started

The following sections explain the basics of preparing your menu project. 
Here, you will also learn about all the components that make up a menu system and the styles that can 
be used to customize each and every one of these components.

Please select the section you would like to read about. We recommend that first time users read all of 
the topics in the order presented below.

●     Preparing Your Web Site
●     Project Properties
●     Creating Menus
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 Preparing your Web Site

Depending on the type of menus you're going to build, certain preparations need to be made to your 
web site. 

DHTML Menu Builder can be used to create a toolbar, or you can create menus which appear using 
elements that already exist on your web pages.

If you're going to use a toolbar created by DHTML Menu Builder, there's no need to do any additional 
preparations to the pages on your web site and you may continue to the next section:  Project 
Properties

Using your own text and graphics

One of the most unique features of DHTML Menu Builder is the ability to attach menus to text or 
graphics which you have already placed in your web pages. 
This feature lets you build your own custom toolbar using your favorite image editing program, and 
then have the menus react when the user activates an element from your toolbar. It is important to 
understand that the toolbar is the only element of a menu that is always visible to the user and its 
design should be consistent with the general layout and design of your web site.

When using your own toolbar, you need to set up each hotspot in a special way so than DHTML Menu 
Builder can later attach the menu groups to them. This setup is known as converting the hotspots into 
null hyperlinks.

Converting your hotspots into null hyperlinks

A hotspot can be an image or just some text. To convert your hotspot into a null hyperlink, simply 
create a hyperlink on that element and make it point to itself; this is done by using a hash (or pound 
sign) character "#" as the target of the link.

  

  

Let's say this is one of the images you're going to use to display a menu. 

The HTML code of the image looks like this: 
<img border="0" src="images/sample_image.gif" align="middle" width="50" height="33">
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After converting the image into a null hyperlink the code looks like this: 
<a href="#"><img border="0" src="images/sample_image.gif" align="middle" width="50" 
height="33" name="MyImage"></a> 

As you can see, by moving the mouse over the converted image, your mouse changes into a 
hand indicating that the image is a link. Highlighted in dark red you can see the code that 
converted the image into a null hyperlink. Also note that we have added a new setting, 
name,  to the image's code. The name setting will allow DHTML Menu Builder identify the 
image and perform automatic alignment of the menus. You should give each image-based 
hotspot a unique name so DHTML Menu Builder can identify it.

This is all the preparation that needs to be done, so when you are ready to implement your menus into 
the page that contains the toolbar, everything will be ready to use the HotSpots Editor and 
automatically make your hotspots active and responsive to users' actions.

Once you have your web site prepared with all your hotspots converted into null hyperlinks, you can 
now move to the next section and start preparing your menus in DHTML Menu Builder: Project 
Properties

Related topics of interest: 

●     Creating Toolbars
●     The HotSpots Editor
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 Project Properties

Every menu system you create with DHTML Menu Builder is stored in a  project file with a DMB 
extension.

Many settings affect your entire project; these are set through the pages of the Project Properties 
dialog.

To access the Project Properties dialog, follow any one of the following steps:

●     From the File menu, choose Project Properties.
●     Press the CTRL+P shortcut
●     Click the Project Properties icon  on the toolbar

The Project Properties dialog is divided into 5 main sections. Along with their main purpose, they are 
listed below:

●     General: specify your project's name and location of the project files. 

●     Configurations: specify the location of your web and the JavaScript files DHTML Menu Builder 
needs to implement the menus . This section is also used to set up frames support. 

●     Global Settings: change several settings that affect the whole project.

●     Advanced: change some of the advanced options of your project (e.g. type of optimization to 
be applied to the generated code files).

Page 6 of 181

file:///C|/My%20Projects/Visual%20Basic/DHTML%20Menu%20Builder%204.8/Help/dialogs/pp_general.htm
file:///C|/My%20Projects/Visual%20Basic/DHTML%20Menu%20Builder%204.8/Help/dialogs/pp_globalsettings.htm
file:///C|/My%20Projects/Visual%20Basic/DHTML%20Menu%20Builder%204.8/Help/dialogs/pp_advanced.htm


 Configurations

The final process of implementing a menu system with DHTML Menu Builder involves the ability to save 
the menus in a folder on your computer. 
To do this, DHTML Menu Builder needs to know where to save the compiled JavaScript files and the 
images that your menus use.

To access the Configurations editor click File->Project Properties->Configurations

By default, when you create a new project DHTML Menu Builder will create a new configuration called 
"Default". 
Bellow is a list of the settings that need to be made:

●     Local Path to the Root Web 
This is the route or path to the folder containing your main HTML page. Typically, this is index.
htm, default.htm, index.html or default.asp. 
Always avoid typing the path manually; use the browse button  to select the folder and avoid 
typographical errors.

●     Folder to Store Compiled Files 
This setting must point to a folder inside your root web where you will store the JavaScript files 
compiled by DHTML Menu Builder. These files are the scripts that build and handle the menus. 
Again, always avoid typing the path manually and use the browse button  to select the folder 
and avoid typographical errors.

●     Folder to Store Images 
This path is where you want DHTML Menu Builder to store the images files used by your 
menus. This folder must also be inside your root web. 
As always,  avoid typing the path manually and use the browse button  to select the folder 
and avoid typographical errors.

DHTML Menu Builder needs some additional information about your web site and the files in it. 
For example, if your site uses frames you will have to set up frames support and specify the necessary 
settings related to frameset structure of your web site.

Another group of settings will let you use the HotSpots Editor to automate the process of inserting the 
code necessary to run the menus on your web site.

Setting up the document that will trigger the menus

Besides the standard path settings described above, each configuration must have information about 
the document on your web site that will be used to trigger the menus. The menus can be triggered 
from the toolbar created by DHTML Menu Builder or through the use of HotSpots.

NOTE: This file will be modified by DHTML Menu Builder to include all the code necessary to make the 
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menus work. It is a good practice to always keep a backup copy of this file.

As you can see, DHTML Menu Builder gives you the option to install the menus onto a single file. 
However, you may want to install the menus on all the files on your web site, and there are several 
ways to this: 
Ideally you should install the menus onto a single file and then share this file across all the other 
documents on your web site. 

●     Some applications, such as Macromedia's Dreamweaver let you create a template from which all 
the documents on your web site inherit their style. This template is where you should install the 
menus so every time you create a new document it will automatically inherit the code that loads 
the menus. For more information about templates, consult your Dreamweaver documentation.

If your HTML editor does not support templates you could then use some sharing technique that is 
either supported by your web server or your HTML authoring application. 

●     For example, Microsoft's FrontPage supports something known as the Page Inclusion 
component. This component allows you to include a page inside another page. For more 
information about the Page Inclusion component, consult your FrontPage documentation.

Finally, many web servers support SSI or Server Side Includes. To know if your web server supports 
this feature and for information on how to use it, consult your web server's documentation or ask your 
server administrator.

Setting up your project to support frames

DHTML Menu Builder has 100% support for implementing the menus on web sites that use frames. 
A common issue when using frames is that most of the time the menus will not fit on the frame where 
you have designed the toolbar. The only solution, since it's not possible to display anything above the 
division of two frames, is to have the menus appear on another, larger frame.

More information about the setting up your menus to work with frames.

Related topics of interest: 

●     Implementing the Menus
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 Creating Menus

A  DHTML Menu Builder menu is comprised of three items: 

●     Groups 
The groups are containers and control the space used to hold commands and separators. 

●     Commands 
These are the basic items of your menus. The commands are the options that user selects to 
navigate through your web site using the menus. 

●     Separators 
The separators are a special kind of command whose only purpose is to create a separation, 
with a thin line, between two commands.

In other words, a Project is made of menus. Each menu is made of groups that contain commands and 
separators. 
The illustration below diagrams this relationship:

Since it is the most general item, the project controls the way the menus will work on your web site. 
The group is a container; it controls the background color, images and borders of the menus. The 
commands control the actions of the menus; the color and font used by the menus is also controlled at 
this level.

Of course, these are just the most basic settings of each item. Later on in this Help, you will find that 
DHTML Menu Builder provides unprecedented formatting options to let you make your menus look 
exactly they way you want them to appear.

Adding, Renaming and Deleting Groups 

After a  project is created, you must next create a group. Once you have created a group, you will then 
be able to add commands and separators to it and this will complete the creation of a menu. 
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A project can have as many menus as you need. 

To add a group, do any one of the following steps: 

●     On the Menu menu, click Add Group.
●     Press the F6 shortcut key.
●     Click the Add Group icon  from the toolbar.

When you create a group, DHTML Menu Builder will add an entry in the left side of the main window 
and will wait for you to type a name. This name is an internal reference for DHTML Menu Builder and is 
independent of the actual caption of the added item. Both the name and the caption can be the same 
if you wish.

After entering the name of the group, DHTML Menu Builder will auto fill the Caption property for you. 
Change it if you need to. The Caption is the actual text that will be displayed when your menu is 
viewed with a browser.

To rename the group, just select it and then choose Rename from the Edit menu. Alternatively, 
after selecting the group name, you can also press F2 or just click it again (after a short pause so it is 
not interpreted as a double-click) and you can edit in place. Note that if you have already set the 
caption for a group, DHTML Menu Builder will not update its caption when you rename the group.

To delete a group, select it and then choose Delete from the Edit  menu.  
It is important to note that when you delete a group, you will always delete any command(s) created 
under it. This is because groups are containers that hold commands; if you delete the container, all the 
commands under it are deleted as well.

To learn more about groups, click here.

Adding, Renaming and Deleting Commands

In order to create commands, you need to have at least one group in your project. 
Each command represents an option in your menu. Commands can have actions associated with them 
to perform functions when a user activates them with the mouse.

A command can instruct the browser to open a page (and optionally to display it in a new browser 
window), to send an email,or to display another group and create what is known as a submenu.

To add a command, do  any one of the following steps: 

●     On Menu menu, click Add Command (or click Add Separator to add a separator).
●     Press the F7 shortcut key (or press the SHIFT+F7 shortcut key to add a separator).
●     Click the Add Command icon  from the toolbar (or click the Add Separator icon  to add a 

separator).
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Right after the command entry has been added, DHTML Menu Builder will let you name the command. 
Again, this name is just an internal name used by DHTML Menu Builder and is not the actual text that 
will be displayed on the menus when these are viewed on your web site with a browser. To change the 
text to be displayed for this item, just change the caption.

To rename a command, just click over it to select it and then select Edit form the menu and then 
Rename. 
Note that if you have already set the caption of this item, DHTML Menu Builder will not update its 
caption.

To rename a command, just select it and then choose Rename from the Edit menu. Alternatively, 
after selecting the command name, you can also press F2 or just click it again (after a short pause so it 
is not interpreted as a double-click) and you can edit in place. Note that if you have already set the 
caption for a command, DHTML Menu Builder will not update its caption when you rename the 
command.

To delete a command, select it and then choose Delete from the Edit  menu. 

To learn  more about commands click here.
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 Groups

Groups are containers for the commands (items) on a menu. They are responsible for specifying 
attributes such as background color, frame thickness and color, margins, etc.

Listed below are the attributes of groups and specific information about each one: 

●     Back Color 
To change the background color of a group, select the group. Then, on the Menu menu click 
Color. 
You can also change the background color of a group by accessing the Image dialog. With the 
image dialog you will have many more options to customize the look of your group and select 
more properties from the dialog. (See Image below). 

●     Font 
A group can define the default font used by its commands. When you change the font on a 
group, newly created commands will inherit this setting. 
Also, when using toolbars, this will be the font used to represent this group. 
To change the font of a group, first select the group. Then, on the Menu  menu click Font. 

●     Cursor 
You can make the mouse pointer change when a user moves the mouse over a hotspot, 
whether it is a hotspot created by you or a hotspot from the toolbar created by DHTML Menu 
Builder. 
To change the cursor of a group, fist select the group. Then, on the Menu menu click Cursor. 

●     Image 
Groups support several types of images: 

●     Back Image 
This is the image used in the background of the container. 
When using images in the background of the groups, the commands will not display the 
normal background color. If they did, this color would cover the image producing an 
undesirable effect. 

●     Border Size and Colors 
Groups are containers. You can customize the borders. 
The border size setting will let you adjust, in pixels, the width of this container. The color 
settings let you customize the color of each one of the four borders.

When using the toolbar created by DHTML Menu Builder, you have the option to specify images 
for your groups to be placed at either or both sides of the group's caption. 
For more information, check the Creating Toolbars section. 
To change any of the above settings for a group, select the group. Then, on the Menu menu 
click Image. 

●     Leading 
This setting controls the vertical spacing between the commands in the group. 
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●     Margins 
This setting controls the distance from the group's borders to its contents. 

●     Selection Effects 
The settings in this section affect the commands under the selected group and control the style 
and color of the bounding rectangle of the menu items. 
Also, if the selected group is going to be displayed on a toolbar, these setting will also affect the 
toolbar item.

●     Normal and Over 
These settings change the border of the commands when the mouse is  over (Over 
state) and not over (Normal state). 
You can choose from three different types of border effects: 

●     (none): No border will be drawn.
●     Raised: A border will be drawn which has the effect of raising the command 

towards you.
●     Sunken: A border will be drawn which has the effect of insetting the border into 

the group's background.
●     Double: Two two solid borders will be drawn around the command.
●     Bevel: Two borders – one raised and one sunken, each half the size of the total 

border width – will be drawn around the command.
You can also define the base color that will be used to draw these borders by using the 
color selection boxes next to the border style controls. 

●     Border Size 
This setting creates a border of the specified width around the commands. 

●     Horizontal and Vertical Margins 
These settings control the distance from the border of the commands to their contents.

●     Special Effects 
The special effects dialog is divided into two sections: 

●     Group Size 
By default, DHTML Menu Builder measures the contents of the group and determines 
the optimal width and height of the group so that the contents fit into it. 
However you can manually adjust these values using the controls on this dialog:

●     Auto: The program will calculate the width and height automatically based on 
the item's contents. This is the default setting.

●     Background Image: The width or height of the item will be set to the size of 
the background image.

●     Manual: DHTML Menu Builder will accept the numbers (in pixels) that you enter 
here These numbers will define a specific width or height for the group. Note that 
defining a value that is too small will cause unpredictable results and will 
incorrectly render the contents of the group. Click the Calculate button to let 
DHTML Menu Builder calculate the recommended size of the selected item.

●     Group Effects 
This dialog will let you define some special effects for the selected group:

●     Drop Shadow Color: Move the slider towards the right to increase the darkness Page 13 of 181



of the shadow displayed behind the selected group. 
●     Transparency: Move the slider towards the right to increase the transparency of 

the group and its contents. This will reveal whatever contents are underneath the 
group.

●     Context Menu: Check this option to make the selected group the context menu 
for the browser. This means that when a user right clicks a page, the selected 
group will be displayed instead of the browser's default context menu.

Note that the Drop Shadow and Transparency effect will only work for those using 
Internet Explorer 5.5 (or above) for Windows. 

●     Commands Layout 
This setting controls the way the commands are aligned inside a group :

●     Vertically (default): Commands will be placed one below the other creating a 
standard dropdown menu.

●     Horizontally: Commands will be placed one next to the other creating a wide menu. 
These kind of menus are ideal when there's not enough vertical space to display a menu.

To change any of the Special Effects settings of a group, select the group. The on the Menu 
menu click Special Effects. 

When the project uses a toolbar, groups are also treated as commands since they will be rendered 
inside a toolbar and will have properties and behaviors very similar to those that only apply to a 
command. Continue to read the information about commands as it will become handy when using the 
toolbar feature of DHTML Menu Builder.

Related topics of interest: 

●     Commands
●     Anatomy of a Menu
●     Copying and Pasting Styles
●     Creating Toolbars
●     Incompatibilities and limitations
●     Style Dialogs
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 Commands

The commands are the basic components of your menus. They represent the options to display on the 
menus so the users can navigate to them. 

Commands usually perform some action when activated by a user. They may be activated by moving 
the  mouse over them, clicking the left mouse button on them,  by double-clicking them,  or by using 
combinations of the three available actions.

The type of actions a command can produce are countless, but DHTML Menu Builder provides an easy-
to-use interface to let you implement the most common:

●     Opening a page (following a link).
●     Opening another group (this is used to create submenus).
●     Opening a page in a new browser window.
●     Sending email.
●     Running a small piece of code written in JavaScript or VBScript.

There are two types of command components:

●     Commands 
These are items that receive and perform actions 

●     Separators 
These are simple lines used to separate commands inside a group. Separators do not receive or 
perform any kind of actions.

Commands are dual-state items and therefore have (for the most part) two settings:

●     Normal 
The settings in this mode apply when the command is not selected. 

●     Over 
The settings  in this mode apply or become active when the mouse is over the command. 

Below are all the possible attributes supported by a command. 

●     Color 
You can assign a background color and the color of the command's caption text. 
This setting supports two sets of two color definitions: background over and background 
normal; and text over and text normal.

●     Font 
This setting controls the font type, size, and style used to display the command's caption text. 
You can apply different font settings for the two modes, Normal and Over.
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●     Cursor 
One of five predefined cursors can be set to display when a user moves his mouse pointer over 
a command. 
To change a command's cursor, select the command. Then click Menu on the menu and click 
Cursor. 

●     Image 
Commands support three types of images, one  image to the left of the caption, one  image to 
the right of the caption, and one image  as the background. 
The two images that can be placed at the right and/or left of the commands support rollover 
effects. This means that you can change either image when the command is selected. 
Note: When using a background image, the color on the Normal state is not used and the 
command is rendered as transparent.

●     Selection Effects 
The settings in this section control the style and color of the bounding rectangle of the menu 
items.

●     Normal and Over 
These settings change the border of the commands when the mouse is  over (Over 
state) and not over (Normal state). 
You can choose from three different types of border effects: 

●     (none): No border will be drawn.
●     Raised: A border will be drawn which has the effect of raising the command 

towards you.
●     Sunken: A border will be drawn which has the effect of insetting the border into 

the group's background.
●     Double: Two two solid borders will be drawn around the command.
●     Bevel: Two borders – one raised and one sunken, each half the size of the total 

border width – will be drawn around the command.
You can also define the base color that will be used to draw these borders by using the 
color selection boxes next to the border style controls. 

●     Border Size 
This setting creates a border of the specified width around the commands. 

●     Horizontal and Vertical Margins 
These settings control the distance from the border of the commands to their contents.

Related topics of interest: 

●     Groups
●     Anatomy of a Menu
●     Copying and Pasting Styles
●     Creating Toolbars
●     Incompatibilities and limitations
●     Style Dialogs
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 Anatomy of a Menu

Because DHTML Menu Builder affords you control over may settings, each menu you create can appear 
and behave in different ways. 
The image below shows what settings affect what portions of the generated menu.

 

Use this link to get the DHTML Menu Builder project used to create the above menu sample. When the 
File Download dialog appears, click Open to load the project in DHTML Menu Builder. 

Related topics of interest:

●     Commands
●     Groups
●     Copying and Pasting Styles
●     Incompatibilities and limitations
●     Style Dialogs
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  Enhanced Map View

DHTML Menu Builder supports creating and 
implementing multiple toolbars within the same project 
and even the same web page.

As of version 4.0, the Toolbars Editor has been redesigned and the Map View has been enhanced to 
accommodate this feature. With the new Map View, you can manage and organize the menu items 
under multiple-toolbars projects.

To work in this mode you must select the Map tab from the mode tabs chooser. 

As you can see on the image, the Map View lets you see the toolbars as well as the groups included in 
these toolbars. There is also a (NoToolbar) item. Groups created in this section are groups that do not 
belong to any toolbar. With DHTML Menu Builder you can create a muti-purpose project where you can 
have some groups displayed under a toolbar and others attached to hotspots. These groups that are 
not included in any toolbar are displayed under the (No Toolbar) item. 

You can also create groups directly under a specific toolbar or you can even drag and drop items to 
move them from one toolbar to the other without having to use the Toolbars Editor dialog. 
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 Creating Toolbars

DHTML Menu Builder can create one or more menu bars from which the menus will be triggered. 
The type of menu bars created by DHTML Menu Builder can be used to for other functions in addition 
to displaying menus. That's why they're known as toolbars.

A project configured to use toolbars enables many features in DHTML Menu Builder that are disabled 
by default. For example, when enabling toolbar support, DHTML Menu Builder will let you change the 
colors, fonts, and images just as you normally do with commands. Notice that in each style dialog 
there's an additional tab called "Toolbar Item" which refers to the properties of the group's appearance 
when displayed on a toolbar. This is because DHTML Menu Builder will treat the groups as commands 
when it creates the toolbar. A group displayed on a toolbar is known as a toolbar item.

Enabling Toolbar support

The toolbar items are comprised of the groups that you set up in DHTML Menu Builder. Therefore, you 
have to create at least some of the groups prior to setting up the toolbar. Once the groups are created 
(at least by filling in the captions), you can configure the toolbar.

To configure DHTML Menu Builder so it creates a toolbar for you, click the Tools menu and select 
Toolbars Editor. Notice that, by default, DHTML Menu Builder will always create a Default toolbar 
tab. If you need more toolbars simply create them by clicking Add Toolbar ( ).

You can delete a toolbar using Delete Toolbar ( ) and rename a toolbar clicking Rename Toolbar 
( ). 
You can give your toolbars any name as this name is used only for your reference and does not affect 
the menus in any way.

Toolbars can also be created, renamed and deleted from the Map view. 
To create a new toolbar, click the Menu menu and select the Add Toolbar option. 
To rename it or delete it use the options from the Edit menu. Shortcuts that apply to groups and 
commands also apply to the toolbar items in the Map view, so for example, you could press the F2 key 
to rename a toolbar. Notice that the names of the toolbar are just for your reference; they have no 
effect over the generated menus.

Stacking Multiple Toolbars

The order in which the toolbars appears on the Map view determines their Z order. Toolbars that are 
listed first have a lower Z order while toolbars appearing at the end of the list have a higher Z order. 
This useful because if you have toolbars that are stacked one above the other, those with a higher Z 
order will appear above those with a lower Z order. The Z order can be easily changes by using the Up 
( ) and Down ( ) buttons from the toolbar.
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Configuring the Toolbars

You can select which groups will be 
displayed in a toolbar and in which 
order. To add groups to the selected 
toolbar click Add Group ( ). 
To remove a group from the toolbar, 
first select it and then click Delete 
Groups ( ).

When creating a toolbar that will be 
rendered horizontally, the first group in the list will be the group in the leftmost position. 
When creating a toolbar that will be rendered vertically, the first group in the list will be the group in 
the topmost position.

You can also add groups from the Map view: to add a new group to a toolbar, simply select the toolbar 
item on the Map view (or any other element that belongs to the desired toolbar) and select the Add 
Group option from the Menu menu. Then you can also use the Up ( ) and Down ( ) buttons to 
re-arrange your groups' order. The same applies to the commands: you can move commands up and 
down to change their order.

Both groups and commands can also be dragged and dropped. You can drag & drop groups between 
toolbars and you can drag & drop commands between groups. While dragging and dropping these 
items you can control the desired results by holding a combination of keys so instead of moving you 
the items are actually copied (cloned). For more information see the Enhanced Map View section.

Groups that have no commands can also be included in the toolbar. These kinds of groups, as well as 
those containing commands, can be used to open pages or execute a script when clicked. This is very 
useful in creating groups that do not have any menus but you still need them to be linked to some 
page.

Adding the Toolbar to your web site

By default, the HotSpots Editor is used to place the menus on the page. However, when you use the 
integrated toolbar support, the hotspots are created by DHTML Menu Builder and there's no need to 
use the separate HotSpots Editor unless you also want to use other elements on your page to trigger 
the menus.

All you need to do in order to incorporate the toolbar is:

●     Compile your project: To generate the JavaScript files containing all the information for both 
Page 20 of 181



your menus and the toolbar.
●     Install the Menus: this process adds the necessary code on your pages so when they are 

loaded by the browser, they call and prepare (initialize) the toolbar and the menus. To install 
the menus, click the Tools menu and then click Install Menus. 
Click here for a complete description on how the Install Menus tool works.

Using the Toolbar with frames

When you use the toolbar in a web site using frames, DHTML Menu Builder will automatically display 
the toolbar in the Target Document and the menus will be displayed on all the documents where you 
have installed the Frames Loader Code.

For more information see the Working with Frames section.
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 Setting the Toolbars Style

DHTML Menu Builder toolbars can be customized in many different ways.

The first setting is the kind of toolbar you want to generate:

●     Horizontal: span across your page with the groups displayed next to each other. This layout is 
ideal when you need a toolbar on top of your page.

●     Vertical: taller than wider with the groups displayed one beneath the other. The resulting 
toolbar is very narrow and usually placed at the left side of your page.

Other properties of the toolbar that you can set are the background color and image, separation 
between the toolbar items, and more. 
A more detailed explanation of all these settings can be found here.
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 Positioning the Toolbar

The alignment dialog in the Toolbars Editor is a very powerful tool which lets you take complete control 
over the follow parameters that affect the way the toolbar is positioned on the browser's window:

●     Anchor: This controls the fixed areas of the toolbar that will remain fixed regardless of the 
alignment setting

●     Alignment: This controls how the toolbar will be positioned relative to the browser's window
●     Position: And this controls where in the document the toolbar will be displayed

Being able to work with the above parameters on their own would be a quite complex and tedious 
task; this is why DHTML Menu Builder's Toolbar Positioning dialog provides a very easy to use interface 
where all you have to do is select from an alignment mode and if necessary set an offset.

The alignment control is divided in three modes:

●     Aligned and Anchored: 
In this mode you select the position from 9 available options. Each option will automatically 
align and anchor the toolbar to a specified location of the browser's window and maintain this 
setting even if the browser is resized.

For example, in the configuration shown here the 
toolbar will be anchored to top/right corners of the 
browser's window. 
This configuration will be maintained regardless of 
the window size and even if this size changes after 
the toolbar has been displayed. 
Please refer to the Positioning the menus tutorials 
for further information.

●     Custom and Fixed: 
In this mode the toolbar will be placed at a give x,y coordinate. 
The coordinates are provided in pixels and as in the previous mode are maintained regardless 
of the browser's window size.

In this sample the toolbar will be positioned at 
exactly 40 pixels from the left corner of the 
browser's window and 120 pixels from the top 
border. 
Please refer to the Positioning the menus 
tutorials for further information.

●     Attached to...: 
Sometimes, placing the toolbar so it flows with the rest of the contents of the page can be quite 
a difficult task. 
With this positioning option you can force the toolbar to follow an item in the HTML document 
so its position will depend on the position of the "attached to" object (which is usually an 
image) and the selected alignment. Page 23 of 181



Optionally you can force the image to inherit the size of the toolbar, this way, whatever content 
appears next to the image will appear to flow as if it was flowing around the toolbar. Note that 
this option is only available when the alignment has been set to Bottom/Left.

In this sample the 
toolbar will follow an 
object named 
"LeftImage" and it will 
be aligned in a way so 
the toolbar will always 
appear below the object 
and centrally aligned. 
Please refer to the 
Positioning the menus 
tutorials for further 
information. 
Click here to see a small 
online tutorial that 
explains in greater detail 
how this option can be 
used.

●     Free Flow...: 
All the previous positioning methods will create toolbars that appear floating above all the 
contents in a page. 
In this mode, the toolbar will not float, but instead, will be part of the HTML contents on the 
page allowing it to flow with the rest of the HTML content... just as if it were an image or a 
table or some other common HTML element. 
For this mode to work you need to add an ID to some enclosing element in the page. The 
toolbar will then look for that ID and will insert the toolbar inside the tag that contains that ID. 
A more detailed explanation of how this method works can be found on the Positioning the 
menus tutorial. 
 

Finally you can further tweak the position of the toolbar by specifying a custom offset. The offset is 
specified in pixels and its applied to the position of the toolbar after it has been calculated based on 
the selected alignment.

Related topics of interest: 

●     Positioning Dialog
●     Tutorial: Positioning the menus
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 Working With Styles

Because of the powerful features in DHTML Menu Builder, you can save a tremendous amount of time 
while you maintain the consistency of your menus.

Three specific features are the real timesavers: the Scope Selector control, the integrated clipboard 
and the preview page generator.

The integrated clipboard of DHTML Menu Builder is capable of globalizing the different style options 
from one item to a whole set of different items in the same project with just a couple of mouse clicks.

Then, you don't even need to go through the entire implementation process of placing the menus on a 
web page to see the final product. DHTML Menu Builder's integrated page generator can create a 
sample page for previewing. With this page, you can exercise your menus and determine what needs 
to be changed.

These features are detailed in the following sections:

●     Copying and Pasting Styles
●     The Scope Control Dialog
●     Previewing
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 Copying and Pasting Styles

One of the most exciting features in DHTML Menu Builder is its ability to let you propagate the style of 
one menu item over to another item or even a set of items.

DHTML Menu Builder implements an advanced clipboard that will let you copy one, several, or all the 
styles applied to one item and then paste them over a set of items of the same type.

To copy the style of one item, just select it. Then, click the Edit menu and then click Copy. You may 

also use the shortcut copy icon  on the DHTML Menu Builder toolbar. 
This will open the selective copy dialog. This dialog will show you all the settings you can copy from 
one item, organized hierarchically so they can be easily selected.

On the topmost level of the settings selection are the most global style settings, such as Color, Font, 
Image, etc. When you click on the small  sign beside each style,you can expand the style definition 
and see more detailed options about the selected style.

Let's say for example that you would like to copy the image style of one command over to the other. 
To do so, just select the command, click Edit, then click Copy and check the box next to Image style. 
Click OK to proceed. 
Now, select the command to which the style will be applied and click Edit and then Paste. You may 

also use the shortcut paste icon  on the DHTML Menu Builder toolbar. Finally, click OK to paste the 
Image style.

Now, let's suppose that you just want to copy the right hand 
image of a command that is activated when the mouse pointer 
pauses over the command. In other words, the command has 
been assigned to the Mouse Over event. 
To copy this image, just select the source command, click Edit, 
then Copy. Now, click on the   sign next to the Image style to 
reveal its settings. Then click the  sign next to the Right style 
property and check box next to the Over option.

To paste the selected style property, just select the target 
command and click the paste shortcut icon on the toolbar. When the dialog appears, accept the 
selection by clicking OK.

Selective Paste Dialog Options

When you want to propagate the style of one item over to several others, the paste dialog offers you 
several options to let you do a process that, if done by hand, would take hours of work.

The Selective Paste dialog has four main style propagation options:
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●     Paste to the ... : This option allows you to paste the selected style to the selected item of the 
same type.

●     Paste to all the commands under the .... group: This option allows you to paste the 
selected style to all the commands under the same group. Note that this option is only available 
when you have copied a style attribute from a command.

●     Paste to all ... : This option will paste the selected style to all the items on the project of the 
same type.

●     Advanced: This option allows you to explicitly select which items (of the same type) will 
receive the pasted style.
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 The Scope Selector

The Scope Selector is an advanced control that will let you apply the same style to a different set of 
menu items, all at the same time.

This control is located on all the style 
dialogs such as Color, Image, etcetera. The 
control is also accessible through the Edit-
>Paste dialog by clicking on the Advanced 
button. 
In the image at the right it is shown the 
Scope Selector for the command's Cursor 
dialog. By default, the Scope Selector will 
be set to apply the styles to the selected 
item only, however, there're several 
different options that can be selected to 
modify the scope of the style dialog:

●     When the selected item is a 
command:

●     Apply to all commands under 
the same group

●     Apply to all commands under 
the same toolbar

●     Apply to all commands in the 
project

●     And an Advanced option
●     When the selected item is a group:

●     Apply to all groups under the same toolbar
●     Apply to all groups in the project
●     And an Advanced option

The Advanced Scope Selector

Besides the standard "apply to" options available in the Scope Selector control there's the Advanced 
option which will let you choose a set of menu items based on different parameters.

The Advanced Items Section feature in DHTML Menu Builder uses a filter to let you select a set of 
items that match the filter settings and then apply the styles on the dialog to this specific set of items.

To learn more about the Advanced Items Selection feature refer to the dialog section of the 
documentation.
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 Previewing

The ability to Preview without having to compile the menus and upload the files to a web server is a 
valuable feature of DHTML Menu Builder.

You can preview your project at any time by just choosing Preview  from the Tools menu. 
Alternatively, you can click the Preview icon  on the Tools toolbar.

When DHTML Menu Builder previews a project, it actually compiles the menus (as if you were doing a 
full compilation) and displays the menus in a Web browser window. 
The fact that the preview window is actually a real Microsoft® Internet Explorer window means that 
what you see on the preview is what you will see when you compile and implement the menus on your 
web site.

If you have groups that are not part of a toolbar or a submenu of a group included in a toolbar, then 
the preview will automatically create buttons that act as hotspots. These will let you trigger the groups. 
These buttons will appear on the top left corner of the preview window and will display the name of 
your groups. If all your groups can be viewed and tested by using items on any of the toolbars, then 
the preview will not create any buttons. Note that these buttons will not be generated when you 
compile your project; they’re only being created in the preview so you can properly test all the groups 
on your project.

Preview Options

●     The internal preview window offers three main options to let you customize the way your 
preview looks:

●     Background Color: Use this option to change the background color of the preview 
window. This is useful if you want to see how your menus look like with a different 
background color.

●     Use Target Document: Check this option if you want to use your target document (as 
specified in your default configuration) as the preview template. 
Note that this option may not always be able to properly display your target document.

●     Encoding: Use this option to change the default character encoding. This is very useful if 
you're developing menus that use non standard ASCII characters and you want to be 
able to see these special characters. Such characters are often used by double-byte 
languages such as Chinese, Japanese, Arabic, etcetera.

●     By default, DHTML Menu Builder will use an internal instance of Internet Explorer to display 
your menus. You can also select alternate browser for previewing by clicking Tools->Set Default 
Browser

Live Preview

Yet one more preview option in DHTML Menu Builder is Live Preview. Appearing in many of the 
style dialogs and also in DHTML Menu Builder's main window, the live preview pane is extremely useful 
since it produces real-time previews of the selected item. Changes to settings of the selected item are 
instantly represented in the Live Preview pane.Page 29 of 181
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Note: Unlike the full preview option, the Live Preview pane does not use an instance of Microsoft 
Internet Explorer to create the preview. Therefore, the results are not 100% accurate and some 
differences may appear on the menus when rendered with a browser. Nevertheless, the Live Preview 
pane is a great time saver.

In order to save space, the Live Preview pane is small enough to represent a single command using a 
moderate font size. The Live Preview pane will also show you the parent group style of the selected 
command.

If the selected item is a group, the Live Preview will not render it unless you have enabled the option 
to create a toolbar. 
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 Presets

A preset is a specialized project configured to server as either a starting point to create a new project 
or to use it as a template to apply its styles to another project.

DHTML Menu Builder uses the Presets Manager dialog to let you work with any Presets that you may 
have installed. 
The Presets Manager offers options to let you organize your presets, create new projects from any 
available preset and it also let's you select which styles should be imported from a preset into an 
existing project.

Select which topic related to Presets would you like to know more about:

●     Creating Projects from a Preset
●     Applying the Styles from a Preset
●     Creating your own Presets
●     Sharing your Presets
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 Creating Projects from Presets

To create a new project from a Preset click on File->New->From Preset 
You will be presented with the Presets Manager dialog.

Select any preset from the list. When you select any preset a sample will be shown on the right pane 
allowing you see and test the menus created by this preset.

When you have found a preset that you like, click on the Load button. After the preset has been loaded 
into DHTML Menu Builder you should set up your project and then start changing the menu structure 
to fit your needs; that is, delete those menu items that you don't want and create the groups and 
commands that you need.

If, at any time, your project looses some of the styles originally provided by the Preset you can easily 
re-apply the lost styles using the Tools->Apply Style from Preset option. Click here to know more about 
this process.

Loading Presets from the Online Catalog

DHTML Menu Builder can connect to the Online Catalog and let you preview and download any presets 
available on the catalog that does not exist on your local library of presets.

To download the list of presets from the Online Catalog click File->New->From Preset and then 
click on the "Online Catalog" node. 
Depending on the number of available presets this process can take some time.

Click on one of the downloaded presets to see its preview. 
While a preset from the catalog is selected the Load button will be changed by a Download button. 
Clicking the Download button will download the preset to your local disk. The Presets Manager will 
then refresh your list of presets and automatically select the downloaded Preset.

The Download button will now be a Load button so clicking it will load the selected preset as a 
project in DHTML Menu Builder.

Related topics of interest: 

●     Applying the Styles from a Preset
●     Creating your own Presets
●     Sharing your Presets
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 Applying the Styles from a Preset

Presets can be used as templates so you can import any number of styles from them and apply them 
into the active project.

To select a preset as a template click Tools->Apply Style from Preset 
A special version of the Presets Manager dialog will be displayed.

First of all select the Preset from which you want to import the styles from. Once a Preset has been 
selected you will be able to select which components from the preset you want to import.

A Preset exposes several 
components, such as Toolbars, 
Groups, Commands, etc. 
Since a Preset can expose one or 
more component from the same 
class, (for example, a Preset may 
contain several Groups) you have the 
option to select from which of the 
groups you want to import the styles 
for the groups on your project. The 
same applies to all the components 
included in the select Preset. 
If necessary you can also choose to 
not to import any styles form a given 
component by selecting the "do not 
import" option.

After you have selected the components you want to use as a template you have the option to choose 
which styles you want to import from them. For example, you could choose to import the color of one 
of the commands in the preset but not the font type. See the image on the right where we have 
selected to only import the Color, Image and Margins from the "Shop Online" group.

This tools offers an additional component not available anywhere else on the program: the Cascading 
element. 
Cascading elements are commands in Preset designated to be used to display subgroups (or 
submenus). Because these type of commands usually have a slightly different style from the rest of the 
commands (such as an arrow image on the right) you can use this special element to import whatever 
special styles have been applied to the Preset to differentiate the commands used to display subgroups.

When you have finished selecting the components to use as templates and the styles that you want to 
import click on the Apply button.

You can use this tool over the same project as many times as you like allowing you to import different 
styles from different Presets.
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Related topics of interest: 

●     Creating Projects from a Preset
●     Creating your own Presets
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 Creating your own Presets

Since a Preset is nothing more than a specially packaged project you can create your own Presets from 
any Project.

This will let you re-use the styles on your projects and apply them to any new projects that you may 
create in the future. It can also let you create Presets so you can share them with your coworkers and 
friends.

The first step to create a new Preset is to load a Project into DHTML Menu Builder. Once a project has 
been loaded into the program simply click File->Save As Preset 
You will then be presented with the Preset Properties dialog. In this dialog will be able to set the title 
of your Preset, your name (under Author), a small description (optional) and a Category. By default 
DHTML Menu Builder provides a series of Categories for you to choose from, but if you wish you can 
create your own Categories by typing their name on the Category parameter textbox.

When done click the Save button.

DHTML Menu Builder will pack the Preset into a single file. The file name will be the same as the Title 
of the Preset and will have the .dpp extension and it will be located on the "Presets" folder which will 
be inside the folder where you installed DHTML Menu Builder. For example, if you chose to install 
DHTML Menu Builder to the default location, the Preset folder will be located in C:\Program Files
\DHTML Menu Builder\Presets\

Sharing Presets with other users

To share Preset you just have to send the Preset package via email, burn it into a CD or use any other 
type of media sharing. Just remember that Presets contain binary information and should be treated as 
binary files.

So, if you would like to share you latest Preset, locate it in the "Presets" folder and send it to the person
(s) you want to share it with.

Once the other person(s) receives the file they just need to double click it and the Preset will be 
automatically installed into their "Presets" folder so the next time they access the Presets Manager the 
Preset will be available.

You can also submit your Presets to the Presets Online Catalog so other can see them and download 
them! 
Click here to know more about this free service.
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Related topics of interest: 

●     Creating Projects from a Preset
●     Applying the Styles from a Preset
●     Sharing your Presets
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 Sharing your Presets

The Online Catalog of Presets

xFX JumpStart offers the Online Catalog of Presets as a free service to all registered users of DHTML 
Menu Builder. 
Although the catalog can be used by anyone with a copy of DHTML Menu Builder only registered users 
can contribute.

The Online Catalog of Presets is a repository of Presets submitted by users of DHTML Menu Builder 
from all over the world. 
You can browse the catalog by category, author, rating and number of downloads.

Click here to view the Online Catalog.

Submitting your own Presets

If you would like to submit a Preset that you have created simply click File->Submit Preset 
The Presets Manager window will be displayed. 
Select the preset that you want to submit and click the Submit button.

Note that by submitting a Preset you agree to the following terms:

●     Any user will be able to download and use your Preset on their own projects
●     Your name and the description for your Preset will be published on the Online Catalog
●     The rating assigned to your submitted Presets is based on the votes of the users and cannot be 

changed

Related topics of interest: 

●     Creating Projects from a Preset
●     Creating your own Presets
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 Implementing the Menus

DHTML Menu Builder offers several tools to help you add the code it creates to your web pages. 
The way you configure your project will determine the tool you use. Of course, you can always add the 
code to the pages manually. Understanding the manual process will allow you to understand how the 
automated tools work, what they do, and how you can detect and overcome possible conflicts and 
problems. 

The most common project setups are described below. Read each one to determine which tools you 
should use:

●     Without Frames 
If your project does not use frames, select the method below based on whether or not you are 
using a toolbar created by DHTML Menu Builder:

●     Using the toolbar created by DHTML Menu Builder 
If you're going to use the toolbar created by DHTML Menu Builder, all you need to do is 
place the code on the pages that will contain the menus. This is done using the Install 
Loader Code tool. (The loader code is the code that points to the JavaScript files created 
by DHTML Menu Builder.) 
To access this tool, click the Tools menu and then click Install Loader Code. 
The Install Loader Code dialog will allow you select which files from your root web 
should display the toolbar. You can select files one by one or add a whole directory at 
once. 
Click the Install button to start the process of placing the code on the pages.

●     Using a toolbar you have created 
When you're the one providing the toolbar, you will need to follow a different procedure:

●     Attach the trigger code: The trigger code is the code that is placed on your 
hotspots, and enabling them to respond to mouse actions and display the menus. 
The trigger code is attached using the HotSpots Editor. Since the HotSpots Editor 
automatically adds the loader code, using the Install Loader Code tool is 
not necessary with your own toolbar if you use the HotSpots Editor.

●     With frames 
If your project uses frames, there's an extra step that needs to be taken in order to add the 
menus to your web site. 
All the documents that are to be displayed in the same frame as the menus (not the hotspots) 
need to load a special file. 
To install the loader code for this special file, use the Install Frames Loader Code option 
found on the Tools menu. 
In the dialog, select all the documents on your web that will be displayed in the same frame as 
the menus. Click the Install button to copy the loader code to the pages. 
More information on the frames support offered by DHTML Menu Builder

Manually adding the menus

As you have seen above, there are several pieces of code that need to be present on your pages so 
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All the code that needs to be placed on your pages can be copied from a file that DHTML Menu Builder 
generates every time you compile your project. This file is located in the same directory as where the 
compiled JavaScript files are placed. The files is called hRef.txt. You can open this file using Notepad 
or any other text editor.

●     The loader code 
The loader code is the code that points to the JavaScript files created by DHTML Menu Builder. 
This code is always placed after the opening <body> tag of your HTML document. 
To add this code to your web page(s), simply copy it from the hRef.txt file and paste it into 
your document(s).

●     The trigger code 
This is the code that makes your hotspots active elements so they can react to the mouse 
actions and display the menus. 
This code is always placed in the anchor tag <a> of your hotspots. 
To add this code to your web page(s), simply copy it from the hRef.txt file and paste it into 
your document(s).

Related topics of interest: 

●     The HotSpots Editor
●     Working with Frames
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 Working with Frames

DHTML Menu Builder can add menus to sites that use frames in three ways:

1.  When your hotspots or toolbars are in the same frame as the menus 
This method is usually used when the frame containing the hotspots or the toolbar has enough 
space to display the menus. 
In this case there's no need to enable frames support. If the hotspots or the toolbar and the 
menus all work together in the same frame, you can leave the frames support turned off.

2.  When your hotspots or toolbars are in a different frame from the menus 
This method is used when the frame containing the hotspots or toolbar is not large enough to 
display the menus. 
Because there's no way to display any HTML element over the borders of two frames (a 
limitation of HTML, not DHTML Menu Builder), it is necessary to display the menus on another 
frame with enough space to hold them.

3.  When you have several toolbars located in different frames and the menus are 
displayed inside the same frame 
This is a special situation where you may have an horizontal toolbar in one frame, a vertical 
toolbar in another frame and then the menus from both toolbars are displayed inside the same 
main frame. 
If you are looking to create such type of project, read the following information and then follow 
the link at the bottom labeled "Advanced Frames Implementation".

It is important to remember that when you have enabled frames support, the Target 
Document setting in your configuration in the File->Project Properties dialog needs to point 
to the document where your hotspots are or where you want to display the toolbar.

To set up your project to support frames:

●     Open the Project Properties dialog
●     Click the Configurations tab
●     Click the Frames Support button
●     Check the Enable Frames Support checkbox

The Frames Document parameter must point to the document that 
defines your web site's frameset. 
When you have selected this document, DHTML Menu Builder will analyze 
it and retrieve all the different frame names.

●     Click the Target Document button

Using the browse button ( ) select the document where you want to 
display the toolbar
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After you have enabled frames support, DHTML Menu Builder will detect all the frames on your 
frameset document and you will be able to specify one of these frames as the target frame to open 
your links. To set the target frame for your menu items' links simply click on the Target Frame button 
( ).

Installing the Menus

The process to install the menus is always the same:

●     Compile the project (Tools->Compile)
●     And install the menus into your HTML documents (Tools->Install)

You will notice that the Install Menus dialog looks a bit different when the frames support has been 
enabled: there're two target panes (on the right) instead of one. 
This is because you now must distinguish between the document that will receive the toolbar and the 
documents that will display the menus.

The top/right pane must list the document where you want to install 
the toolbar. 
The bottom/right pane must list all the documents where you want to 
display the menus. 
 
If you're not using SSI (server side includes), templates or shared 
borders you should click on the Auto button to let DHTML Menu 
Builder fill the right panes automatically. 
Note that even after using the Auto button you should manually check 
that DHTML Menu Builder has correctly listed all the documents.

By default, DHTML Menu Builder will automatically detect the document that must be listed on the top/
right pane since this is the document defined by the Target Document from your configuration. 
However, DHTML Menu Builder not able to detect all the documents where you want to display the 
menus and you might need to add them yourself.

Let's consider this frame set:
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It is obvious that the documents displayed on the MAIN FRAME are the ones that will display the 
menus. So, you must make sure that the bottom/right pane of the Install Menus dialog contains all the 
documents from your web site that, at any time, will be displayed on the MAIN FRAME.

When you're done, simply click the Install button and DHTML Menu Builder will proceed to install 
your menus.

As mentioned earlier, DHTML Menu Builder will let you have several toolbars, each placed on different 
frames and display their menus inside the same main frame. 
Follow to the Advanced Frames Implementation section for more information about this method.

Related topics of interest: 

●     Advanced Frames Implementation
●     Working with IFRAMEs
●     Project Properties
●     Configurations
●     The HotSpots Editor

Page 42 of 181



 Working with IFRAMEs

Because IFRAMEs (Inline Frames) function very similarly to Frames, it is not difficult to work with them 
and DHTML Menu Builder.

It is highly recommended that you first read the information on how to work with standard frames.

The basic difference between the standard frames support and the IFRAMEs support provided by 
DHTML Menu Builder is that when using IFRAMEs, DHTML Menu Builder will provide an additional 
frame named "top". 
This frame refers to the document that contains all the IFRAMEs and should be the one pointed to by 
the "Frames Document" setting.

Knowing this, here are some common scenarios and a brief explanations on how DHTML Menu Builder 
should be set up:

●     The hotspots and the menus will be 
on the document that contains the 
IFRAMEs 
In this case, frames support must be 
disabled and the only document that 
requires the loader code is the container 
for the IFRAME.

●     The hotspots are on the Frames 
Document but the menus will be 
displayed inside an IFRAME 
This is very similar to the way the 
standard frames support works: the 
Loader Code is installed in the IFRAME 
container document and the Frames 
Loader Code is installed in all the 
documents displayed inside the IFRAME.

●     The hotspots and the menus will be displayed inside an IFRAME 
In this case frames support must be disabled and all the documents displayed inside the 
IFRAME must contain the Loader Code.

DHTML Menu Builder supports an infinite number of nested IFRAMEs, which means that you can have 
any number of IFRAMEs placed inside another IFRAME. 
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 Advanced Frames Implementation

Sometimes you may want to have several toolbars, each placed on different frames and then share the 
same main frame to display the menus.

For example, consider the scenario described in the Working with Frames section where you have 
three frames: 

But this time let's say that you want a toolbar in the top frame, 
a toolbar in the left frame and that both toolbars will pull-down 
menus that will appear inside the main frame.

To achieve this you will have to follow these simple steps:

Follow the instructions in the Working with Frames section as if 
you only had one toolbar. 
Configure each toolbar to use the "Free Flow" positioning 
technique. 
Compile the project and install the menus as directed in the 

Working with Frames section. 
Now, simply follow the instructions described in the Free Flow tutorial to designate the position of the 
toolbars. This will cause the toolbars to appear inside the tag corresponding to their ID regardless of 
the frame where this tag is located.

So, for example, if you add this code in the left frame:

<span id="dmbTB1ph"></span>

...the first toolbar in our project will be displayed in the left frame. Then, if we add this code in the top 
frame:

<span id="dmbTB2ph"></span>

...the second toolbar will appear in the top frame.

As you can see it is very important that you fully understand how to work with frames and how to use 
the Free Flow positioning method. This will ensure that you will have no problems implementing multi-
frames menus.
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Related topics of interest: 

●     Working with Frames
●     Using the Free Flow positioning method
●     Working with IFRAMEs
●     Project Properties
●     Configurations
●     The HotSpots Editor

Page 45 of 181



 Installing Menus

DHTML Menu Builder provides a series of tools to help you with the process of installing the menus on your web site.

The menus are stored in separate JavaScript files (with an extension of .js) which are generated when you compile your project (using 
the Tools->Compile option). After they are compiled, you have to add some special code (known as Loader Code) to your pages so 
that the browser can load these JavaScript files and display the menus.

Starting with version 4.0, DHTML Menu Builder offers a new tool called "Install Menus". It is found on the Tools menu.

The Install Menus tool is divided into two panes and three main sections:

●     The left pane (source files) is divided into
●     The directory structure of your web site
●     The files on the selected directory or folder

●     The right pane (selected files)
●     The selected files that will receive the menus (the list of files into which DHTML Menu Builder will copy the Loader 

Code )

The web's directory structure section 
 

In this section you will see the folders on your web site. 
Clicking any folder will display the list of HTML documents under the selected folder.

This section also lets you do global operations on the files under the selected folder. 
For example, to remove the menus from the files under a specific folder and all the 
folders inside it (if any) right click on the desired folder and select the Remove 
Menus option.

Another option would be to install the menus on all the documents under the 
selected folder. To do this right click the desired folder and select the Install 
Menus option.

You may also drag and drop folders to the pane on the right.

The files section 
 

 

This section shows the documents inside the selected folder. Besides the standard information for a document such as its name, size, 
and date of modification, this section also displays the type of loader code, if any, currently installed on each file.

The loader code is a series of JavaScript instructions used by the browser to locate the .js file(s) containing the menus. 
DHTML Menu Builder uses two different types of loader code depending on various settings:

●     Standard: used to load the main .js file which contains the information to display the toolbar (if any). On projects that don't 
use DHTML Menu Builder frames support, this loader code is also used to handle the menus.

●     Frames: used to load the menus on projects with frames support.

It is important to understand that the menus and the toolbar(s) are created, displayed, and handled differently. This is why the 
toolbar is stored in a separate file from the menus when using frames support: separate types of loader codes are required to load 
them both. Page 46 of 181



A file containing no loader code will be displayed in black, a file with the standard loader code in blue and a file with the frames loader 
code in green. Files displayed in light gray are documents that do not support any type of loader code.

Just as with the folders pane, you can perform several actions on the files displayed in the files pane. Right click a file and select a 
command from the context menu or simply drag and drop the file to one of the panes on the right. (Unless you have chosen Frames 
Support, there will only be one pane displayed on the right .)

The list of selected files to receive the menus

This pane displays the list of documents that will receive the loader code. For those documents 
that already contain the loader code, this display will be updated.

Clicking Install will result in the loader code being copied to the files displayed in this pane. 
As a result, the menus will be loaded into these documents when viewed from a browser.

To remove any file from this pane, right click it and select Remove From List. Note that if the 
selected file contains some loader code this option will not remove the code; the file will be 
simply removed from the list and will not be updated.

 

When working with frames

Remember, when frames support is enabled, DHTML Menu Builder splits the code that it 
generates into two sections, generating two files. Each of these sections/files must be copied 
into different web pages:

●     One section/file contains the code that 
handles the menus. If the project has 
been set up to use a toolbar, it will also 
contain the necessary information to 
render the toolbar.

●     The other section/file will contain the 
necessary code and information to 
display the menus.

As a result, when frames support is enabled, 
DHTML Menu Builder will split the right pane 
into two panes: one of them to receive the 
standard loader code and the other to receive 
the frames loader code.

The Auto button

Some times it can be difficult to determine which files should receive the loader code. When the frames support is enabled, it can be 
even more difficult to determine which files should receive which loader code.

To make this task as simple as possible, the Auto button automates this process by analyzing the default configuration, the menu 
items on the project, and the files on your web site. Performing over a hundred different tests, the Auto function will quickly 
determine which files require which loader code either because they don't have any or the type they have is outdated.

Although the process has been tested under many scenarios, it is not guaranteed that it will always detect the appropriate files. In 
some circumstances, it may even fail to provide any help at all. In this cases, add the files yourself. If the menus don't work, do the Page 47 of 181



following:

1.  analyze the results
2.  fix the problem
3.  remove the loader code from the whole web site

Repeat the operation and check the results again.

IMPORTANT: The Auto feature must not be used when the menus are going to be installed on a shared document (a document that 
is included by either your HTML authoring application or your web server). For example, if you plan on installing the menus into a 
Dreamweaver template, a FrontPage Shared Border, or an SSI document, then add this shared document yourself and do not use the 
Auto feature.
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 The HotSpots Editor

The HotSpots Editor is a tool integrated into DHTML Menu Builder that automates the process of 
implementing the menus in the files of your web site.

There are two basic steps performed by the HotSpots Editor:

●     The addition of the loader code 
The loader code is a series of JavaScript instructions used by the browser to locate the .js file(s) 
containing the menus. These files contain all the information about your menus plus the code 
necessary to make them work.

●     The addition of the trigger code 
The trigger code is the code that is placed on your hotspots, and enabling them to respond to 
mouse actions and display the menus. Without this code, your hotspots would not be able to 
detect when the mouse was over them.

To access the HotSpots Editor use either of following methods:

●     From the Tools menu, click HotSpots Editor
●     Click the HotSpots Editor icon  on the toolbar

Attaching the Groups

The process of attaching a group to a hotspot is very simple:

●     Select the hotspot from the list of available hotspots.
●     Select the group you want to attach from the list of groups.
●     Select the alignment.
●     If the selected hotspot is an image you will be able to change the image name. In order to 

enable support for auto-alignment of the menus, the images must have a name.
●     If the selected hotspot is text, the x,y (left and top) coordinates of where you want your menu 

to be displayed has to be specified. Since manually obtaining the best x,y position can be a 
tedious job, you can use the Active Text feature. This converts the text-based hotspot into 
an active element that supports auto-relative positioning, just like image-based hotspots do. 
This means that DHTML Menu Builder will be able to determine from the browser for the exact 
position of the hotspot when the web page is loaded and and automatically align the menu to 
the hotspot. This will occur accurately even if the position of the hotspot changes when the 
browser window is resized.

Repeat the above steps for all your groups.

Installing the loader code when using frames

If your hotspots are located in one frame and your menus are shown in another, each document 
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loaded in the frame where the menus are to be displayed must contain an additional loader code that 
loads a special file created by DHTML Menu Builder.

This is done using a tool integrated into DHTML Menu Builder. After you commit your changes in the 
HotSpots Editor, DHTML Menu Builder will automatically display a dialog to let you add files that need 
this loader code. You should add all the documents that will be displayed in the frame that displays the 
menus. After clicking the Install button DHTML Menu Builder will scan all the added files and add 
the required loader code.
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 Multiple Projects

DHTML Menu Builder offers two methods for implementing multiple navigation menus on the same 
page:

1.  By creating multiple toolbars on the same project
●     Pros: Easier to maintain and implement. Can control which toolbars to display using the 

Visibility Condition.
●     Cons: The compiled javascript files may become quite large. The use of the Visibility 

Condition requires a considerable JavaScript knowledge.
2.  By creating multiple projects and loading them simultaneously on the same page

●     Pros: A separate JavaScript file is created for each project so secondary JavaScript files 
will be quite small (around ~4KB each) . Also, only the necessary JavaScript files will be 
loaded when needed.

●     Cons: Complex installation process. Complex maintenance.

Before you decide to use one method or the other you should carefully consider the above mentioned 
pros and cons. The results are usually the same with both approaches, so try to determine which 
method will be more effective to meet your needs.

Note that the possibilities with DHTML Menu Builder are quite endless... and sharing multiple projects 
is one good example since you could even create a navigation system that uses both methods: sharing 
projects from multiple projects and controlling the visibility of some toolbars using the Visibility 
Condition.

You may also want to take a look at our online tutorial for implementing multiple menus available at: 
http://software.xfx.net/utilities/dmbuilder/tipstricks/multimenus/

Introduction

Merging projects is the process of installing menus from several projects into the same HTML 
document or documents. 
The way DHTML Menu Builder handles the use of multiple projects is by working with a master project 
and secondary projects (explained below). All the tools related to the compilation and implementation 
of the menus have been enhanced to be able to handle the use of multiple projects.

In this small how-to you will learn the basics for creating, preparing and implementing a navigation 
system that uses two toolbars from two different projects:

Creating the projects 
The first step is to create the projects that you want to merge together. Each project can have any 
number of toolbars and even completely different settings for their styles and special effects. However Page 51 of 181

http://software.xfx.net/utilities/dmbuilder/content/tipstricks/multimenus.php


there're several important rules that you must follow:

●     Frames are not supported when sharing projects. So none of the project should have the 
Frames Support enabled.

●     All projects must use the exact same type of configuration and their default configuration must 
be identical; that is, all the paths must point to the exact same location.

●     Each project must have a completely different name for their compiled files. To change the 
name of the compiled files click File->Project Properties->Advanced and use a different name 
for each one of the projects. 
If you don't change the names of the compiled files, DHTML Menu Builder will randomly select 
different file names when your compile.

●     If one or more secondary projects use toolbars, the master project must have, at least, one 
toolbar. If your master project does not require a toolbar then you can create an empty toolbar 
and then set its "Visibility Condition" to false to keep it hidden. To do so, click Menu->Add 
Toolbar to add the toolbar to the project, then, right click the toolbar and select 
Properties. Go to the Advanced tab and type this on the Visibility Condition 
textbox: return false;

●     Only projects created with version 4.1 (and above) can be used as secondary projects.

Defining a master project 
A master project is a project whose menus are always going to be available. This project is the one 
that will always be included into all the documents of your web site. This is the project containing all 
the code to handle its own menus and the menus from all the secondary projects.

Any project can be the master project, so always try to select the project whose menus are going to be 
common to all the sections of your web site.

Defining the secondary projects 
The secondary projects are those projects that are going to be combined with the master project.

To define the list of secondary projects click Tools->Secondary Projects 
Use the Add button to add projects and use the Delete button to remove projects from the list.

Press the OK button when you're done defining the list of secondary projects.

NOTE: Only projects created with DHTML Menu Builder 4.1 (or above) can be used as secondary 
projects.
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Compiling the projects 
To generate all the .js files for the master and secondary projects simply click Tools->Compile

NOTE: DHTML Menu Builder will automatically save your master project before starting the compilation 
process.

Installing the Menus 
To install the menus click Tools->Install Menus 
The Secondary Projects dialog will be displayed so you can select which combination of projects you 
want to install. 
When done click OK

Then you will see the usual "Install Menus" dialog. 
Select the documents that should receive the master project plus the selected secondary projects and 
click Install.

As you may have already guessed, you can repeat this process as many times as you like and each 
time selecting different sets of secondary projects. This will allow you to install different combinations 
of projects into different documents in your web site. 
 

Related topics of interest: 

●     Toolbars' Visibility Condition
●     Online Tutorial for implementing multiple menus
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 Tutorial

DHTML Menu Builder can be used to implement menus on a menubar that you create or by using the 
toolbar that the application creates. Since these two methods involve very different ways of using 
DHTML Menu Builder there are two separate tutorials.

You will use the menubar created by DHTML Menu Builder 
DHTML Menu Builder has the ability to create menubars (known as toolbars) giving you 
great flexibility on how you want to design and position them. In this tutorial you will 
learn the basics about creating a toolbar, but there's a lot more that can be done... such 
as creating multiple toolbars on the same project, specifying advanced alignment and 
positioning settings, etcetera. It will be up to you, after you take the tutorial, to discover 
all the wonders that you can create with DHTML Menu Builder...

This tutorial has two main sections:

1.  Creating and setting up your menus project
2.  Implementing the menus on your pages

Click here to start the tutorial.

You provide the menubar 
Under some circumstances you may want to create your own menubar. In this case you 
will have to attach the menu items in your project to the elements of your menubar. In 
this tutorial you will learn the basics of implementing a menu system whose menus are 
triggered from elements that already exist on your HTML documents.

This tutorial has three main sections:

1.  Creating the menubar
2.  Creating and setting up your menus project
3.  Implementing the menus on your menubar

Click here to start the tutorial.
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 The Tutorial - Using a Toolbar

Introduction

This tutorial will guide you through the complete process of creating working menus from scratch. 
If you would like to see how the menus and the project will look like at the end, download the zip file 
containing everything mentioned in this tutorial.

The Toolbar Feature

DHTML Menu Builder can create a toolbar from the group elements on your project so each group 
element is treated as an item inside the toolbar. From now on we will call these items "toolbar items".

Using the Toolbar feature is the easiest way of creating and implementing the menus on your web site. 
You don't have to concern yourself with issues like alignment, positioning, preparing and creating your 
hotspots because DHTML Menu Builder will do everything for you.

Starting the Tutorial

Before we begin working with DHTML Menu Builder you should have an HTML document already 
created that will ultimately display the menus.

Create a folder on your hard drive and call it DMB_Tutorial. (For example,  "c:\DMB_Tutorial
\")  Then create an empty HTML file in that folder and name it hotspots.htm. Later in the tutorial 
you will see how we will use this file as the receiver for the menus.

Now, create a folder called menus inside the c:\DMB_Tutorial\ folder. We will use this folder to 
store the JavaScript file generated by DHTML Menu Builder. 
Finally, create a folder called images  inside the c:\DMB_Tutorial\ folder. We will use this folder 
to store any images you menus may use.

Your folder structure should look something like the image below.
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Continue »
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 The Tutorial - Using a Toolbar

Setting up your menus project

Before you even start to create the menus you need to set up your project. Start DHTML 
Menu Builder and create a new empty project (File->New->Empty Project) .

The first step in setting up your project is to launch the Project Properties dialog. (If it 
doesn't appear automatically click File->Project Properties.)

Under the General tab you will see a setting called Project Name. 
Type here the name of your project; for this tutorial we will call it "Tutorial", so type it 
without the double quotes.

The most important part of this dialog is the Configurations tab. By default, DHTML Menu 
Builder will create an empty Configuration for you to fill in. 
Each configuration has two main sections, the Paths and the Target Document. In the 
Paths section you're telling DHTML Menu Builder where it should  store the files it 
creates. When working with toolbars on projects that do not require frames support, the 
Target Document section can be left empty.

The Local Path to the Root Web 
setting must point to the folder 
where your introductory HTML 
page is located. This file is usually 
named index.htm, index.html, or 
default.asp. 
(For this tutorial we'll use the 
folder where you saved the 
hotspots.htm file, c:
\DMB_Tutorial\) 
When setting up the Project 
Properties avoid typing the paths 
manually, instead, use the browse 
buttons ( ) provided in the 
dialog. As a rule, to avoid errors, 
it is always better to use the 
browse buttons in any part of 

DHTML Menu Builder.

The Folder to Store Compiled files must be a folder located inside the root web. It can be 
the same folder as the one above. 
However, for organizational purposes, create a new folder under c:\DMB_Tutorial\ 
and name it menus. Now use the browse button to select the c:\DMB_Tutorial
\menus\ folder.
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The Folder to Store the Images should point to the c:\DMB_Tutorial\images\ 
folder you created in the previous step of the tutorial.

 

 

Creating the menus

This is the fun part! 
Now we're going to create some sample menus that later we'll implement (or install) into 
the c:\DMB_Tutorial\hotspots.htm document.

So you have an idea, this is the structure of the menus we're going to create:

 Home   Products

Computers
High Performance
Gaming Systems
Desktop Systems
Computers for the Home

Accessories
Cables
Adapters
Connectors
Batteries

-------------
Catalog Index

Links

Search the Web 
xFX JumpStart

 

Contact Us

The top level items (in bold), Home, Products, Links, and Contact Us are groups (the 
toolbar items). The second level items (Search the Web, etc.) are the commands. The 
top level items (groups) will be used to create the toolbar.

So, let's start adding our menu items to the project!

First of all make sure you're in Map mode. In this 
mode DHTML Menu Builder displays all the menu 
items in a tree-like structure which makes it easier to 
work with the projects. You can switch modes using 
the modes tab on the main dialog as displayed on this image. Click here for a complete 
description about the Map View.
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If you would like to always use the Map mode by default click on Edit-
>Preferences and enable the option "Default to Map View"

You will see that when a new project is created DHTML Menu Builder displays two items: 
the "Default" toolbar and the "(NoToolbar)" item. 
The "Default" toolbar is an empty toolbar that DHTML Menu Builder creates every time 
you start a new project. 
The "(No Toolbar)" is a special item that holds all the menu items that are not associated 
to any toolbar. Groups under this special item will not be part of any toolbar.

The first thing to do is to rename the "Default" toolbar item. To do so select it and click 
Edit->Rename 
Now type "My Toolbar" (without the double quotes). Although this will not affect our 
project in any way it is a good idea to keep things organized.

To add a group to your project and under "My Toolbar", select the "My Toolbar" item and 
click Menu->Add Group 
DHTML Menu Builder will add a new group and wait for you to type its caption. The 
caption is the actual text that will be displayed when the menus are viewed from a 
browser.

Other ways to create a new group are: 
    - Press the F6 shortcut key 
    - Right click any toolbar item and click Add Group 
    - Click on the Add Group icon ( ) on the toolbar

Type Home and press the ENTER key on your keyboard.

Because this item does not contain any 
commands (menu items) select (none) from 
the Action Type parameter of the Over 
event.

Add the second group: Products 
You can use any of the above mentioned 
methods to create this new group. 
Now, we can add commands to this group.

 

Now we will add the commands to the "Products" group.

To add a command to the Products group, select it and click Menu->Add Command 
DHTML Menu Builder will add a new command and wait for you to type its caption. Type 
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Other ways to create a new command are: 
    - Press the F7 shortcut key 
    - Click on the Add Command icon ( ) on the toolbar

Create another command by 
clicking Menu->Add Command 
and name it "Accessories".

Now, let's add a special type of 
command, a separator. 
Separators are just horizontal 
lines (or vertical if the commands 
layout is set to horizontal) which 
can be used to separate 
commands inside the same group.

To add a separator click Menu->Add Separator 
Because separators do not display any text DHTML Menu Builder will not prompt you its 
caption. In fact, when a separator is selected, all the fields in the Command Properties 
are disabled.

Repeat the above process to add a command and name it "Catalog Index".

Now let's create a subgroup (or submenu) under the Computers command.

Subgroups (or submenus) are menu items that are displayed when a command 
is selected. This is very useful to keep your menus organized under main 
categories. This will not only keep your menus organized but will also make 
them a lot easier to use by your users (the visitors of your web site... the ones 
you are designing these menus for).

Select the Computers command and click Menu->Add SubGroup 
Add these commands to the subgroup:

●     High Performance
●     Gaming Systems
●     Desktop Systems<br><small>Computers for the Home</small>

Notice that the last command contains several HTML tags. The <br> tag is used to 
create multi-line captions and the <small> tag is used to reduce the size of the text. As 
you'll see in the Live Preview pane, DHTML Menu Builder has created a multi-line 
command. Multi-line commands are commands whose Caption contains two or more lines 
of text.
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You can use virtually any HTML tag on the menu item's caption. Although not all 
the tags will be properly rendered by the Live Preview, they will look just fine 
when you view your menus with a browser.

Let's now create another subgroup. 
Select the Accessories command and click Menu->Add SubGroup 
Add these commands to the subgroup:

●     Cables
●     Adapters
●     Connectors
●     Batteries

Finally let's add the last two toolbar items. 
Right click the "My Toolbar" item, click Add->Group and name the new item "Links". 
Add these commands to the Links group:

●     Search the Web
●     xFX JumpStart<sup>®</sup>

To add the ® symbol press and hold the ALT key and then type 0174 on your 
keypad.

Again, right click the "My Toolbar" item, click Add->Group and name the new item 
"Contact Us". 
Remember that since this group will not contain any commands (menu items) select 
(none) from the Action Type parameter of the Over event.

At this point DHTML Menu Builder's interface should look like this: 
(note that the names of the subgroups may vary)
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If you want to take a look at how your menus are working so far, click Tools-
>Preview.

Because the preview uses an instance of Internet Explorer what you see on the 
preview is what you will actually see when your menus are implemented on the 
pages of your web site.

Continue »Page 62 of 181



 The Tutorial - Using a Toolbar

Now, lets make our menus look cooler!

Select the first group, Home and click Menu->Color 
Click the Back Color button and type these values: FF, C8 and 40 for red, green and 
blue, respectively. (This will produce a "gold" color.) 
Set the border size to 2 and set the four border colors to 80, 40 and 40 for red, green 
and blue respectively.

Notice that the Color 
Picker dialog can let you 
re-select previously used 
colors quite easily. Since 
we have already use the 
80/40/40 color, to select 
it again we just have to 
click on the Used Colors 
button and select the 
color that we want to re-
use from the list.

We could also use the 
Picker button to pick the 
color from anywhere on 
the screen, so if the color 
that we're looking for is 

visible on the screen just 
click on the Picker button and click over the color. The Color Picker will read 
that color and make it available for you. 
You can also SHIFT+click the Picker button to use an alternate version of the 
picker.

You could also use the Windows button to access the common color picker 
used in most Windows applications.

Finally, the Color Picker dialog can display a slightly modified version of the 
selected color which is optimized for the web. A web optimized color is a color 
that is guaranteed to be properly displayed under any browser running under 
any platform. To select the WebSafe version of the selected color simply click 
on the small square besides the main color preview.

Remember that when using the Toolbar feature, a group has two "identities:" One is as 
a container for the commands it will display, so the background color you've just set 
changes the background color of the rectangle that encapsulates the commands. The 
other identity is as a toolbar item.

To change the colors of the Home toolbar 
item click the Toolbar Item tab. 
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Under the Normal state click Text 
Color and set the color values to: 00, 00 
and 00 (Black) 
Again, under the Normal state click 
Back Color and set the color values to: 
FF, C8 and 40.

Now, under the Mouse Over state click 
the Text Color button and set the color 
values to: FF, FF and FF. (white) 
Again, under the Mouse Over state click 

the Back Color button and set the color values to: 80, 40 and 40. (dark maroon)

Click OK to accept the changes and click OK again to close the Color dialog.

Click Menu->Font to set up the font that the toolbar item will use. 
Click the Change button under the Normal state and set the font to Tahoma, 12, Bold. 
Do the same for the Over state.

Click Menu->Margins and select 2 pixels for both the horizontal and vertical margins.

To set up the other groups with the same style settings, just make sure the Home group 
is selected and click Edit->Copy 
Check the Color, Font, Image and Margins checkboxes and click OK. 
Now click Edit->Paste, select the Paste to all groups option and click OK.

You have just applied the same style changes to all the groups in the project! (You 
probably don't believe that it could be done that easily, so go ahead--check for yourself!)

Now, let's change the style of the commands. 
The steps are very similar as changing the style of the groups.

Select the first command under the Products group, Computers, and click on Menu-
>Color 
For the Normal state click Reset. This will assign the default settings of the parent 
group's style. 
For the Mouse Over state, click Text Color. Then click Windows and select the 
White color. 
Now click Back Color and type 80, 40 and 40 for red, green and blue, respectively.

Now click Menu->Font to set the font type, size and style of the command's Caption. 
For both states select Tahoma for the font name, 11 for the size and Bold for the style.

Finally, to propagate the same style to all the commands, make sure the Computers 
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command is selected and click Edit->Copy 
Select the Font and Color checkboxes and click OK. 
Click Edit->Paste, choose Paste to all Commands and click OK.

This is now a good time to preview your project by clicking Tools->Preview. 
Verify that your menus look like the image below.

Because the Computers and Accessories commands are used to display another menu, 
it's a good idea to let the user know that by selecting them they will get another menu 
with more options. An easy and effective way is to add small arrows to the right of the 
Captions where this happens.

These arrows can be small images you have created with some graphic editor or you 
may use the two arrows below:

To save the above images, just right click on the image and select Save Picture 
As... from the context menu. You should save these images in the c:\DMB_Tutorial
\images\ folder.

Note that one arrow is black and the other is white. (The table cell background color was 
made black so that you can see the image. The image is smaller than the cell.) This is 

Page 65 of 181



because the menus we have created have a light background color when the items are 
not selected and a dark background color when selected. Therefore, we'll use the black 
arrow for the default state of the menus and the white for when the menus are selected. 
This way the arrow image will always contrast with the command's background color.

To set up the Computers 
command to use these arrow 
images, select the command and 
click Menu->Image 
Click Change for the Normal 
state, under the Right Image 
pane. 
Click From File... and select 
the black_arrow.gif image. 
Click Change of the Mouse 

Over state, under the Right 
Image pane. 
Click From File... and select the white_arrow.gif image.

Because the arrow images are a bit too large, set the size to 10, 10. 
By default you will notice that the size of the arrow images is set to 16,16 but this is too 
large and would affect the way our menus look by making the commands using these 
images too tall.

To apply these changes to the Accessories command, select the Computers 
command, click Edit->Copy and select the Image checkbox. 
Now select the Accessories command, click Edit->Paste, make sure the Paste 
to the command Accessories option is selected and click OK.

Finally, let's set up the style properties of the toolbar itself.

Click Tools->Toolbars Editor. 
You will notice that the Toolbars Editor dialog is divided into four sections, each 
represented by a tab at the bottom of the toolbar tab.

In the first section, General, we can perform the following actions:

●     Select which groups must be included into the toolbar
●     Select in which order we want our groups to be displayed on the toolbar

Click on the Appearance tab. 
Set the Toolbar Style parameter to Horizontal. 
Set the Border to 2 and its color to 80, 40, and 40 for red, green and blue respectively.  
Set the Separation to 2. Because you cannot create separators for the toolbar, we 
add some separation between each item to reveal the background color of the toolbar. 

Page 66 of 181



This will have a similar effect to that produced by a separator. 
Make sure the Force the same width on the groups is unchecked. This will 
allow each toolbar item to have each own width based on the length of its caption. 
Set the Back Color to the values 80, 40, and 40 for red, green and blue respectively.

Click on the Positioning tab. 
Click on the second dot from the first row. This will make the toolbar to appear centered 
on the page and auto center whenever the browser is resized. It will also keep it aligned 
to the top of the page. 
This section of the dialog provides many different options to let you control the position 
and alignment of your toolbar; more information about the different options can be 
found on the Positioning the Menus tutorial. 
Set the Spanning to (auto). This will keep the background of the toolbar to the same 
size as its contents. We do this because we don't want to have the background color of 
the toolbar to span across the width of the page.

Finally click OK to apply your changes.

This should be a good time to preview your project by clicking on Tools->Preview

Continue »
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 The Tutorial - Using a Toolbar

Implementing the menus into your menu bar

This is the final step in the process of creating a menus project.

This 
process is 
accomplished 
by using 
the 
Install 
Menus 
option 
under 
Tools. 
You will be 
presented 
with the 
Install 
Menus 
dialog, as 
displayed 
on the 
image at 
the left.

The Install 
Menus dialog is divided into two sections; the lefts section shows the folders and files on your web site 
and the right section shows the files that have been queued to receive the menus.

To include a file (or a folder) in the right pane simply drag it from the left pane and drop it over the 
right pane. You may also right click a file (or a folder) and select the Install Menus option.

When you have all the files on the right pane (since in this tutorial we're working with just one file we'll 
have just the hotspots.htm listed) click the Install button. This will process all the files in the right 
pane and install the menus in all of them.

You could also use the Auto button to add files to the right pane. The Auto button will perform a 
series of tests to determine which files require the Loader Code. The Loader Code is a piece of 
JavaScript code that instructs the browse to load the menus. Without this code the menus will not be 
displayed. Sometimes, on more complex projects, determining which files require this code can be a bit 
more complex and the Auto button is an excellent aid to let DHTML Menu Builder do this for us.

Now that our hotspots.htm file contains the Loader Code click on the Close button to close the 
Install Menus dialog.Page 68 of 181



The only thing left is to generate the JavaScript code for your menus. 
To do so, simply click on Tools->Compile.

Launch your file (hotspots.htm)  with your preferred browser and test the menus.

This concludes the basic "Using a Toolbar" tutorial. Yet, there're many more things you can do with 
DHTML Menu Builder. 
We now recommend you that you take the "Positioning the menus" tutorial to learn how to control the 
way your menus are positioned and aligned on your pages.
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 The Tutorial - Positioning the menus

Introduction

This tutorial will provide you with detailed information on how to control the position of the menus on 
your HTML documents under different scenarios.

Positioning the menus

DHTML Menu Builder supports two different positioning methods:

●     Free Flow: While in this mode the menus will be part of your HTML structure and will allow 
you place the menus anywhere on your page just as you do with images, tables, text , etc...

●     Floating: In this mode the menus will be floating elements, which means, that they will not 
take any space in the HTML structure of your documents and will float above everything on 
your page. Although this provides great versatility to the menus it makes it a little bit hard to 
control their position. 
Fortunately, DHTML Menu Builder provides a highly configurable interface and will let you have 
total control over the way your menus are positioned and aligned on your HTML documents.

Understating the Positioning dialog

The position of the menus is controlled through the Positioning tab of the Toolbars Editor 
dialog. Click Tools->Toolbars Editor->Positioning to access it.

A complete description of each one of the options in this dialog is provided here. In this tutorial we're 
not going to describe them, instead, we're going to present a series of scenarios and we're going to 
figure out the best way to use those controls to position our menus.

Here's a list of different scenarios that we're going to examine in this tutorial:

Free Flow mode:

●     Positioning the menus inside a table's cell

Floating mode:

●     A horizontal menu must be placed inside a horizontally aligned cell
●     A vertical menu must be placed inside a left aligned vertical cell
●     A vertical menu must be placed inside a cell where its left position can vary 

depending on the browser's window size
●     When the menus appear perfectly positioned under some browsers and not others

More information about the menus positioning can be found on our web site at the following resources:Page 70 of 181



●     Understanding the Positioning Controls
●     Placing a toolbar inside a table's cell using an image as a reference
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 The Tutorial - Positioning the menus

Scenario: Positioning the menus inside a table's cell (Free Flow mode)

The Free Flow mode is the easiest of the positioning options provided by DHTML Menu Builder but it 
requires that you add or modify the HTML code on your HTML documents. 
In this tutorial you will learn how to do this and insert the menus inside a table's cell.

Try to increase this window's size as much as possible to ensue that the sample layout is 
fully displayed.

Your browser does not support inline frames or is currently configured not to display inline frames. 

As you can see, this is a very common design for a simple web site and yet and we're going to place 
the menus in the left dark-blue cell.

Since we're going to use the Free Flow method we must configure our project so the toolbar uses this 
method as the positioning mecanism. 
Click the Continue button to learn how to do this. 
 

Continue »
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 The Tutorial - Positioning the menus

Scenario: Positioning the menus inside a table's cell (Free Flow mode)

To configure our 
project so the 
toolbar is 
positioned using 
the Free Flow 
mode we first click 
Tools-
>Toolbars 
Editor-

>Positioning 
and select the 
Free Flow 
option.

That's all that is 
required to 
configure the 
project.

You may have 
noticed that, 
besides the Free 
Flow option, 
appears a code 
between brackets; 
this is the ID that 
the toolbar will 
look for on your 
pages. 
An ID is 
something like a 

unique name that you can assign to an element on page to identify it and distinguish it from the rest. 
The ID displayed next to the Free Flow option is telling you the ID that you must use for this toolbar. If 
you have a project with more than one toolbar then each toolbar will have its own ID.

And how do we assign an ID to our cell? Its actually very easy and all you will need is a text editor or 
you could use your preferred HTML editor (such as FrontPage, Dreamweaver, etc...)

So, start you favorite editor for HTML documents and load the document containing the cell where you 
want the toolbar to appear. 
If you're using a visual editor such as FrontPage or Dreamweaver you will have to switch to "Code 
View" so you can see the HTML code. 
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Next, locate the HTML code for the cell. In our example, this is how the HTML code for the cell looks 
like:

<td align="left" 
valign="top" 
bgcolor="#004080" 
height="100%" 
nowrap></td>

Now, all you have to do is to add the "ID" parameter and assing it the ID that DHTML Menu Builder 
generated for your toolbar: dmbTB1ph. When done, the code for your cell will look like this:

<td align="left" 
valign="top" 
bgcolor="#004080" 
height="100%" 
nowrap 
id="dmbTB1ph"></
td>

Notice that we have highlighted the changes in bold/red text. That's it... that's all that is required to 
assign an ID to a cell. 
Now, when you view your menus using a browser the menus will look for the dmbTB1ph ID and will 
position themselves inside whatever tag contains the ID.

Below you can see how the sample looks like after we have added the ID parameter to our cell.

Try to increase this window's size as much as possible to ensue that the sample layout is 
fully displayed.

Your browser does not support inline frames or is currently configured not to display inline frames. 

The great advantage of this method is that the toolbar will flow with the cell's size, alignment and all 
its parameters in general. This means that if you ever change your design layout, as long as you keep 
the cell's ID, the toolbar will reposition itself inside the cell... automatically. 
 

This concludes this tutorial. Click here to return the "Positioning the menus" tutorial index.
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 The Tutorial - Positioning the menus

Scenario: A horizontal menu must be placed inside a horizontal cell (Floating mode)

Let's consider this page layout where we have an image (perhaps, the logo of our company), a cell and 
then another cell with the HTML content.

Try to increase this window's size as much as possible to ensue that the sample layout is 
fully displayed.

Your browser does not support inline frames or is currently configured not to display inline frames. 

As you can see, this is a very common design for a simple web site and yet, placing the menus at the 
correct spot (inside the dark blue cell) can be quite tricky.

First of all we need to define the properties of our design. The two most important things to consider 
here are:

1.  The layout is centered in the page. This means that as the browser window is resized, the 
content will remain centered.

2.  The position of the dark blue cell is constant in respect to the top, which means that it will 
preserve that same distance to the top regardless of the browser size.

Click the continue button below to look at how a simple menu would look like if it was implemented in 
the above design without changing any of the default positioning settings. 
You must keep in mind that every new toolbar that you create in DHTML Menu Builder will be placed, 
by default, horizontally centered and at the top. 
 

Continue »
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 The Tutorial - Positioning the menus

Scenario: A horizontal menu must be placed inside a horizontal cell (Floating Mode)

Here's how a menu would look if we implemented it without changing any of the default positioning 
settings:

Your browser does not support inline frames or is currently configured not to display inline frames. 

As you can see, the menus almost look right. Horizontally, they're centered but they are at the top of 
the page so all we need to do is move them down until they appear right above the dark blue cell. 
To do this we're going to use the Vertical Offset parameter found in the Tools->Toolbars 
Editor->Positioning dialog, as show in this screenshot.

Highlighted in red 
you will see the 
settings that we 
need to adjust.

First of all its the 
alignment. By 
selecting the 
second dot from 
the first row we're 
configuring the 
toolbar to appear 
horizontally 
centered and at 
the very top of 
the page.

Next, we use the 
Vertical 
Offset to push 
the toolbar 
downwards. In 
this case we have 
chosen an offset 
of 100 pixels. 
This means that 
the toolbar will 
appear 
horizontally 
centered, just as 
our HTML content 

and 100 pixels from the top of the page.
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Don't worry if you don't know the exact offset that you need to apply on your particular case. Try with 
a small value and compile the project. Then, test your settings by viewing the menus on your browser. 
Either increase or reduce the value you have used and recompile until you obtain the results that 
you're looking for.

 
Here's how the menus will look like after applying the above mentioned settings:

 Your browser does not support inline frames or is currently configured not to display inline frames. 

As we expected, the menus still maintain their horizontal centered position but have been pushed 100 
pixels from the top placing them exactly above the dark blue area.

This concludes this tutorial. Click here to return the "Positioning the menus" tutorial index.
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 The Tutorial - Positioning the menus

Scenario: A vertical menu must be placed inside a vertical cell (Floating mode)

Let's consider this page layout where we have an image (perhaps, the logo of our company), two cells 
underneath where the leftmost one will contain our menus and the other our HTML contents.

Try to increase this window's size as much as possible to ensue that the sample layout is 
fully displayed.

Your browser does not support inline frames or is currently configured not to display inline frames. 

As you can see, this is a very common design for a simple web site and yet, placing the menus at the 
correct spot (inside the dark blue cell) can be quite tricky.

First of all we need to define the properties of our design. The two most important things to consider 
here are:

1.  The layout is aligned to the left of the page (although the contents frame is of a variable 
width). This means that regardless of the browser window is size the dark blue cell will remain 
in the exact same position.

2.  The position of the dark blue cell is constant in respect to the top and the left borders of the 
browser window.

Click the continue button below to look at how a simple menu would look like if it was implemented in 
the above design without changing any of the default positioning settings. 
You must keep in mind that every new toolbar that you create in DHTML Menu Builder will be placed, 
by default, horizontally centered and at the top.

 

Continue »
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 The Tutorial - Positioning the menus

Scenario: A vertical menu must be placed inside a vertical cell (Floating mode)

As expected, the toolbar appears horizontally centered and at the top of the page, as it can be seen 
here:

Your browser does not support inline frames or is currently configured not to display inline frames. 

The first thing we should try to do is to bring the toolbar down so it appears at the same level as the 
dark blue cell. To do this we're going to use the Vertical Offset parameter of the Tools-
>Toolbars Editor->Positioning dialog. 
Setting the Vertical Offset parameter to 97 pixels, as shown in the image below, will move the toolbar 
97 pixels from the top, placing at the exact same level as the dark blue cell.

Don't worry if you don't know the exact 
offset that you need to apply on your 
particular case. Try with a small value and 
compile the project. Then, test your settings 
by viewing the menus on your browser. 
Either increase or reduce the value you have 
used and recompile until you obtain the 
results that you're looking for.

In the sample below you can see how the 
toolbar has moved downwards, placing it 
exactly at the dark blue cell level.

Now we'll need to move the toolbar to the 
left so it appears over the dark blue cell. 
There're several ways in which we can do 
this. 
Click the Continue button below to continue 
to the next step where this process is better 

explained. 

Your browser does not support inline frames or is currently configured not to display inline frames. 

 
 

Continue »
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Scenario: A vertical menu must be placed inside a vertical cell (Floating mode)

Since the dark blue cell will maintain its 
distance to the left border of the browser 
window, regardless of its size, we can safely 
say that if we anchor the toolbar to left it will 
appear over the cell.

To change the alignment we go to the 
Tools->Toolbars Editor-
>Positioning dialog and change the 
Alignment parameter by selecting the first 
dot. The first dot means: anchor the toolbar 
to the left border of the browser window and 
at the top.

What will happen is that now, the toolbar, 
instead of appearing horizontally centered it 
will appear anchored to the left border of the 
browser window.

Let's see what happens if we configure our project by changing the alignment option as shown in the 
image at the left.

Well, as expected, the toolbar has moved to the left and will preserve that position regardless of the 
browser's window size. Notice how it is still preserving the 97 pixels vertical offset that we applied 
earlier.

 [THIS LIVE SAMPLE MUST BE VIEWED FROM WITHIN DHTML MENU BUILDER'S HELP VIEWER]

 

Now, all that we need to do is to apply an Horizontal Offset to move the toolbar towards the 
right so it is placed, exactly, above the dark blue cell. 
To do this we click Tools->Toolbars Editor->Positioning and enter a 31 in the Horizontal 
Offset textbox... and here's how the final product looks:

Your browser does not support inline frames or is currently configured not to display inline frames. 

Don't worry if you don't know the exact offset that you need to apply on your particular case. Try with 
a small value and compile the project. Then, test your settings by viewing the menus on your browser. 
Either increase or reduce the value you have used and recompile until you obtain the results that 
you're looking for.
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This concludes this tutorial. Click here to return the "Positioning the menus" tutorial index.
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 The Tutorial - Positioning the menus

Scenario: A vertical menu must be placed inside a cell where its left position can vary 
depending on the browser's window size (Floating mode)

Let's consider this page layout where we have an image (perhaps, the logo of our company), two cells 
underneath where the leftmost one will contain our menus and the other our HTML contents.

Try to increase this window's size as much as possible to ensue that the sample layout is 
fully displayed.

Your browser does not support inline frames or is currently configured not to display inline frames. 

As you can see, this is a very common design for a simple web site and yet, placing the menus at the 
correct spot (inside the dark blue cell) can be quite tricky.

First of all we need to define the properties of our design. There's only one important thing to consider 
here:

1.  The layout is centered which makes all the cells in the table change their horizontal position as 
the browser window is resized.

This makes positioning the menus quite difficult because the position of the cell where we want to 
place the menus will vary depending on the browser's window size and we will never know, for sure, 
what offset to apply. In this case DHTML Menu Builder provides a method for attaching the menus to 
an element inside that cell. This will cause the menus to follow this element (which is usually an 
image) thus guaranteeing that the menus are always properly positioned.

Click the continue button to learn how to attach a toolbar to an image so it follows the image position. 
 

Continue »
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 The Tutorial - Positioning the menus

Scenario: A vertical menu must be placed inside a cell where its left position can vary 
depending on the browser's window size (Floating mode)

Although the menus could be attached to almost any element in a page we recommend using an 
image as this will ensure that this technique works under any of the supported browsers. 
So, in order to avoid the image from showing up on our page we're going to use a transparent image; 
the best way to create a small transparent image is to use any graphics editor and create an 100% 
transparent GIF image. Click here to download an image that can be used for this purpose.

The next step is to insert the image in the cell. Here's a sample piece of code that can be used to 
insert the image:

<img border="0" src="blank.gif" width="1" height="1">

Now, we must give the image a name. It must be a unique name which DHTML Menu Builder will use 
to reference this image. In this tutorial we'll call our reference image "RefImage" and here's the code 
that needs to be inserted into the <img> tag to give our image a name:

<img border="0" src="blank.gif" width="1" height="1" 
name="RegImage">

Now, although you can't see it (and that's the idea) this sample below already contains our image 
inside the dark blue cell. 
In this tutorial we're using an image that cannot be seen but, in fact, you could use any image that 
already exists on your HTML documents as a reference image. For example, if our HTML layout would 
have had the logo in the upper corner of the dark blue cell we could have used the logo as the 
reference image.

Your browser does not support inline frames or is currently configured not to display inline frames. 

The final step is to configure 
our toolbar so its position is 
not fixed and, instead, it 
attaches itself to our image. 
To do this we go to the 
Tools->Toolbars 
Editor->Positioning 
dialog and set the 
Alignment setting to the 
Attached To option.

Inside the Object Name 
textbox we type the name of 
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 The Tutorial - Positioning the menus

Scenario: A vertical menu must be placed inside a cell where its left position can vary 
depending on the browser's window size (Floating Mode)

Notice how in the sample below the 
toolbar is now properly positioned, 
much closer to the top border of the 
dark blue cell.

This was achieved by applying a 
negative vertical offset to the 
toolbar. The offset used is -14 
pixels, which means, that the toolbar 
now appears 14 pixels above its 
original position.

Although this is a very easy method 
for positioning the menus we 
recommend that you avoid its use 
whenever possible. Here're some 
important issues that you must know 

when this method is used:

●     When using a reference image the menus will remain hidden until the whole page has finished 
loading. When using any of the other positioning/alignment settings, the menus will be among 
the first things displayed on a page while its loading. When using this method, the menus must 
wait for the whole page to finish loading before the menus can be displayed. 
 

●     Under Mozilla-based browsers the toolbar will not re-adjust its position as smoothly as it wil do 
it under Internet Explorer or when using some of the other positioning methods. 
 

●     Working with a hidden image can be tricky. Sometimes it might look as if the menus were not 
being positioned correctly when, in fact, it could be the image that it is not placed where you 
expected it to be. When this happens, try to temporarily change the transparent GIF image for 
an image that you can easily see and work with.

 

Your browser does not support inline frames or is currently configured not to display inline frames. 
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 The Tutorial - Positioning the menus

Scenario: When the menus appear perfectly positioned under some browsers and not 
others (Floating mode)

The previous tutorials about positioning only showed how the toolbars appeared under Internet 
Explorer. If you try one of the samples in the tutorials using FireFox or any other browser you would 
notice that the toolbars appear out of position... or do they?

This image on the 
left shows how the 
menus look under 
FireFox. They 
appear to be out of 
position but the 
fact is that its the 
HTML content that 
is out of position. If 
you compared the 
position of the 
menus under 
Internet Explorer 
and FireFox you 
would see that they 
are being displayed 
at exactly the same 
spot but the HTML 
content is actually 
being rendered 
lower under 
FireFox. Why? Well, 
because on this 
particular sample 
we didn't specify a 

top margin for the BODY and Internet Explorer uses a different "default top margin" than other 
browsers.

Although most modern browsers try to follow the W3C standards as close as possible to render HTML 
content there're a lot of situations where one browser will interpret the standards in a different way 
resulting in the HTML layout being rendered differently.

So, how do we deal with this problem? Well, DHTML Menu Builder provides what's known as custom 
offsets. A custom offset is a highly configurable condition that, when met, will apply a specific offset. 
Since we designed the menus to work under Internet Explorer we could create a condition that when a 
Mozilla-based browser is detected we apply a different vertical offset so the toolbar appears properly 
positioned.
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Here's how this is done:

Click File->Project Properties->Advanced->Menus Offset. Click the Advanced button.

You will now see the Custom Offsets dialog. 
This dialog lists all the custom offsets that we 
have defined. DHTML Menu Builder supports an 
unlimited number of custom offsets.

Click the Add button to add a new custom 
offset.

The Custom Offsets dialog may look complex 
and overwhelming but it's actually very easy to 
use. The dialog is divided in to two main 

sections: the Assistant and the Advanced.

Most of the offset differences produced by the way HTML content is rendered under different browsers 
can be resolved by using the Assistant. The Assistant is the default section of the Custom Offset dialog 
and requires no knowledge of javascript programming and yet it is powerful enough to cover almost all 
circumstances and conditions where a custom offset might be needed.

Let's take a look at all the sections in the Custom Offsets dialog to get familiarized with them: 
 

Description

In this area you can type a small 
description for the custom offset. This 
is very useful so you know what this 

custom offset is used for in case you need to revise your project in the future.

For the purposes of this tutorial we're going to write this description: Fix offset for 
Mozilla-based browsers

Condition
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This is the section where you define the condition. The condition is very important 
because it will determine when DHTML Menu Builder will apply the offset.

The section is divided into three main sub-conditions:

●     The Platform: The platform defines the operating system under which the 
browser is being used and can have the following values:

- Any: The condition will be applied regardless of the operating system being 
used to view the menus. 
- Windows: The condition will be applied when the browser is running under 
Windows. 
- Linux: The condition will be applied when the browser is running under Linux. 
- Mac: The condition will be applied when the browser is running under Mac.

Although most cross-platform browsers, such as Mozilla, will render the content 
exactly the same under any platform there're situations where the HTML layout 
will present some minor variations depending on the platform under which the 
browser is being used. This is specially true for Internet Explorer 5 for Mac.

In this tutorial we'll leave the condition as "Any" because we want to apply the 
same offset regardless of the platform being used. 
 

●     The Browser: Here we can choose for which browser we want to apply the 
offset. Notice that for each browser we have three options: "The browser", "Not 
the browser" and "Ignore the browser". 
This is so because DHTML Menu Builder will treat some browsers as a 
combination of browsers. Don't worry if you feel confused... there is a very good 
reason for this. 
For example, DHTML Menu Builder will "see" Safari as combination of three 
browsers: Internet Explorer, Mozilla-based and Opera. So, if you want to apply a 
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custom offset for Internet Explorer that doesn't affect other browsers you should 
setup your browser condition as seen in this image:

So why does DHTML Menu Builder sees browsers as a combination of other 
browsers? To simplify the code... but, don't worry too much about it. Just keep in 
mind that if you create a custom offset for browser A and you see the offset 
affecting browser B and you did not want this to happen then simply use the 
"Not the browser" option for browser B.

Here's a list of browser grouping performed by DHTML Menu Builder:

●     Internet Explorer is seen as a unique browser
●     Netscape 4 is seen as a unique browser
●     Mozilla-based browsers (such as FireFox and Netscape 6 and 7) are seen 

as a combination of Mozilla-based browsers and Internet Explorer
●     Opera is seen as a combination of Internet Explorer, Mozilla-based and 

Opera
●     Safari (and/or Konqueror) is seen as a combination of Internet Explorer, 

Mozilla-based, Opera and Safari

Since in this tutorial we want our offset to affect all Mozilla-based browsers we 
are going to select the "Mozilla-based" option. According to the browser grouping 
table above, any offset applied to Mozilla-based browsers will also affect Safari 
and Opera. This is a good thing because the offset that you see on the 
screenshot at the top of this page is also occurring under these browsers so with 
just one custom offset we're going to solve a positioning problem under three 
different browsers! 
 

●     The Browser Version: Here you can restrict the condition so it is only applied 
under a specific version of the selected browser. This is particularly useful to 
accommodate issues with very old browsers. For example, suppose that you have 
discovered that there's an offset issue with Netscape 6, but the menus appear 
properly positioned under all other versions of Netscape; in this case you would 
select the Mozilla-based option and then set the browser version to "Less than 7", 
which means that the condition will be applied to all Mozilla-based browsers 
whose version is below 7.0:
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You're probably asking yourself, and why not use "Equal to 6"? Because using 
"Less than 7" is a more generic condition and it will let us target versions 6.0, 
6.1, 6.2 and so on...

For the purposes of this tutorial we're going to leave the browser version 
condition as "Any" because we want to target all browser versions.

Offsets

Here is where you specify the offset that will be applied when the Condition that you 
have defined is met. 
As you can see you can specify offsets for all the elements in a project: toolbars, root 
level menus and submenus.

For the purposes of this tutorial we only need to specify a small vertical offset for the 
toolbar. Notice that we have specified 10 pixels vertically.

This means that when DHTML Menu Builder detects that the menus are being viewed by 
any Mozilla-based browser, the toolbar will be pushed 10 pixels down.

The result can be seen on this screenshot of the FireFox browser:
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This concludes this tutorial. Click here to return the "Positioning the menus" tutorial index.

 

Page 90 of 181



 The Tutorial - Using HotSpots

Introduction

This tutorial will guide you through the complete process of creating working menus from scratch. 
If you would like to see how the menus, the menu bar and the project will look like at the end,  
download the ZIP file containing everything mentioned on this tutorial.

Creating the menu bar

There are many ways you can create a menu bar. 
The easiest and most recommended is to create a set of images to serve as hotspots and place them 
inside the cells of a table. Although you could use text instead of images, the use of images is highly 
recommended. Also, it is very important that you create independent images for each one of your 
hotspots, instead of creating a single image and then using an image map to define hotspots; the 
HotSpots Editor (a tool you will learn to use in this tutorial) does not support image maps.

You can use any graphic application to create your hotspot images. Some sample images are provided 
here for you to use with this tutorial:

To save the above images, just right click on the image and choose Save Picture As... from the 
context menu.

Open your preferred HTML editing application and create a table with 4 cells in it. Since you will be 
using images, you can choose any type of alignment for the table and its cells. Then place one image 
inside each cell. 
When using images as the hotspots, the menus created with DHTML Menu Builder will be able to auto-
align to the images dynamically regardless of the size of the browser or the screen resolution. This is 
why it is so important the use images instead of text-based hotspots.

Now you must prepare these images so they are ready to accept the menus. Only those images that 
will display menus need to be prepared. In this tutorial we'll create two menus, one for the Products 
hotspot and another for the Links hotspot.

The first step is to convert the images into hyperlinks. Each HTML editing application has its own way 
to create a hyperlink, so you should consult your program's documentation to see how to do this. 
When you're asked for the target link to which the hyperlink should (the pound or hash sign, typically 
found above the number 3 on the keyboard) point to, type: # (the pound or hash sign, typically found 
above the number 3 on the keyboard). 
The pound symbol (#) means that this hyperlink will point to itself. This is known as a "null-hyperlink." 
(If you want to do this by hand, enclose the image's code in <a> </a> tags:
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 The Tutorial - Using HotSpots

Setting up your menus project

Before you even start to create the menus you need to set up your project. Start DHTML Menu Builder 
and create a new empty project (File->New) .

The first step in setting up your project is to launch the Project Properties dialog. (If it doesn't appear 
automatically click File->Project Properties.)

The most important part of this dialog is the Configurations tab. By default, DHTML Menu Builder will 
create an empty Configuration for you to fill in.

Every configuration has two main sections, the Paths and the HotSpots Editor. In the Paths section 
you're telling DHTML Menu Builder where it must store (save) the files it creates. In the Target 
Document section you will tell DHTML Menu Builder which of the files in your web contains the 
hotspots.

The Local Path to the Root Web setting must 
point to the folder where you introductory 
HTML page is located. This file is usually named 
index.html or default.asp. 
For this tutorial we'll use the folder where you 
saved the hotspots.htm file, c:\DMB_Tutorial\

When setting up the Project Properties avoid 
typing the paths manually, instead, use the 
browse buttons provided in the dialog.

The Folder to Store Compiled files must be a 
folder located inside the root web or it can be 
the same as well. 
For organization purposes, create a new folder 
under the c:\DMB_Tutorial\ and name it 
menus. Now use the browse button to select 

the c:\DMB_Tutorial\menus\ folder.

The Folder to Store the Images should point to the c:\DMB_Tutorial\images\ folder you created 
in the previous step of the tutorial.

Now click on the Target Menu button. 
Again, avoid typing it manually and use the browse button to locate the hotspots.htm file which is 
stored in the c:\DMB_Tutorial\ folder.

Finally click on Tools->Toolbars Editor and click on the Delete Toolbar button ( ) to avoid Page 92 of 181
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DHTML Menu Builder from creating a toolbar.

Creating the menus

This is the fun part! 
Now we're going to create some sample menus that later we'll attach to the hotspots we created in the 
first step of the tutorial.

So you can have an idea, this is the 
structure of the menus for the 
Products hotspot that we're going to 
create. 
This is composed by a main group 
(also known as a root level menu) 
where two of its commands will 
display a submenu with more options.

Menus are composed of two basic 
elements: groups and commands, so 
let's start creating the first group:

Before you add the first group it is recommended that you switch to 
the "Normal" view. By default DHTML Menu Builder will start in 
"Map" mode; in this mode DHTML Menu Builder modifies the way 
the menu items are presented in the project so its easier to work 
with toolbars. Since we're not going to use toolbars it is highly recommended that you switch to the 
"Normal" mode. To do so simply click on the "Normal" tab.

To add a group to your project select Menu->Add Group 
DHTML Menu Builder will add a new group and wait for you to give it a name 
Type grpProducts and press the ENTER key on your keyboard.

Now, we can add commands to this group.

To add a command select Menu->Add Command 
DHTML Menu Builder will add a new command and wait for you to give it a name 
Type Computers and press ENTER.

When creating new items, DHTML Menu Builder will fill the Caption property automatically for you. If 
required you can later change both, the name and the Caption to whatever you need to. You should 
note though that DHTML Menu Builder will automatically remove invalid characters from the item name 
and change them for an underscore (_).

Create another command by selecting Menu-
>Add Command and name it Accessories.
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Now, let's add a special type of command, a 
separator. 
Separators are just horizontal lines which can 
be used to separate commands inside the same 
group.

To add a separator select Menu->Add 
Separator 
Separators do not have names so DHTML Menu Builder will not prompt you for one.

Repeat the above process to add a command and add a new one and name it Catalog_Index. Note 
that DHTML Menu Builder will automatically remove the space in the name and rename your entry to 
Catalog_Index.

Submenus, under DHTML Menu Builder are just normal groups, so to create the two submenus shown 
in the picture above we'll follow the exact same steps.

Create a new group and name it grpComputers and add these commands to it: High Performance, 
Gaming Systems and Desktop / Home. 
Now let's do something interesting with the last command, Desktop / Home:

Select the command and change its Caption to: Computers for the Home<br>Desktop 
Systems 
As you'll see in the Live Preview pane, DHTML Menu Builder has created a multi-line command. Multi-
line commands are commands whose Caption contains two or more lines of text. 
To create a new line simply use the <br> HTML code.

Now let's create the second group that will be used as a submenu by the Accessories command. 
Just follow the above instructions and name the new group grpAccessories. 
Add these commands to the group: Cables, Adapters, Connectors and Batteries.

Now, we need to configure the Computers 
and Accessories commands so when 
selected they display the two respective 
submenus we just created. 
Let's configure the Computers command first. 
Select the Computers command and click on 
the Over tab of the Actions pane. 
Select the Display SubMenu action type and 
select the grpComputers group from the 

Target Group list.

What you just did is tell DHTML Menu Builder that when the mouse passes over the Computers 
command, the grpComputers should be displayed.
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Repeat the same process to set up the Accessories command so when the mouse passes over it, 
the grpAccessories group is displayed.

To take a look at how your menus are working so far, select Tools->Preview and DHTML Menu 
Builder will generate a sample toolbar for you so you can test your project.

To finish the project let's create the last menu: Links. 
Repeat what you have learned and create a group named grpLinks and add two commands to it: 
Search the Web and xFX JumpStart.

When creating the Desktop / Home command you learned that you can use HTML tags to format the 
Caption of your menu items. 
DHTML Menu Builder supports the use of almost any tag in the Caption, but not all of those tags will 
be properly rendered by the Live Preview. 
An example is the use of the <sup></sup> tags. These tags will make the text enclosed text appear 
superscripted. 
To demonstrate this feature select the xFX JumpStart command you have just created and add the 
® symbol at the end, so the Caption looks like this: xFX JumpStart® 
NOTE: To add the ® symbol press and hold the ALT key and then type 0174 on your keypad. 
Now, enclose the ® symbol with the <sup> tag, so the Caption looks like this: xFX 
JumpStart<sup>®</sup>

If you take a look at the Live Preview you will notice that the results are not what we expected, but if 
you preview your menus you will see that the real preview does render the tags and makes the 
Caption look like this: xFX JumpStart®

Now, lets make our menus look cooler!

Select the first group, grpProducts and click Menu->Color 
Click the Back Color button and type these values: FF, C8 and 40 for red, green and blue 
respectively. 
Set the border size to 2 and set the four border colors to 80, 40 and 40 for red, green and blue 
respectively. 
Click on the OK button to close and commit the Color dialog.

Click on Menu->Margins and select 2 pixels for both the horizontal and vertical margins.

To set up the other groups with the same style settings, just make sure the prgProducts group is 
selected and click on Edit->Copy 
Check the Color, Image and Margins checkboxes and click OK. 
Now select Edit->Paste, choose the Paste to all groups option and click OK.

As easy as that you have just applied the same style changes to all the groups in the project!

Page 95 of 181



Now, let's change the style of the commands. 
The steps are very similar as changing the style 
of the groups.

Select the first command under the 
grpProducts group, Computers, and click 
on Menu->Color 
For the Normal state click on the Reset 
button. This will assign the default settings 
based on the parent group's style. 
For the Mouse Over state, click on the Text 
Color button, the click on Windows and select 
the White color. Now click on the Back Color 
button and type 80, 40 and 40 for red, green 
and blue respectively.

Now click on Menu->Font to set the font type, 
size and style of the command's Caption. 
For both states select Tahoma for the font type, 
11 for the size and Bold for the style.

Finally, to propagate the same style to all the 
commands, make sure the Computers 
command is selected and click on Edit->Copy 
Select the Font and Color checkboxes and click OK. 
Click Edit->Paste, choose the Paste to all Commands and click OK.

This should be a good time to preview your project.

Because the Computers and Accessories commands are used to display another menu, is a good idea 
to let the user know that by selecting them they will get another menu with more options. An easy and 
effective way is to add small arrows to the right of the commands' Caption.

These arrows can be small images you have created with some graphic editor or you may use the two 
arrows bellow:

To save the above images, just right click on the image and select Save Picture As... from the 
context menu.

Note that one arrow is black and the other is white. This is because the menus we have created have a 
light background color when the items are not selected and a dark background color when selected. 
Then, we'll use the black arrow for the default state of the menus and the white for when the menus 
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are selected. This way the arrow image will always contrast with the command's background color.

You should save these images in the c:\DMB_Tutorial\images\ folder.

To set up the Computers command to use 
these arrow images, select the command and 
click Menu->Image 
Click on the Change button of the Normal 
state, under the Right Image pane. 
Click on the From File... button and select 
the black_arrow.gif image. 
Click on the Change button of the Mouse 
Over state, under the Right Image pane. 
Click on the From File... button and select 

the white_arrow.gif image.

To apply these changes to the Accessories command, select the Computers command, click on 
Edit->Copy and check the Image checkbox. 
Now select the Accessories command, click on Edit->Paste, make sure the Paste to the 
command Accessories option is selected and click OK.

 

Continue »
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 The Tutorial - Using HotSpots

Implementing the menus into your menu bar

This is the final step in the process of creating a menus project. 
In this step you will combine the menu bar on your HTML page with the menus you've just created.

This process is accomplished by using the HotSpots Editor. 
The HotSpots Editor will load the file containing your hotspots (this is the Target Document defined on 
your configuration) so you can attach each group on your project to its corresponding hotspot.

To start the HotSpots Editor select Tools->HotSpots Editor.

The HotSpots Editor will 
present all the hyperlinks 
found on the page. These are 
listed under the Available 
HotSpots list. 
Each entry contains the HTML 
code for each of the 
hyperlinks. When these 
hyperlinks are images, a 
preview of the image (if 
available) will be displayed in 
the image preview pane, on 
the bottom right corner.

Locate the Products hotspot 
and select it. 
Now select from the list 
groups (available under the 
Attached Group list) the 

group named grpProducts. 
As soon as you select a group from this list, the group gets attached to the selected hotspot.

Because the hotspot is an image, DHTML Menu Builder will allow you type a name for the selected 
image. This is very important because without this name, the menus will not be able to auto-align to 
the hotspots that triggers them.

So, click on the Image Name textbox and type: HSproducts. 
The name of the image can be anything, but remember that whatever name you choose it should be a 
unique name. This means that this same name cannot be used by another image or any other element 
in your page.

Now select the links hotspot and then select the grpLinks group from the list of groups. 
In the Image Name field type: HSlinksPage 98 of 181



Finally, click on the Install button to commit your changes and the HotSpots Editor will add all the 
necessary code to your page so the hotspots can react to the mouse actions and display the menus 
you created.

Now the only thing left is to generate the JavaScript code for your menus. 
To do so, simply click on Tools->Compile.

Launch your file with your preferred browser and test the menus.

Final Notes

There's no need to repeat this process (running the HotSpots Editor) unless:

●     You add more groups on your project that need to be attached to a new hotspot
●     You rename one of the groups
●     You change the alignment of one of your groups

If you just make style changes to the items on your project, recompiling (Tools->Compile) will be 
enough.
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 More Help

The following sections cover additional information about the use of DHTML Menu Builder.

●     Tutorial 
A step by step guide that goes from the very basics of preparing your web site to the final 
process of implementing your menus into your pages.

●     Online Samples 
A list of real-life samples by users who have already used DHTML Menu Builder in their own 
web sites.

●    Dialogs 
A full description of the functions and options on most of the dialogs available in DHTML Menu 
Builder.

●     Frequently Asked Questions 
A list of the most commonly asked questions and their answers.

●     Tips & Tricks 
Useful information to improve productivity while working with DHTML Menu Builder.

●     Public Forum 
A place to look for answers and post your own questions, comments, and suggestions.
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 Incompatibilities and limitations of different browsers and platforms

DHTML Menu Builder is optimized to take advantage of the great features in Microsoft's Internet 
Explorer 5.5 and above. 
Because of Netscape Navigator 4's lack of support for standardized features, some features in DHTML 
Menu Builder can't be reproduced on other browsers.

Known Style Issues 
Below you will find a list of style settings supported by DHTML Menu Builder that will not work on some 
browsers:

●     Drop shadow and transparency effects (Special Effects Dialog) 
These effects use some proprietary features of Internet Explorer 5.5 and 6.0, so no other 
browser will be able to render them.

●     Raised and sunken borders effects on the commands selections (Special Effects 
Dialog) 
These features are not available under Netscape Navigator 4 
The resulting menus will not show the effect

●     Colored borders (Special Effects Dialog) 
These features are not available under Netscape Navigator 4 
The resulting menus will not show the effect

●     Cursors (Cursor Dialog) 
The support for different cursors is not available under Navigator 4

●     Border Colors (Group Color and Group Image Dialog) 
Netscape Navigator 4 does not support different color borders in the same group. 
The resulting menus will show a single colored border taken from the setting for the left corner.

●     Context Menus  (Special Effects Dialog) 
With the exception of Internet Explorer 4 and Opera, this feature is only supported on browsers 
running under Windows .

●     Fonts (Fonts Dialog) 
Under Netscape Navigator 4, fonts may appear slightly smaller, especially when using the 
Macintosh or Linux versions.

Netscape Navigator 4 specific issues 
Netscape Navigator 4 is a very old browser with a huge list of problems. Here you will find some of the 
most common issues that directly affect the menus created by DHTML Menu Builder.

●     Resizing the browser window crashes Navigator or makes the menus inoperable 
This is probably the most annoying bug in Navigator 4. 
The reason this happens is outside the scope of this document, but if you would like more 
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information, including possible solutions, try these links:
●     The Web Wise Wizard
●     Dynamic HTML Lab (hierMenus columns)
●     Navigator 3.0+ bug list (including the resize bug)

●     Font sizes under Netscape Navigator appear smaller 
Because of a bug in Netscape Navigator 4 that forces us not to use in-line style sheet 
declarations, DHTML Menu Builder converts font sizes from pixels to points. Under some font 
types and sizes, this may cause the fonts under Navigator to appear slightly smaller than in 
other browsers. 
The cause of this problem is outside the scope of this document, but if you would like more 
information try these links:

●     PHP Builder (Mail Archive)
●     DejaNews Search Query (+ttyle)

●     Browser crashes when loading a page with the menus 
Under some circumstances, very old versions of Netscape Navigator 4 (specifically 4.05 and 
4.08) will crash when loading the menus. 
This is usually caused by the combination of the menus' scripts plus some other non-Navigator 
compatible code in your page, including scripts generated by other programs. 
You should try previewing the menus directly in Navigator. Alternatively, you might try creating 
a page that contains ONLY the menus and the toolbar. If the browser does not crash with the 
menus alone, then your pages contain some code that, when used in conjunction with the 
DHTML Menu Builder menus, crashes the browser.

Opera 5 and 6 specific issues 
This excellent browser has made its way from a purely simple browser to an almost perfect browser in 
terms of compatibility with the W3C standards.

●     Commands do get selected when hovering over them 
Opera 5 still has no support for several DOM properties that are required for menus 
highlighting. As a result only the images change when you move your mouse over menu items.

●     Resizing the browser window crashes Opera or makes the menus inoperable 
Just as Navigator 4, Opera 5 may crash or improperly render the menus after resizing the 
browser window.
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 DEMO version limitations

The only limitation in the DEMO version of DHTML Menu Builder 3.5 (and above) is that the links will 
not work. 
You will be able to compile your project, implement it on your web site, test it to see how it looks and 
behaves but the links on the menus will not respond.

As soon as you register your copy of DHTML Menu Builder and recompile your project, the links on the 
menus will work.
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 Importing Projects from older versions (2.8 or older)

One of the most significant improvements in DHTML Menu Builder Version 3.0 is the ability to generate 
paths that work under any scenario in which they are implemented. This can be done by virtue of the 
new Configurations section under Project Properties.

All of the information about the items in your project is strongly tied to the selected default 
configuration. If you are going to use a project from an older version (2.8 or older) of DHTML Menu 
Builder with a version 3.0 or newer, you must create this information contained in the default 
configuration.

When importing a project created with an older version of DHTML Menu Builder, the following 
three things will be done automatically: 

●     Fix Groups  Over action 
Version 2 Groups had just one action: Display the Group. Version 3 Groups, on the other hand, 
can have multiple actions.

●     Fix Commands URL 
Under earlier versions of DHTML Menu Builder, URLs could be root-level links or relative links. 
Under DHTML Menu Builder 3.0, all of the command links must be fully qualified URLs. The 
program will try to add the fully qualified path to each page based on the imported information 
about your server's root folder. 
You should check each and every link after you import a project. Those  links found to be faulty 
can be fixed by clicking on the browse button under the selected action and then re-selecting 
the target document.

●     Create a default configuration 
The single configuration that existed under earlier versions will be imported as the default local 
configuration under DHTML Menu Builder 3.

After importing an older project, you must check the settings of the default configuration to ensure 
that the setup is correct.

Here are more issues you should check if your projects use any of the features mentioned below:

●     Opening links in new windows 
If your project used JavaScript commands to open a link in a new window, it is recommended 
that you convert these actions and use the integrated support to open new windows. To do the 
conversion, just follow these simple steps: 

●     Change the action type to Open URL in new window
●     Remove all the JavaScript code from the URL and just leave the target link
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●     Click the New Window Settings button  and set up your new window settings

●     AddIns 
None of the AddIns that were developed for previous versions of DHTML Menu Builder will work 
in version 3. However, the following AddIns are now default behaviors, so these AddIns are no 
longer needed:

●     Auto Relative Positioning
●     AutoClose Timer
●     Context Menus
●     For Images Only

It is very important to understand that after saving an imported project under DHTML Menu Builder 3, 
you will not be able to re-open this same project under any previous version, so you should always 
make backup copies of your projects.
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 Registration Information

This document will guide you in the process of getting DHTML Menu Builder registered

Entering your registration information

Your registration information is composed of three pieces of data:

●     Your order number 
The order number is the number of your receipt. This number can be located in the 
confirmation email you received when you purchased DHTML Menu Builder. 
This is not a serial number or unlock code from a previous release. It is the number of your 
invoice (and receipt).

●     Your name 
This the name of registrant. This is the name of the person who purchased DHTML Menu 
Builder and it was used in the purchase form. 
Make sure you type the name exactly as it appears in your purchase receipt.

●     Your company's name 
This the company to whom the program has been registered to. 
If you did not include any company name in the purchase form, leave this field empty. 
Make sure you type the company's name exactly as it appears in your purchase receipt.

Validating the information

Before clicking on the Validate button, make sure you're connected to the Internet. 
The Validation process will submit the information you've typed to our servers and will be matched to 
our purchase database.

If the match is successful you will be able to click on the Register button. Doing so will restart DHTML 
Menu Builder in registered mode.

If the match is not successful in can be caused by one of the following reasons:

●     The server was unavailable because of Internet connection problems or the server was 
protecting itself because of too many registration requests. The server can only handle 2000 
registration requests per second.

●     The information you provided was not correct. Verify and double check that all the fields 
contain the correct information exactly as it appears on your purchase receipt.

●     Your order has not been processed yet. If you have just purchased DHTML Menu Builder, allow 
one to 3 hours for your information to become available on our databases and the validation 
can be performed.

●     You're not using the latest version of DHTML Menu Builder. The Validation process also checks 
that you're using the latest version of DHTML Menu Builder. If our servers detect that your 
version is outdated, it will notify DHTML Menu Builder and deny the registration process. 
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NOTE: Even if doing a Help->Upgrade reports that you have the latest version, you should re-
download and re-install DHTML Menu Builder if you're instructed by the Validation process to do 
so.

Registering DHTML Menu Builder

Once the validation process has been successfully completed click on the Register button and DHTML 
Menu Builder will restart itself as a registered program.

Related topics of interest: 

●     Privacy Information
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 Privacy Information

Registration Process

When registering DHTML Menu Builder, the information you type in the Registration dialog is submitted 
to our validation server for verification. No other information is submitted. 
The validation server is located on our offices and only the president of the company has access to this 
information.

Information we keep in our databases

The information in our databases includes:

●     Registrant's name, company, phone, and address
●     Number of copies purchased

A copy of your registration details is also maintained at RegNet's and RegNOW servers, as they process 
our transactions. If you used a credit card to purchase DHTML Menu Builder, the credit card 
information is never revealed to us. For more information on RegNet's and RegNOW's privacy 
statement use the appropriate links below:

●     RegNet's Privacy Policy
●     RegNOW's Privacy Statement

Access to your personal details (except for the credit card number) is only available to the president of 
xFX JumpStart.

Information transferred over the Internet when you click the Validate button

The only information that is transmitted:

●     From DHTML Menu Builder to our validation server:
❍     Your Order Number, as typed in the Order Number field.
❍     Your Full Name, as typed in the User Name field.
❍     Your Company Name, as typed in the Company field.

●     From our validation server back to DHTML Menu Builder:
❍     A result indicating if the registration information is valid
❍     A server response based on the validation result. This data will never contain personal 

information, nor anything related to you personally, nor the details included in the 
purchase receipt used to validate the request.

xFX JumpStart's Privacy Policy

xFX JumpStart guarantees that the information on our databases is never used for any means other 
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Builder's Registration dialog.

This information will never be shared with other people, companies or organizations.

We understand your privacy and highly respect it.
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 What's New

20/Dec/2005

●     DHTML Menu Builder 4.10.005 is released 
●     Added support to import ROR files. 

The ROR format is a new proposal for a standard to describe web sites through the use 
of XML documents. 
To use this new feature just click File->New->Import from ROR file 
Please refer to the http://www.rorweb.com for further information about the ROR file 
format.

●     The frames support has been enhanced so you can now have multiple toolbars displayed 
in different frames and share the same main frame to display their menus! 
Refer to the Advanced Frames Implementation section for further information

●     The developers' edition DynAPI has been enhanced to better handle projects containing 
images in the menu items and separators in the groups.

●     Engine 2.5.005
●     This version contains many bug fixes and improvements; among them, the new loader 

code should now pass the most common W3C validation tests.

16/Oct/2005

●     DHTML Menu Builder 4.10.002 is released 
●     This is a maintenance release. This release contains lots of bug fixes reported by many 

DHTML Menu Builder users. The fixes include code fixes, for the code generated by 
DHTML Menu Builder, and fixes for the CollapsibleMenus and several other AddIns.

●     The developers' edition also includes many code fixes as well as support for two new 
functions that allow the creation and removal of toolbars (dmbAPI_addToolbar and 
dmbAPI_removeToolbar).

●     The loader code has also been improved so it now passes most of the W3C validation 
checks.

●     Engine 2.5.002
●     This is a maintenance release.

12/Aug/2005

●     DHTML Menu Builder 4.10.001 is released 
●     This is a maintenance release.
●     ort for the CollapsibleMenus AddIn to specify which toolbar should be converted into a 

collapsible menu.
●     Engine 2.5.001

●     Fixed bug that caused javascript errors with some submenu alignments. 
●     Fixed bug that caused the menus to fail to work properly under Netscape 4.
●     Improved support for the new Free Flow positioning method which resolves some issues 

with Internet Explorer.
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27/Jun/2005

●     DHTML Menu Builder 4.10.000 is released 
●     Fixed bugs that affected some old browsers such as Safari 1.0 and 1.1 and Internet 

Explorer 5.0.
●     Fixed bug that, with certain projects, caused the program to crash when accessing the 

Toolbars Editor dialog.
●     Added support to position the menus relatively so they take space and flow along with 

the rest of the HTML contents in the page (see the new "Free Flow" alignment option in 
the Tools->Toolbars Editor->Positioning dialog). 
A new tutorial has also been included to provide further information about this new 
positioning technique. Click Help->Tutorials->Positioning the menus to access it.

●     Improved the stability and performance of the CollapsibleMenus and pShowMenu AddIns.
●     Added support for the CollapsibleMenus AddIn to specify which toolbar should be 

converted into a collapsible menu.
●     Engine 2.5.000

●     Several minor bugs have been corrected in the DynAPI (developers' edition only).
●     The code used to generate the toolbars has been considerably enhanced so it is now 

smaller and faster.

23/May/2005

●     DHTML Menu Builder 4.9.018 is released 
●     Fixed bug that could case the status bar to display the incorrect information about the 

selected item.
●     Fixed some minor bugs in the CollapsibleMenus AddIn.
●     Added support to exclude menu items (commands, separators, groups and toolbars) 

from being compiled.
●     Added a "Compile" button in the Tools->Toolbars Editor dialog. 

Items excluded from the compilation will appear in a different color and the color can be 
customized through the Edit->Preferences->Display dialog.

●     Engine 2.4.018
●     The DynAPI has been enhanced so it now runs even faster. Preliminary support for 

images has been added; further information, samples and detailed documentation about 
the image-related functions will be made available on the next release.

●     Several tests have been performed to ensure full compatibility with the new Netscape 
8.0 browser and the latest release of Safari (included in Mac OS X 10.4/Tiger)

12/Apr/2005 
(never publicly released)

●     DHTML Menu Builder 4.9.017 is released 
●     This is a maintenance release.

●     Engine 2.4.017
●     This is a maintenance release.
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●     DHTML Menu Builder 4.9.016 is released 
●     Fixed several problems with he "Install Menus" dialog:

●     The splitters will no longer cause the contents of the different panes to get cut 
(no clipping).

●     The list of files can now be properly sorted by date and size.
●     The headers for the files list pane are now properly displayed (no clipping).

●     Fixed bug with the Menus Report tool as it wasn't properly calculating the time required 
to download the menus.

●     The HelpViewer application will now order search results correctly.
●     The "Selection Delay" parameter will now work on toolbar items as well allowing the 

mouse to pass above both toolbar items and commands without changing the selection.
●     Added support to compress the generated .js files using GZIP. This can reduce the .js 

files by up to a third of their original size.
●     Included three new AddIns:

●     RollerEffect2: This is a new version of the RollerEffect which implements a 
smoother animation.

●     HideOnClick: Projects compiled with this AddIn will only hide the menus when 
clicking on the document.

●     HideOnMouseOut: This AddIn will hide the menus when the mouse is moved 
away from them. This is the standard behavior of the menus but this AddIn will 
allow the menus to maintain this behavior even when the mouse pointer position 
is unknown; a common situation is when the menus appear over an iframe.

●     Engine 2.4.016
●     Fixed javascript error that occurred under Netscape 4 when a menu was about to be 

hidden.
●     Projects that use AddIns that implement substitution of complete functions (such as the 

CollapsibleMenus AddIn) will now produce much smaller javascript files.

16/Feb/2005

●     DHTML Menu Builder 4.9.015 is released 
●     Fixed problem with the File->Project Properties->Global Settings->Extended Features 

dialog that could cause the "Properties" button for the "In-Global Scrolling" option to 
disappear.

●     Fixed problem that could cause older projects to be incorrectly upgraded.
●     Fixed bug that could cause some colors to become corrupted due to a mathematical 

miscalculation.
●     The DynAPI for the developers' edition was been updated to version 1.0f which 

implements two new technologies, buffering and rendering on demand. This provides a 
huge performance boost allowing the DynAPI to run up to 55% faster.

●     The CollapsibleMenus AddIn has been updated again to fix some minor issues.
●     Engine 2.4.015

●     Fixed some problems that affected the developers' edition.
●     Fixed problem with the Transparency support for FireFox that affected DHTML Menu 

Builder when running under an operating system where the decimal separator is a "," 
instead of a "."
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27/Jan/2005

●     DHTML Menu Builder 4.9.014 is released 
●     Fixed some minor issues.
●     Added four new tutorials that explain how to position the menus under several 

scenarios. These tutorials can be accessed by clicking Help->Tutorials->Positioning the 
menus

●     The CollapsibleMenus AddIn has also been updated.
●     Engine 2.4.014

●     Fixed some minor issues.

6/Jan/2005

●     DHTML Menu Builder 4.9.013 is released 
●     Fixed a problem with the CollapsibleMenus AddIn while running under Internet Explorer 

5 for Mac.
●     The validation and registration mechanism has been enhanced to provide a more reliable 

and problem-free process.
●     Engine 2.4.013

●     Fixed a bug that affected the menus running under Internet Explorer 4.
●     Fixed some issues with the Item Highlighting functionality when running on frames.

28/Dec/2004

●     DHTML Menu Builder 4.9.012 is released 
●     Removed the fading effects on the nag screen and the About dialog to avoid 

compatibility issues with some video chipsets.
●     Added support to specify a "Selection Delay". This delay will allow the pass of the mouse 

over menu items without changing the current selection. This is very useful so users 
don't have to be too careful when moving the mouse and allows a certain amount of 
error when selecting menu items.

●     The CollapsibleMenus AddIn has also been updated. This version fixes several bugs and 
provides a great improvement in the menus usability.

●     Engine 2.4.012
●     Fixed several issues that affected the <developers' edition> version.

26/Nov/2004

●     DHTML Menu Builder 4.9.011 is released 
●     Added support to allow a reference image (an image used to attach a toolbar) to be 

automatically resized so its size (width and height) matches the size of the toolbar. 
This will allow the toolbar to appear to occupy space in the HTML content and will let the 
content on the page to appear as if it was flowing around the toolbar. 
(See the Positioning the Toolbar section for further information)

●     Added support to delete a toolbar by simply right clicking it and selecting "Remove 
Toolbar" from the context menu.
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●     The so popular CollapsibleMenus AddIn has been updated with lots of bug fixes and 
several new features. 
(Visit the CollapsibleMenus AddIn official section for more information)

●     Engine 2.4.010
●     Fixed a problem caused by Internet Explorer 6SP2 that could cause javascript errors 

under some web sites using frames support.
●     Improved the "max" compression algorithm resulting in the generation of even smaller .

js files.

9/Nov/2004

●     DHTML Menu Builder 4.9.010 is released 
●     Fixed several minor bugs reported by users.

●     Engine 2.4.010
●     Fixed several minor bugs reported by users.

25/Oct/2004

●     Engine 2.4.009
●     Fixed bug that caused projects using frames, configured as "remote" and using tooltips 

to cause javascript errors.
●     The code generated by the engine has been considerably improved requiring less HTML 

to render a single menu item thus producing smaller .js files and faster (more 
responsive) menus. 
Projects using lots of images and special effects will be the most benefited from this 
improvement.

●     The code introduced in 2.4.008 to prevent popup blockers from preventing the menus 
from opening new windows has been improved.

24/Sep/2004

●     DHTML Menu Builder 4.9.008 is released 
●     Fixed bug that cause the Blinking Speed to decrease every time the Project Properties 

dialog was opened.
●     Fixed bug that caused the Shadow Size slider for the toolbars to allow only 5 possible 

values instead of 10.
●     Fixed bug that caused the Item Highlighting Wizard not to display files with the CFM 

extension.
●     Fixed bug that could cause, under some very specific scenarios, the "Select Reference 

Image" and "Target Frame" dialogs to display invalid images and frames names.
●     Fixed bug that could cause DHTML Menu Builder to save a new project with the wrong 

file extension or no extension at all.
●     Added support to specify a new cursor type: "SizeAll" (known as "move" under the CSS 

specifications), which displays the system cursor for the "Size All" action.
●     Added two new types of Selection Effects and Borders: "dashed" and "dotted".
●     Added support to specify that new windows opened using the "Open URL in new 
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●     DHTML Menu Builder will now display the version type on the Nag and About screens so 
its easier to differentiate between the "Standard", "<developers' edition>" and "LITE" 
versions.

●     Engine 2.4.008
●     Fixed bug that caused the Follow Scrolling settings to fail under some circumstances.
●     Fixed bug with the Blinking effect that could cause javascript errors when using Frames 

support.
●     Fixed bug that caused (under some circumstances) the javascript compression engine to 

corrupt the caption and the code from the "Visibility Condition".
●     Added a special piece of code that solves an issue caused by a bug in Internet Explorer: 

when opening a document using the javascript location.href property, Internet Explorer 
will not send the referrer value in its headers. 
This new code will force Internet Explorer to send the referrer information.

●     Added a special piece of code that should prevent some poorly designed popup blockers 
from corrupting the javascript code.

12/Aug/2004

●     DHTML Menu Builder 4.9.007 is released 
●     Fixed bug that could cause the Item Highlighting feature to fail with menu items 

containing special characters on their caption.
●     Fixed bug that caused DHTML Menu Builder to display incorrectly, under some Windows 

XP skins, when maximized.
●     Fixed bug that caused the menu item to scroll too fast when using the In-Group scrolling 

feature.
●     Added a tool to specify the reference image when using the "Attached To" feature to 

position toolbars.
●     Added support to specify Selection Effects (borders) for the scrolling buttons displayed 

when using the in-group scrolling feature.
●     Added a new feature called "Global In-Group Scrolling" under the File->Project 

Properties->Global Settings->Extended Features section, which will allow all the menus 
to enable the in-group scrolling feature when required.

●     Engine 2.4.007
●     This is a maintenance release.

21/Jul/2004

●     DHTML Menu Builder 4.9.006 is released 
●     Fixed bug that could cause the program to start running slower after having performed 

changes to a very large project.
●     The interface has been enhanced to run smoothly, consume less resources and respond 

faster.
●     Engine 2.4.006

●     Fixed a bug that caused the engine to calculate the height of a toolbar when the toolbar 
items contained both background images and left/right images.

●     Added support to display the transparency effects under Mozilla.
●     The compilation time has been considerably enhanced.
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●     Wizard 2.1.004 
●     Fixed more bugs related to the use of Presets in the Wizard. 

15/Jul/2004

●     DHTML Menu Builder 4.9.005 is released 
●     This version includes an updated Wizard, an updated Project Compiler and an Updated 

version of the RollerEffects AddIn. 
●     Wizard 2.1.000 

●     Fixed bug that could cause javascript errors if the project was modified after applying a 
preset.

●     Fixed bug that caused Presets with images in their borders to be rendered improperly.
●     Fixed bug that caused the images in the menus not to be saved in the project file. 
●     The project will now be saved after quitting the Wizard.

29/Jun/2004

●     Engine 2.4.005
●     Fixed several bugs that caused the new blinking effect to stop working when using 

frames.

16/Jun/2004

●     DHTML Menu Builder 4.9.004 is released
●     Fixed bug that caused the "Options" button on the File->Project Properties-

>Configurations dialog to become inoperable if the dialog was accessed through the new 
shortcuts on the toolbar.

●     Fixed bug that could cause the program to crash when selecting the "Timers" tab under 
the File->Project Properties->Global Settings dialog.

●     Engine 2.4.004
●     Fixed bug that caused multiple javascript errors when a non HTML document was 

displayed inside the menus' frames.

13/Jun/2004

●     DHTML Menu Builder 4.9.003 is released
●     Fixed bug that could caused the program to crash when clicking the small arrow next to 

the Preview toolbar button.
●     Fixed bug that could cause the "Remove Menus" option from the "Install Menus" tool to 

fail.
●     Added a button to the new "Custom Offsets" dialog so the project can be recompiled 

every time a new custom offset is created or edited allowing for easier testing of the 
custom offsets.

1/Jun/2004
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●     DHTML Menu Builder 4.9.002 is released
●     Minor improvements have been made to the following sections of the application:

●     The ColorPicker now uses the new xFX Slider.
●     The main toolbar now adds a small arrow besides the Toolbar Properties and 

Project Properties buttons for easier access to their respective areas.
●     Added a small Help icon to all the style dialogs for easier access to the 

documentation.
●     The Help->Tutorials menu now has direct links to the two tutorials included in 

the documentation.
●     The Global Settings section has been completely redesigned so its easier to use.

●     Added support to enable a blink/flashing effect when menu items are clicked. This option 
is now available as part of the effects that can be applied to the menus under the Global 
Settings dialog.

●     The overall performance of the application has been considerably enhanced to reduce 
load and compilation times.

●     The Live Preview component has been improved to provide a more realistic preview of 
menus using Bevel selection effect.

●     Engine 2.4.002
●     Fixed some minor issues that affected Internet Explorer 5 for the Mac.
●     Fixed bug that caused custom cursors not to be extracted from the project file.

6/May/2004

●     DHTML Menu Builder 4.9.001 is released
●     Fixed bug that caused the in-group scrolling support to generate javascript errors when 

used on secondary projects.
●     Fixed bug that caused the in-group scrolling controls in the Special Effects dialog not to 

function correctly.
●     Fixed bug with the Color Picker where some times could cause the whole application to 

crash.
●     The AddIn Editor has been improved to provide easier creation and editing of AddIns.
●     DHTML Menu Builder, the HelpViewer, the Wizard and the Project Compiler applications 

will now inherit most of the styles provided by the current them under Windows XP.
●     Engine 2.4.001

●     Fixed bug with the way the scrollbar position was calculated under Safari and Konqueror 
causing the menus to close unexpectedly.

20/Apr/2004

●     DHTML Menu Builder 4.9.000 is released
●     Several minor bugs have been fixed.
●     Added support to specify the selection effects (previously known as command 

highlighting effects) to each menu item individually. 
In previous versions the selection effects settings were located in the Special Effects 
dialog. These controls have now been moved to the Selection Effects dialog which can 
be accessed from the Menu->Selection Effects option. 
Now, both groups and commands support this setting and a different set of effects can 
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be applied to each menu item in the project. 
The documentation has also been updated to reflect this major change in the program.

●     The way DHTML Menu Builder rearranges menu items when using the up/down arrows 
on the toolbar has been considerably enhanced to provide a much smoother display and 
to avoid flickering. 
The collapsed and expanded status of the menu items will now be preserved when 
rearranging menu items using the up/down arrows.

●     Engine 2.4.000 is released
●     Several minor bugs have been fixed.

●     Wizard 2.0.000 is released
●     Added support to apply styles from Presets 

The "Apply Style from Preset" option is available on the last step of the Wizard.

02/Apr/2004

●     DHTML Menu Builder 4.8.003 is released
●     Fixed bug that caused the tree-like menus generated by the "Export As HTML" feature to 

generate errors when using the "Expand All/Collapse All" options under Mozilla and 
KHTML based browsers.

●     Fixed bug that caused javascript errors in the preview window when previewing a tree-
like menu and the "Show Project Information in the Preview window" option was 
disabled.

●     Added an option to ignore any internet connection errors when checking for updates 
with the Help->Check for Updates option

●     Improved the submenus creation:
●     When adding a submenu a new command will be added to the subgroup 

automatically.
●     The names of the subgroups will now be much shorter.

16/Mar/2004

●     DHTML Menu Builder 4.8.002 is released
●     Fixed bug that caused DHTML Menu Builder to crash when some presets (such as the 

'Bubbles Menus') were selected in the Presets dialog.
●     Added two new language packs.

●     Engine 2.3.001 is released
●     Improved support for frames when displaying non HTML documents.

10/Mar/2004

●     DHTML Menu Builder 4.8.001 is released
●     This is a maintenance release.

5/Feb/2004

●     DHTML Menu Builder 4.8.000 is released
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●     Fixed problem that caused the "Export As HTML" dialog to loose the settings of the 
"Group Class" and "Commands Class" parameters.

●     Added support for displaying tooltips for each menu item.
●     The support for the Status Text parameter has been considerably enhanced:

●     You can now use the Edit->Copy and Edit->Paste features to propagate the 
status text of one item to all the other items in the project

●     The Status Text text field now supports two variables: %c and %u which will be 
substituted (at compilation time) for the menu item's caption and URL 
respectively.

●     Added support to specify highly customizable offsets for toolbars, root level menus and 
submenus through the new "Advanced Offsets Configurations" tool.

●     The alignment controls on the main dialog have been moved to appear inside the event 
tabs section to make it clear that this parameters works in conjunction with the "Display 
Submenu" action.

●     The width and height settings of the "Image" dialogs will now remain disabled until an 
image has been assigned.

●     The toolbar items shown in the Map View are now displayed using a new icon to help 
differentiate them from the standard groups. 

●     Engine 2.3.000 is released
●     Fixed bug that caused a javascript error when the menus where being navigated using 

the keyboard and the ENTER key was pressed on a toolbar item with no submenus 
displayed.

●     Fixed bug that caused javascript errors when using the Dreamweaver or ImageReady 
Rollovers support and the Code Optimization was set to "max".

●     Fixed bug that caused the "Item Highlight" functionality to leave items highlighted when 
frames support was being used.

●     Wizard 1.2.000 is released
●     Minor improvements have been made to enhance the usability of the Wizard.

●     HelpViewer 1.0.110 is release
●     Improved display of tooltips for the dialogs section of the documentation.

27/Jan/2004

●     DHTML Menu Builder 4.7.002 is released
●     Fixed several problems that occurred when dragging menu items from one project to 

another.
●     Fixed problem that could cause the application to crash if it wasn't able to save a project.
●     Fixed problem with the Highlighting functionality when the feature was used on a 

framed web site.
●     Improved Live Preview component:

●     Fixed problem that could cause menu items to render improperly when using 
images on the groups' borders.

●     Slightly improved rendering performance.
●     Improved Map View:

●     When performing operations such as copy/paste over menu items over the Map 
View the tree will no longer scroll maintaining the original view and layout of the 
tree structure.

●     Highly enhanced Search and Highlighting feature in the Help Viewer application.Page 120 of 181
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●     Added new option on the Edit->Preferences dialog called "Show Project Information in 
the Preview window". 
Disabling this option will remove all messages and information from the preview window 
leaving an empty document with just the menus.

●     Engine 2.2.002 is released
●     Fixed flickering problem that occurred on the browser's status bar when the "Item 

Highlight" feature was activated.

12/Dec/2003

●     DHTML Menu Builder 4.7.001 is released
●     Fixed bug that could crash DHTML Menu Builder if a corrupted language package was 

used.
●     The "Item Highlight Wizard" will now prevent the display of documents that belong to 

FrontPage subwebs.
●     Most of the new features introduced since version 4.6.010 are now localizable. At this 

moment, only the "Spanish" package has been fully updated.
●     Engine 2.2.001 is released

●     Fixed problem with the follow browsers' scrollbars function which could cause a browser 
to scroll eternally.

●     Fixed bug that caused the browsers' status bar to flicker and prevented any status text 
to be displayed when the "Item Highlight" feature was being used.

05/Dec/2003

●     DHTML Menu Builder 4.7.000 is released
●     Fixed multiple problems with the Item Highlight Wizard
●     Minor improvements have been made to the "Secondary Projects" support.
●     Added support to navigate the menus using the keyboard. To enable this feature turn on 

the "Keyboard Navigation Support" under the File->Project Properties->Global Settings-
>Extended Features section.

●     Engine 2.2.000 is released
●     Fixed multiple bugs that effected the performance and reliability of the menus under 

some very specific circumstances.

14/Nov/2003

●     DHTML Menu Builder 4.6.001 is released
●     Fixed several bugs that affected the new "Item Highlighting" functionality and the 

frames support.

11/Nov/2003

●     DHTML Menu Builder 4.6.000 is released
●     Fixed problem that prevented DHTML Menu Builder from loading projects when a .dmb 

project was doubled clicked from FrontPage 2003
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●     Added a new tool called the "Item Highlight Wizard" which allows the easy 
implementation of automatically highlighting an item, or sets of items, based on the 
section in which the visitor is inside the web site. 
This new tool completely substitutes the AutoSel AddIn by providing a user interface to 
implement and remove the code required to highlight an item.

●     Engine 2.1.000 is released
●     Fixed bug that caused the Map view to report links as broken when the local 

configuration used shares in the form of \\machinename\

24/Oct/2003

●     DHTML Menu Builder 4.5.010 is released
●     Engine 2.0.009 is released

●     Fixed a problem with the "Follow Scrollbars" feature which would prevent a toolbar from 
being properly displayed if the toolbar didn't fit inside the visible area of a browser 
window.

●     Fixed bug that caused the rollover effects on the toolbar items to stop working if a 
project used toolbars and image-based hotspots to display the menus.

16/Oct/2003

●     DHTML Menu Builder 4.5.009 is released
●     This is a maintenance release that fixes a compatibility problem between the links in the 

menus and ZoneAlarm's popup blocker.
●     Several minor bugs have been fixed.

02/Oct/2003

●     DHTML Menu Builder 4.5.008 is released
●     Engine 2.0.008 is released

●     Fixed bug that caused javascript errors under Navigator 4 when some alignment settings 
other than Bottom/Left were being used.

●     Improved rendering engine so menu items with borders do not appear to "jump several 
pixels" when the mouse is moved over them.

●     Highly improved the rendering of borders so 3D effects are now more notable and 
cleaner.

23/Sep/2003

●     DHTML Menu Builder 4.5.007 is released
●     Fixed bug that caused the program to freeze when using the "Background Color" option 

from the Preview dialog under Windows 95, 98 and Me.
●     Fixed bug that caused the program to run progressively slower after using it for some 

time.
●     Improved online connection testing. DHTML Menu Builder should now properly detect if 

the host computer is connected to the internet.
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●     Improved frames parser to discover the frames on a frameset document.
●     Engine 2.0.007 is released

●     Fixed bug that affected the "follow scrollbars" feature.
●     Fixed bug that affected some projects with frames support.
●     Fixed bug that affected the frames support under Internet Explorer 5 for the Mac.

08/Sep/2003

●     DHTML Menu Builder 4.5.006 is released
●     Fixed bug that caused the new Save function in the "Images" dialog to save the selected 

image as an empty file.
●     Added support to define how the different menu items should be displayed in the Map 

Mode. 
The display options are located in the Edit->Preferences->Display dialog. 
This feature also provides the ability to flag items with broken links by changing their 
color.

●     Added a Broken Links Report system available through the Tools->Reports->Broken 
Links Report menu.

●     Add support to specify automatic links verification when loading, saving and/or compiling 
a project through the Edit->Preferences->Links Verification dialog.

●     Changed the way DHTML Menu Builder detects if the host computer is connected to the 
Internet. 
Now DHTML Menu Builder should be able to detect the online status even if the 
computer is behind a firewall and/or proxy server.

●     The Tools->Install Menus dialog has been considerably enhanced to make the 
implementation of secondary projects easier and more intuitive:

●     The name of the projects to be installed is now displayed on the title bar of the 
dialog

●     When a file is selected, the name of projects that have been installed into the file 
will be displayed on the status bar

●     Engine 2.0.006 is released
●     Fixed bug that could cause javascript errors when toolbar items are set to display a 

submenu when clicked.
●     Fixed bug that could cause a browser to freeze if an HTML document that contained one 

or more secondary menus was scrolled up and down several times.
●     Fixed bug that could cause the toolbar items to flicker under some types of projects.
●     Fixed bug that that caused an error under Mozilla-based browsers when the _blank 

target frame was specified.
●     Fixed bug that could cause some rollovers created with ImageReady to stop working 

when the "ImageReady Rollover Support" was enabled.

19/Aug/2003

●     DHTML Menu Builder 4.5.005 is released
●     Fixed bug that could cause the application to crash when using the Edit->Copy tool on a 

separator.
●     Engine 2.0.005 is released
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●     Fixed bug that caused javascript errors when using the "ImageReady Rollovers" support 
(again).

●     Fixed bug with the ActiveText feature used in text-based hotspots that would cause the 
menus to disappear immediately after being displayed.

●     Fixed bug that caused JavaScript errors in Internet Explorer 4.

09/Aug/2003

●     DHTML Menu Builder 4.5.004 is released
●     Fixed bug that could cause the "Directory Scanner" tool to fail to detect files from 

custom file type definitions.
●     The "Export As HTML" feature has been enhanced so the tree-like menus can be 

collapsed/expanded all at once.
●     Engine 2.0.004 is released

●     Fixed bug with the compression algorithm that caused it to generate corrupted javascript 
files when more than one menu items in the project being compiled used the "Open in 
new Window" action type.

●     Fixed bug that caused javascript errors when using the "ImageReady Rollovers" support.
●     The compiler has been enhanced so very large projects will be compiled much faster and 

will produce smaller .js files.

31/Jul/2003

●     DHTML Menu Builder 4.5.003 is released
●     This is a maintenance release which fixes several minor bugs.

●     Engine 2.0.003 is released
●     This is a maintenance release which fixes several minor bugs.

All users of DHTML Menu Builder 4.5.000, 4.5.001 and 4.5.002 are urged to upgrade 
immediately to ensure the proper functionality of the program.

24/Jul/2003

●     DHTML Menu Builder 4.5.002 is released
●     Fixed typo on the File->Export As HTML dialog.
●     Added support to specify complex sets of items to receive style changes. 

This feature can be accessed through each style dialog by clicking on the new scope 
control and selecting the "Advanced" option. This advanced feature can also be selected 
from the Edit->Paste dialog by clicking on the "Advanced" button.

●     Now when generating an HTML version of the menus using the File->Export As HTML 
feature, DHTML Menu Builder will not add rollover effects to those groups and 
commands that are not linked.

●     Enhanced the way DHTML Menu Builder detects an internet connection. This will avoid 
potential problems with the validation system and the connection to the Online Catalog.

●     Minor cosmetic changes have been applied to some sections of the program.
●     Engine 2.0.002 is released
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●     Fixed bug that caused the menus to continuously reset the status text of the browser.
●     Fixed bug that caused some menus to close immediately after moving the mouse over 

them. This often occurred with menus displayed from hotspots where the first command 
in the group displayed a subgroup.

17/Jul/2003

●     DHTML Menu Builder 4.5.001 is released
●     Fixed a small bug with the Preview feature of groups not belonging to any toolbar.
●     Fixed bug that could cause the File->From Directory Structure option to crash under 

some circumstances.
●     Increased the overall performance of the application. This will be more notable on 

projects using many images.
●     Added support to hold up to 8 recently used documents from the File->Open Recent 

menu; also, DHTML Menu Builder will now automatically remove from the recent files 
menu any projects that no longer exist.

●     Added support to specify the default charset encoding for the preview window. This 
option is accessible through the Edit->Preferences dialog as well as from the Preview 
window.

●     Added support to change the style of several menu items all at once from each style 
dialog.

●     Enhanced keyboard-based navigation of the DHTML Menu Builder interface using the 
TAB key.

●     The tree-like menus generated by the File->Export As HTML feature are now fully 
compatible with Opera 7 and Safari 1.0

●     Engine 2.0.001 is released
●     Fixed bug in the generated code that could cause a toolbar item that does not display a 

menu to flicker when the mouse was moved above it.
●     Fixed bug that could cause the menus to generate a javascript error when using non-

standard alignment settings for submenus.
●     Fixed bug that caused one of the images in the loader code to have two extensions: 

'dmb_m.gif.gif'
●     Enhanced compression algorithm will now generate slightly smaller JavaScript files.

25/Jun/2003

●     DHTML Menu Builder 4.5.000 is released
●     This version has been released to accommodate the enhancements in the 1.2 version of 

the DHTML Menu Builder Engine.
●     Added support to generate menus that are compatible with Lotus Domino web server.
●     Added support to display the subwebs of a FrontPage web under the Install Menus 

dialog.
●     Changed the way nodes in the Edit->Copy dialog are automatically selected so the "URL/

Script" and "Target Menu" options are never auto-selected. 
This will solve the problem of ending with all menu items displaying the same group 
when moused over or linking to the same page when clicked.

●     Support for the "Opera Helper Functions" has been removed.
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●     Engine 2.0.000 is released
●     The new engine is now capable of producing smaller, faster and more compatible menus. 

The new code generated by the 1.2 version of the DHTML Menu Builder Engine 
generates code that is fully compatible with the following browsers:

●     PC/Windows Platform:
●     Internet Explorer 4, 5, 5.5 and 6 and all browsers based on Internet 

Explorer 4 and above.
●     Netscape Navigator 4
●     Opera 6.0 and above (see *note below regarding support for Opera 6)
●     All Mozilla based browsers including Navigator 6 and 7 and FireBird

●     Macintosh Platform
●     Internet Explorer 5 for MacOS 9 and X and all browsers based on Internet 

Explorer 4 and above.
●     All Mozilla based browsers including Navigator 6 and 7
●     Safari 1.0
●     Opera 6.0 and above (see *note below regarding support for Opera 6)

●     UNIX Platforms (including Linux)
●     Netscape Navigator 4
●     All Mozilla based browsers including Navigator 6 and 7 and FireBird

The following list of browsers have been removed from the supported list:

●     Opera 5 and 6 
*NOTE: The menus will work perfectly fine under Opera 6 as long as no special effects, such 
as DropShadows, are used.

Related topics of interest: 

●     DHTML Menu Builder News
●     Full DHTML Menu Builder History Log
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 Glossary

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

Note: The following definitions all pertain to use within the context of DHTML Menu Builder.

A
AddIn 
An AddIn is a reusable component that provides additional or modified behaviors for the menus. 
For more information see the AddIn Editor section.

Anchor 
A tag in an HTML document that defines a section of text, an icon, or other element as a link to 
another element in the document or to another document or file. See also HotSpot. 
Click here for a complete description.

AUE (Advanced Unfolding Effects) 
Module integrated into DHTML Menu Builder to setup advanced visualization effects for the menus. 
To access this tool click File->Project Properties->Global Settings->Advanced Unfolding Effects

B
Border 
Area surrounding an element, specifically the area surrounding a group defined through the Color 
dialog. 
For commands. this is the area surrounding the selection. It can be set through the Selection Effects 
dialog.

DMB 
Short name for DHTML Menu Builder.

C
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Code 
A series of instructions, variables and values that, when interpreted by the appropriate engine, produce 
some kind of result. 
In DHTML Menu Builder the term usually refers to the code generated by the Compile process. The 
code generated by DHTML Menu Builder will always be saved in files with a "js" extension which means 
it is a JavaScript file. It is important to know that JavaScript files created by DHTML Menu Builder must 
be treated as binary (as opposed to text) documents.

DHTML Menu Builder generates more code than that stored in the "js" files. Below is a complete list of 
all the code that can be generated by DHTML Menu Builder:

●     Menus Code: This is the code stored on the "js" files that display and control your menus. 
These files are generated through the compilation process.

●     Loader Code: This is the code placed in your web documents that instructs the browser to load 
the "js" files. This code is installed through the Install Menus tool (or if you have enabled the 
"Use Advanced Installation Tools" option the Install Loader Code will be used).

●     Trigger Code: For projects using hotspots, this is the code placed on the hotspots so when the 
hotspots are selected they display the attached menu. This code is installed through the 
HotSpots Editor tool.

Compile (Compilation Process) 
The action of generating the JavaScript code that will display and control the menus of your project. 
For more information about compiling see the Implementing the Menus section.

E
Effect 
A setting that applies a special feature to an element in the menus. 
See AUE, Unfolding Effects, Special Effects.

F
Frame 
An individual frame within a FRAMESET. In HTML, this is usually a window within a page where the 
contents are separated and independent from the contents on another frame. DHTML Menu Builder 
provides support for triggering the menus on one frame and displaying them in another.  

Page 129 of 181

file:///C|/My%20Projects/Visual%20Basic/DHTML%20Menu%20Builder%204.8/Help/dialogs/ilcman.htm
file:///C|/My%20Projects/Visual%20Basic/DHTML%20Menu%20Builder%204.8/Help/dialogs/preferences.htm
file:///C|/My%20Projects/Visual%20Basic/DHTML%20Menu%20Builder%204.8/Help/dialogs/installloadercode.htm
file:///C|/My%20Projects/Visual%20Basic/DHTML%20Menu%20Builder%204.8/Help/dialogs/pp_globalsettings.htm
file:///C|/My%20Projects/Visual%20Basic/DHTML%20Menu%20Builder%204.8/Help/dialogs/group_sfx.htm


For more information see the Working with Frames section.

H
HotSpot 
An element on a web page that can be used to trigger (display) a menu. A HotSpot must always be a 
hyperlink and the hyperlinked object can be any HTML element that supports the anchor tag. 
For more information, see the Preparing your Web Site section.

Hyperlink 
An HTML element enclosed in anchor tags.

I
Image 
Technically, a file containing information about a two dimensional array of pixels that represent some 
sort of graphic. In practical terms, any graphic. 
You can assign images to various elements in your menus such as the background of the groups, 
toolbar, commands, and either or both sides of a command or toolbar item. 
For more information, see the Images dialog.

M
Margin 
Margin defines the distance from the outer border of an element to the inner border of the container. 
Margins can be applied to numerous elements in DHTML Menu Builder:

●     Group Margins
●     Commands' Margins
●     Toolbar Margins

Menu 
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A menu is what the user sees when a hotspot is triggered. A menu is composed of a group and its 
commands. 
For more information see the Anatomy of a Menu section.

Menubar 
(see toolbar)

P
Project 
The file where all the information about your menus is stored. 
DHTML Menu Builder's projects have a "dmb" extension and should be treated as binary files.

T
Toolbar 
A toolbar (also known as menubar) is a special object used to display a series of menu items. A toolbar 
remains always visible and can be used to allow access to the different menus in your project. 
In DHTML Menu Builder you can create as many toolbars as you want, place them anywhere on a 
page. Click here to know more about toolbars. 
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 Advanced Topics

The following topics cover sections and features of the program that require a reasonable knowledge 
of the technologies used by the menus, such as JavaScript, DHTML, the Document Object Model, etc.

It is no necessary that you understand these topics to use the program, but, if you feel comfortable 
with the mentioned technologies then knowing how to use these features can greatly and considerably 
enhance your experience with DHTML Menu Builder:

●     The Toolbars' Visibility Condition
●     The AddIn Editor
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 Toolbars' Visibility Condition

Under some situations you may want to be able to display or hide a toolbar. For example, you could 
create a project with two toolbars: one which is always visible and the other that its only displayed 
under a specific section of your web site.

The toolbars' visibility is controlled through the state of a condition known as the "Visibility Condition". 
To access this parameter, click Tools->Toolbars Editor->Advanced

The condition must be defined by the body of a function that, when evaluated, must return either true 
(visible) or false (hidden).

So, for example, if you add this code to the Visibility Condition of a toolbar:

return document.title.indexOf("Customers")!=-1;

The toolbar will remain hidden unless the title of the document being displayed contains the 
"Customers" string in its title. 
If you need to match the exact title of an HTML document to determine the visibility state of a toolbar 
you could use this code:

return document.title == "Ink Cartridges - Color";

In this case, the toolbar will remain hidden unless the title of an HTML document exactly matches the 
"Ink Cartridges - Color" string.

These are just some basic examples that take advantage of the page title to determine the visibility 
state of a toolbar... but you could be a lot more creative and use some more complex conditions. 
For example, you could create a condition that depends on some other javascript variable in your page, 
or perhaps a condition that depends on the actual time or date. 
The possibilities are just endless...

Modifying the Visibility Condition programmatically

The state of a toolbar can also be changed by directly accessing the variable that controls their visibility 
by adding some code into an HTML document. 
For example, this code will turn the toolbar number 1 off:

<script language="JavaScript"> 
    tbVisC[1] = new Function("return false"); 
    SetupToolbar(); 
</script>

The first line of code defines the body of a simple function that returns a false value setting the 
visibility state for the toolbar number 1 to be hidden. 

Page 133 of 181



The second line of code causes a refresh in all the toolbars by re-evaluating all their parameters. If the 
second line is omitted the visibility state will not change.

Creating a blinking effect

Although it may not be a useful thing to have a toolbar blink it demonstrates the power and versatility 
of this new feature in DHTML Menu Builder 4.1 (and above) 
Here's the code used in the Visibility Condition of the toolbar:

var m=new Date().getMilliseconds(); if(!SM)window.setTimeout
("SetupToolbar()", 100); return (m<800);

First of all, notice that the code must always be contained in a single line and must always return 
either true or false. 
So, let's analyze the code, piece by piece:

var m=new Date().getMilliseconds();

The first piece of code queries the system and retrieves the current time, but only the milliseconds. 
The result is stored in the variable 'm'. 
The second section of the code:

if(!SM)window.setTimeout("SetupToolbar()", 100); 

This code setups a timer so the SetupToolbar() function is called again. This will force the code to keep 
re-evaluating our condition until the page is unloaded. Notice that this timer is only required on 
Internet Explorer; this is why we use the "if(!SM)" condition, which means: "...if its not a mozilla-based 
browser, then...". 
And finally, the third piece of code:

return (m<800);

...is the return statement. 
In this statement we're comparing the value in the variable 'm' with the number 800. If the value in 'm' 
is less than 800 the function will return true, otherwise it will return false.

This causes the function to return true for about 800 milliseconds and false for about 200. This will 
cause the toolbar to remain invisible (hidden) for about 200 milliseconds per every second. 
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Related topics of interest: 

●     Secondary Projects Support
●     Online Tutorial for implementing multiple menus
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 AddIn Editor

The AddIn Editor is an integrated editor which offers many more options than those available through 
DHTML Menu Builder's user interface. Since DHTML Menu Builder generates code that is based on an 
editable template, you can modify the template to customize your menus even further than the 
program normally allows. These changes can also be reused in any DHTML Menu Builder project that 
you want.

You can add features, do real-time modifications to the menus, change standard settings, etc. You can 
even add variables (parameters), so they can be easily modified without having to re-run the AddIn 
Editor. All changes supported by AddIns are compiled into the JavaScript files ultimately generated by  
DHTML Menu Builder. You do not have to concern yourself with any additional files on your web site.

Please note that the AddIn Editor is only intended for use by advanced users with a working knowledge 
of HTML, DHTML, JavaScript, CSS, and the DOM of the latest browsers. (If you are not familiar with 
any of these terms, you probably should not be using the AddIn Editor.)

The AddIn Editor Window

The AddIn Editor window is 
composed of five main sections:

●     The Section selector 
This list displays all the 
standard functions used by 
DHTML Menu Builder. 
Selecting a section from 
this list displays the 
contents of that section. 
The predefined functions 
can be modified but not 
deleted. Any functions you 
create will also be found in 
this list. 
In the DHTML Menu Builder 
code template, there is one 
special section which is not 
a function. It's called 
GLOBAL. This is where all 
the global variables used by 
the functions are defined.

●     The new code pane 
This pane shows the 
modified code.
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This pane shows the original code as found on the default template.

●     The functions variable bar 
This small bar shows all the variables defined on the selected section.

●     The description pane 
This pane will show a small description of what the selected function does.

Working with the AddIn Editor is very simple, and basic customizations to the default template are 
easily implemented.

Basic Operations

Starting the AddIn Editor

To start the editor, click AddIn Editor on the Tools menu.

Creating a New AddIn

The easiest way to create an AddIn is to click Properties on the File menu . 
Type the name and the description of the new AddIn and click OK to save your changes.

Subsequent changes will be saved to a file under the name of the AddIn. All the AddIns are saved in 
the same place, a directory called AddIns under the folder where you installed DHTML Menu Builder.

Opening a previously saved AddIn

To open an AddIn click Open on the File menu. 
Then select which AddIn to open from the displayed list.

Deleting a previously saved AddIn

To delete an AddIn click Open on the File menu to display the AddIn file dialog.  
Then select which AddIn to delete and click Delete.

Note that you cannot undo this deletion.

Installing a new AddIn

Several AddIns are usually available for download on our web site. These typically offer support for 
some of the most requested features. 
To install a new AddIn, double-click the (downloaded) AddIn file. It will be automatically installed into 
the correct folder.
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Adding a new function

To add a function to the selected AddIn,  click Add on Function menu.

The function name should be made of alphanumeric characters only and the first character must be a 
letter. The naming conventions for the JavaScript functions applies. Note that you should not add the 
parameters declaration on the name.

Finally, if you wish, you can type a small description of what the function does.

Editing or removing a custom Function

Default functions cannot be deleted although they can be edited. To edit a function, select the function 
from the list and then click  Edit on the Function menu. To remove (delete) a custom function, 
select the function from the list and then click Delete on the Function menu.

Restoring the original code from a function

To restore the default code of the selected function, click Restore on the Function menu.

Parameters

The AddIn Editor supports inserting parameters in the code. This is useful if you want some values 
changed without having to re-edit the code in the AddIn Editor.

The Parameters menu offers options to Add, Edit, Remove and Insert parameters to your code.

Changing the compilation value of these parameters can be performed by clicking the Parameter 
Properties button , which is located in the Advanced tab of the Project Properties dialog.
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While working in map view 
There're many tasks that can be performed directly from the Map View interface. Once you have 
reviewed all the possible options that are available while working on this mode you will be able to work 
faster and more efficient.

Creating Items

●     Toolbars: click Menu->Add Toolbar
●     Groups: Select the toolbar where you want to create the group and click Menu-

>Add Group
●     Commands: Select the group where you want to create the command and click 

Menu->Add Command

Creating SubMenus

To create a submenu simply select a command and click Menu->Add 
SubGroup 
DHTML Menu Builder will automatically set the Over/Cascading mode for 
the command and will cerate a group for you so you can start adding the 
commands for the new submenu.

Deleting Items

To delete an item simply select the item that you want to delete and press 
the DEL key on your keyboard or click Menu->Delete 
Notice that while in Map View DHTML Menu Builder will automatically 
perform some additional tasks when:

●     Deleting a toolbar: All the groups that were attached to the deleted toolbar will 
be automatically moved to the (NoToolbar) section

●     Deleting a group: All the commands that belonged to group will be deleted 
automatically

●     Deleting a submenu: The command that displayed the submenu will be 
automatically configured to do nothing when the mouse is moved over it

Renaming Items

●     Notice that after creating a new item the Map View will auto-select it and wait for 
you to give it a caption. To do so, simply write the caption for the newly created 
item and press the ENTER key when done.

●     Once an item has been created, to rename it, simply select the item and press 
the F2 key or click Edit->Rename

●     When renaming an item you're actually changing the caption of the item. If you 
would like to change the items' name (this only applies to groups and 
commands) then start renaming the item by clicking Menu->Rename and enclose Page 139 of 181



the item's name in brackets.

Rearranging the menu items

The order in which the toolbars, the groups and commands appear in the Map View 
affects your project. Rearranging the menu items in the Map View is a very easy task:

●     To move toolbars, groups and commands up and down simply use the Up ( ) 
and Down ( ) buttons from the toolbar.

●     Groups and commands can be dragged and dropped while the Map View. This 
way you can easily move or copy group from one toolbar to another or you can 
move or copy a command from one group to another. While dragging and 
dropping a command hold down the ALT key to change the default move action 
to copy.

The smart Context Menu

The Map View features a smart context menu which automatically modifies itself to display only the 
most commonly used options based on the selected item. 
This is a very powerful feature that can save a lot of time when creating and working with a project 
because instead of having to search through the menus or the toolbars for a specific option you just 
have to right click an item from the Map View and the context menu will be customized to provide you 
with the most useful and most frequently used set of options.

The menu items' colors and icons

Each items in the Map View is represented by its caption and an icon.

●      This is the icon used to represent toolbars
●      This is the icon used to represent toolbar items
●      This is the icon used to represent groups
●      This is the icon used to represent commands
●      This is the icon used to represent separators

The icon for toolbar items, groups and commands have several variations used to represent the events 
used by the item. For example, a command icon with a "0" and arrow ( ) means that the over event 
for the item has been configured to display a submenu. A command icon with a "1" ( ) means that 
the click event has been configured to open a page when clicked (link).

Each menu item is also represented using a different set of colors and styles. For example, toolbars, 
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toolbar items and groups are displayed using bold text; items with broken links are displayed using a 
red color, etcetera. 
To customize how the different items are displayed, use the Edit->Preferences->Display dialog.
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the image that we want to 
use as a reference. In this 
case we called our image 
"RefImage".

And, finally, its just a matter of recompiling the project using the Tools->Compile command to see 
how our changes are working.

Well, as expected, the toolbar is appearing "near" the image in the dark blue cell and it is following it 
(you can verify this by resizing this window). But... it is not exactly over the image. This is normal and 
it can be fixed by applying some small offsets to tweak the final position of the menus.

As you can see in the sample below the toolbar is appearing a couple of pixels to the right so we'll 
need to compensate this by applying a negative offset. A negative vertical offset will move the toolbar 
towards the top and a negative horizontal offset will move the toolbar towards the left.

Click the Continue button below to see how we apply these offsets and finalize our project. 

Your browser does not support inline frames or is currently configured not to display inline frames. 

Continue »
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even previewing. 
 
When a group is selected, the Live Preview shows how the background of the menu will appear. If the 
toolbar option is selected, the preview will show how the actual toolbar hotspot will appear. 
 
When a command is selected, the Live Preview shows how the selected command will appear against its 
parent group.
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 DHTML Menu Builder History

16/Jun/2003

●     Engine 1.07.007 is released
●     Fixed bug that caused background images on some menu items not to appear under 

Netscape Navigator 4.

11/Jun/2003

●     DHTML Menu Builder 4.3.009 is released
●     Added support to preview the sitemap generated through the File->Export As HTML 

option.

06/Jun/2003

●     DHTML Menu Builder 4.3.008 is released
●     Fixed bug that could corrupt non-HTML documents if the "Remove Menus" option was 

used while the "Hide Unsupported Documents" option was not selected.
●     Engine 1.07.006 is released

●     This is a maintenance release.

22/May/2003

●     DHTML Menu Builder 4.3.006 is released
●     Fixed bug introduced in version 4.3.005 that caused the ImageReady and Dreamweaver 

Rollover Support to stop working. 
When enabling any of these extra features the Root Menus Delay will be ignored in order 
to ensure that the rollover support is properly implemented.

●     Greatly improved the speed at which styles are applied through the Tools->Apply 
Style from Preset option.

●     The Menus Offsets will now be applied from the select Preset when using the Tools-
>Apply Style from Preset option.

19/May/2003

●     DHTML Menu Builder 4.3.005 is released
●     Fixed bug that could crash the program if a user tried to delete an Online preset from the 

Presets Manager.
●     Added support to specify a delay to show root level menus.
●     Added a new AddIn, AutoSel, which will allow you to select a menu item 

programmatically. 
Click here for more information.

●     Engine 1.07.005 is released
●     Fixed bug that caused the DropShadow effect not to work on toolbars with transparent 
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●     The context menus will now be shown instantly regardless of any delay.
●     Installer

●     The installer has been enhanced to properly install all files and perform a successful 
upgrade when installing DHTML Menu Builder over a previous version.

13/May/2003

●     DHTML Menu Builder 4.3.004 is released
●     Fixed minor bugs that affected the way the menus in the program work.
●     Fixed bug that caused the program not to update the interface when a menu item was 

being selected and required the item to be selected twice.
●     Fixed bug that caused the "Live Preview" to incorrectly render some menu items when 

using custom toolbar sizes.
●     Added support to browse the Presets on the Online Catalog directly from the Presets 

Manager window.
●     Engine 1.07.004 is released

●     Fixed bug that caused links on toolbar items to generate a javascript error or to stop 
working when the target frame contained a document from a different domain.

●     DHTML Menu Builder Wizard 1.1.004 is released
●     Fixed bug that caused the font alignment setting to be ignored.

06/May/2003

●     DHTML Menu Builder 4.3.003 is released
●     Fixed several bugs that affected the Secondary Projects support.

●     Engine 1.07.003 is released
●     This is maintenance release.

29/Apr/2003

●     DHTML Menu Builder 4.3.002 is released
●     Fixed bug that could cause the HelpViewer window to always appear behind the main 

DHTML Menu Builder window.
●     Fixed bug that could cause the Preview window to appear modal when activated from the 

main DHTML Menu Builder window.
●     Fixed bug that could cause the "Menu" menu to appear empty.
●     Fixed bug that caused the "Live Preview" to incorrectly render caption-less toolbar items.
●     Fixed several bugs with the "Secondary Projects" support that could cause the application 

to crash or to incorrectly report incompatible projects.
●     Engine 1.07.002 is released

●     Fixed bug that caused the menus to behave unexpectedly under Navigator 4 when using 
frames support.

●     Fixed bug that affected the way the engine calculates the size of caption-less toolbar 
items.

25/Apr/2003
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●     DHTML Menu Builder 4.3.001 is released
●     The menu system used in the program has been changed from scratch in order to fix the 

following problems:
●     The "File" menu does not work.
●     The program crashes under Windows 95 when the SHIFT, CTRL or ALT keys are 

pressed.
●     Added support to trigger the groups' scrolling feature when the mouse is over the 

scrolling buttons.
●     Added support to create new projects from a directory structure or by following the links 

on the documents of a web site.
●     Added support to access the File->New menu from the main toolbar.
●     Added support to recursively delete menu items by holding the SHIFT key while selecting 

the Edit->Delete option.
●     Added support to submit Presets online to the Presets Online catalog by using the new 

File->Submit Preset option.
●     Minor enhancements have been made to the "Secondary Projects" support.

●     Engine 1.07.001 is released
●     Fixed bug that, under some circumstances, caused the size of the toolbars to be 

miscalculated.
●     Fixed bug that caused some Advanced Unfolding Effects to stop functioning due to a 

corrupted style description.
●     Enhanced how the menus are positioned on the visible area of the browser when they 

don't properly fit in it.
●     Installer

●     The installer has been redesigned to make it smaller and faster.

02/Apr/2003

●     DHTML Menu Builder 4.3.000 is released
●     Fixed bug that affected the way new menu commands are added to a project when their 

parent groups have crosslinked assignments (that is, groups that display other group's 
commands).

●     Enhanced support to drag and drop items while in the Map view. DHTML Menu Builder 
will now properly copy groups being dragged and dropped, specially groups with 
submenus and complex structures.

●     Added support to specify background images in the toolbar items. The Images dialog for 
the groups have been redesigned to accommodate this new feature.

●     Added support to display the context menu of any menu item using the context menu key 
on the keyboard.

●     Engine 1.07.000 is released
●     Fixed bug that could cause javascript errors if the "Support for ImageReady Rollovers" 

feature was enabled.
●     Fixed bug that caused separators on horizontally aligned groups to appear corrupted or 

not to appear at all.
●     Minor enhancements have been made to the generated code to make it cleaner and more 

compatible/compliant to the standards.
●     Several javascript functions have been revised to provide better support for Opera 7 and 
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24/Mar/2003

●     DHTML Menu Builder 4.2.003 is released
●     Minor bug fixes related to the Map view will prevent unexpected results when performing 

operations such as drag&drop, pasting and deleting menu items.
●     Engine 1.06.005 is released

●     Enhanced rendering engine so the font information does not affect the size of caption-
less menu items. 

20/Mar/2003

●     DHTML Menu Builder 4.2.002 is released
●     Minor enhancements have been made to ensure that DHTML Menu Builder's interface is 

properly rendered under Windows XP in skinned mode.
●     Engine 1.06.004 is released

●     Fixed bug that could cause the "Optimize Paths" option of a configuration of type remote 
to generate invalid absolute paths.

●     Fixed bug in the compression engine which could corrupt the code used to pre-load the 
images in a menu when using a configuration of type remote.

●     Enhanced code generation on projects using image-only menu items.
●     Added a new function to overcome a bug in Internet Explorer 5 for Mac that could cause 

a misalignment on groups and/or toolbars attached to images.

19/Mar/2003

●     DHTML Menu Builder 4.2.001 is released
●     Fixed multiple bugs regarding the new Map view functionality.

17/Mar/2003

●     DHTML Menu Builder 4.2.000 is released
●     Fixed bug that could cause the Preview window to fail to assign the background color and 

become modal.
●     Fixed bug that prevented the drag&drop operation to copy groups from one toolbar to 

another.
●     Added support to set the size and color of the drop shadow. Consequently the 

DropShadow PRO AddIn is no longer required.
●     Added "Single Select" support to the Tree mode in the Export As HTML function.
●     The drop shadow and transparency effects are now rendered in such a way that the drop 

shadow will not be visible through the groups due to the transparency setting.
●     Added support to specify drop shadow and transparency effects for the toolbars.
●     The application has been enhanced to consume about 10% less system resources on 

Windows 95, 98 and Me.
●     The Map view mode has been dramatically enhanced for performance. Large projects 

with 500 or more menu items are now rendered almost instantly with minor notable 
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●     Engine 1.06.003 is released
●     Fixed bug that caused a javascript error when using the groups' scrolling support on 

projects with frames support.
●     Fixed bug that caused the menus to render improperly on documents running with 

XHTML compatible DOCTYPE.
●     Fixed several problems with Navigator 4 and the Toolbar's "Attached To" feature.
●     Highly improved support and compatibility for Opera 7.
●     The code will now reset itself whenever the menus' frame is reloaded to avoid possible 

crashes on some versions of Internet Explorer. This applies to projects with frames 
support.

●     Some parts of the code have been tweaked to properly support the upcoming final 
version of Mozilla 1.3

06/Mar/2003

●     Engine 1.06.002 is released
●     Fixed bug that could crash the program when using separators on menus wider than 300 

pixels.
●     Minor enhancements to the compression algorithm should provide smaller compiled files 

on large projects.
●     The compiled menus should now be more responsive under Internet Explorer 5 for the 

Mac as well as all Mozilla based browsers.

03/Mar/2003

●     Project Compiler 1.1.123 is released
●     Fixed bug that could cause some projects using separators to be compiled incorrectly.

●     Engine 1.06.001 is released
●     Fixed bug that could crash DHTML Menu Builder when starting multiple instances
●     Fixed bug that caused javascript errors when the group scrolling feature was activated on 

projects using configurations of type remote.

26/Feb/2003

●     DHTML Menu Builder 4.1.000 is released
●     Fixed bug that caused the Map view to improperly render the menu's structure after 

changing the action type.
●     Fixed bug that caused the Map view to improperly render the menu's structure after 

moving a toolbar using the Up/Down arrow controls.
●     Fixed bug that could cause the use of the Install Menus option to corrupt some non-

HTML documents.
●     Fixed several bugs that affected the functionality of the ColorPicker.
●     Fixed bug that caused DHTML Menu Builder to crash if a new toolbar was created and 

then a menu item was moved up or down.
●     The Map view has been improved so the state of the expanded and collapse items is 

maintained.
●     The Integrated Preview has been enhanced so you can now easily change the 
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background color of the preview document and you can also preview the menus directly 
over the Target Document, as specified on the default configuration.

●     New subgroups and new commands created under a subgroup will now inherit the styles 
from their parent elements.

●     Added support to show and hide toolbars programmatically through the new "Visibility 
Condition" property.

●     Added support to combine projects into the same document.
●     Added support to see all the documents on the web site through the Install Menus tool.
●     Added support to specify the border type of groups (Menu->Color dialog) and Toolbars 

(Tools->Toolbars Editor->Appearance dialog).
●     Added support to create scrollable menus. This is specially useful for menus that are too 

long to fit in a standard browser window; with this feature users will be able to scroll up 
and down the contents of the menus.

●     The presets are now compressed to save space.
●     The Used Colors menu from the ColorPicker dialog will now display a small red rectangle 

on the currently selected color.
●     The documentation has been updated to reflect all the new features.

●     Export As HTML fixes and enhancements
●     The links on the tree-like menu items will now have the correct relative path when using 

configurations of type relative.
●     The links on the tree-like menu items will now include the target frame information so the 

menu can be included in a frame.
●     AddIn Editor 1.5 has been released

●     This new version of the AddIn Editor is able to properly upgrade AddIns to the current 
version of the default code template. By simply opening an AddIn with the AddIn Editor 
and saving it is enough to update all the non-modified functions.

●     Engine 1.06.000 is released
●     Fixed bug that caused a javascript error when the support for "ImageReady Rollovers" 

support was enabled.
●     Fixed bug that caused javascript errors under Internet Explorer 5 for the Mac.
●     Fixed bug that caused menu items with no submenus to remain highlighted after moving 

the mouse away from them under all Mozilla-based browsers.
●     Fixed bug that caused corruption on some menu items' links when the links where 

manually entered (not using the browse button).
●     Fixed bug that could case incompatibility problems with third-party scripts.
●     The loader code from relative configurations now fully complies with the W3C standards 

by adding the width, height, border and alt parameters to the <img> tags.
●     The menus will now acquire their z-index value programmatically based on the z-index 

value of their parent toolbar allowing them to always be placed above every other menu 
object in the document. This fixes bug where a menu could be appearing behind other 
toolbars from the same project.

●     The overall performance of the menus has been increased resulting in more responsive 
rollover effects for the commands.

30/Jan/2003

●     DHTML Menu Builder 4.0.002 is released
●     This is a maintenance release.
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●     Engine 1.5.003 is released
●     This is a maintenance release.

24/Jan/2003

●     DHTML Menu Builder 4.0.001 is released
●     Fixed bug that caused menu items to get deleted when the DEL key was pressed to 

delete something from the Caption, URL/Script or Status text boxes.
●     Fixed bug that under some circumstances caused the wrong item name/caption to appear 

on the Paste dialog.
●     Fixed bug that caused the Map view not to refresh after doing a Paste operation.
●     Fixed bug that caused new projects created from a Preset to have a corrupted default 

configuration.
●     Some minor bugs have been resolved with the Find/Replace feature.
●     The "Export as HTML" feature has been enhanced to properly support projects with no 

toolbars and disabled items.
●     The documentation for the Advanced section of the Project Properties dialog has been 

updated to reflect the new Code Optimization setting.
●     The Map mode has been enhanced so you can now move (rearrange) groups and 

toolbars up and down using Up and Down arrows on the toolbar.
●     Engine 1.5.002 is released

●     Fixed bug that caused JavaScript errors when enabling the support for Dreamweaver and/
or ImageReady rollovers.

●     Fixed bug that caused the AUE to stop working on groups using the DropShadow and/or 
Transparency effect.

●     Fixed bug that could crash the program if a project contained a toolbar with no groups.
●     The DropShadow effect  will now be displayed in-synch with the AUE effects.
●     Fixed bug that caused the menus to be incorrectly rendered under IE when documents 

followed the XHTML specification.
●     Fixed bug that caused a javascript error if the mouse was hovered over a menu being 

closed with an slow AUE effect.
●     Fixed bug that caused a document to stop loading if a toolbar item was selected before 

the document had finished loading.
●     Improved how the toolbar sizing is handled under Navigator 4 and Mozilla.
●     Added new functionality to the Toolbars' size parameters: When specifying a manual 

width or height setting, the engine will optimize the size of each one of the toolbar items 
instead of justifying them (making them all the same size). However, you may still force 
them to have the same size by enabling the Justify option.

●     The frames support has been considerably improved by providing a method of locating 
frames when the specified target frame does not exist. This is useful when the menus are 
run from a web site which uses a redirector or when the menus are being viewed from 
inside another frameset.

●     DHTML Menu Builder Wizard 1.1.003 is released
●     This is a maintenance release to keep the code generated by the Wizard compatible and 

up-to-date with the latest changes in the application.

10/Jan/2003
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●     DHTML Menu Builder 4.0 is released

11/Jul/2002

●     DHTML Menu Builder 3.6 public beta 1 is released
●     Several interface enhancements
●     Add support to create multiple toolbars
●     Added new Loader Code Manager

●     Engine 1.5 is released
●     Enhanced compression
●     Fix several bugs related to the way some URLs are handled

28/Jun/2002

●     DHTML Menu Builder 3.5.003 is released
●     This is a maintenance release that fixes several bugs introduced since the official release 

of version 3.5
●     Engine 1.3.003 is released

●     This is a maintenance release that fixes several bugs introduced since the official release 
of version 1.3

21/Jun/2002

●     DHTML Menu Builder 3.5.002 is released
●     Improved the load time of the application.
●     Added support to choose a default browser for previewing from the main window.
●     Add the "Add Links" button to the Install Frames Loader Code dialog.
●     The browse for folder dialog will now appear properly centered to the parent calling 

dialog.
●     Added support to specify any of the four standard target frames: _self, _top, _blank and 

_parent.
●     Engine 1.3.002 is released

●     Fixed bug that could cause the JavaScript error 'location is undefined' when importing 
projects created with older versions.

●     Fixed a minor bug that was preventing the hide timer used to hide the menus from 
properly working.

●     Better handling of HTML tags in the caption now results in more accurate calculations of 
the width and height of the menu items.

●     Wizard 1.1 is released
●     Added support to create submenus.

●     Fixed bug that could cause the HelpViewer application to crash when performing a search 
operation.

●     The documentation has been revised to make sure the content matches all the new features and 
changes.

16/Jun/2002
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●     DHTML Menu Builder 3.5.001 is released
●     Fixed some bugs with the Install/Remove Loader Code dialogs.
●     Improved some minor cosmetic issues with the Install/Remove Loader Code dialogs.
●     The Wizard is now part of the standard setup and its accessible through the Tools menu.

●     Engine 1.3.001 is released
●     Minor improvements to the compression engine results in smaller compiled code.

10/Jun/2002

●     DHTML Menu Builder 3.5 is released
●     Added support for a new configuration type: Relative. Click here for more information.
●     Added support to set transparent colors.
●     Added support to set the background color of separators.
●     Added support to set the alignment of submenus.
●     Added support for the toolbar items to display the Highlight Effects assigned to the 

groups.
●     Added support for pre-loading all the images used on the project. Older version would 

just pre-load some images.
●     Added support for customizing the width and height of the toolbar.
●     Added support to use Macromedia Flash animations as the background of any menu item.
●     Added preliminary support for the Konqueror browser.
●     Added support to type in a custom font size on the Font Dialog even if the font size is not 

displayed on the list.
●     Added support to control the unfolding effect speed, the time the menus will remain open 

before auto-hiding and the time the pointer must be on a command before the submenu 
is displayed.

●     Added support to enable Opera to display rollovers.
●     Added support to keep rollover effects created with ImageReady in synch with the menus.
●     Image-based hotspots now can be placed inside layers (or divs) and still preserve the 

proper alignment of the menus under Navigator 4.
●     The Frames Support has been highly enhanced making it simpler to set up the project in 

order to support frames. Also, the new support offers the ability to place the menus on 
any subframe that can be nested inside any number of parent frames. Finally, this new 
enhanced code will let you change the names of the frames without having to reconfigure 
or recompiling your project.

●     Several enhancements have been made to the registration system to avoid downtimes.
●     The LivePreview control has been considerably enhanced to reflect all the new features in 

this release.
●     Fixed bug that could cause DHTML Menu Builder to enter an infinite loop if a browser, 

previously configured on the Available Browsers dialog, was deleted from the system.
●     Fixed bug that caused the Live Preview component to appear when DHTML Menu Builder 

started even if the Live Preview option was disabled.
●     Fixed bug that caused the list of recently used colors menu on the Color Picker dialog 

didn't display the complete list of all the colors on the project.
●     The DEMO version of DHTML Menu Builder now supports all the features of the final 

release. Its only limitation is that the generate menus will not contain any links so when 
clicked will do nothing.
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integrated into the program.
●     All the sound support options have been removed. The options will be re-enabled as soon 

as this feature is considered safe and stable.
●     The FTP/Publishing feature has been completely removed from the program.

●     Engine 1.3 is released
●     The generated code for Navigator 4 has been highly enhanced resulting in smaller, faster 

and more stable menus.
●     Fixed bug that caused URLs containing single quotes to be improperly parsed.

Click here for information on how to properly upgrade your project.

24/Mar/2002

●     Engine 1.2.008 is released
●     Fixed bug that caused the preloading of images to fail when compiling a project using the 

FINAL optimization mode. 
This is a serious bug that caused numerous error entries on the web server's log files, 
slowed down the menus and under some circumstances caused an annoying flickering 
under Navigator 4. (Thanks to Tim)

21/Mar/2002

●     DHTML Menu Builder 3.3.004 is released
●     Fixed bug that could cause DMB to crash when accessing the Validation/Registration 

dialog.
●     Fixed bug that could cause the caption of toolbar items to appear incorrectly aligned 

under Navigator 4.
●     Fixed bug that caused the Caption and Status text to lose any blank spaces placed after a 

punctuation mark.
●     Enhanced detection support for complex nested Frames and IFrames.
●     Updated some sections of the documentation such as:

●     Incompatibilities and limitations of different browsers and platforms
●     Registration Information
●     Frequently Asked Questions
●     DEMO version limitations

17/Mar/2002

●     Engine 1.2.005 is released
●     Fixed bug that could cause the loader code from a CD-ROM configuration to cause 

problems if used on .asp documents.
●     Fixed another bug that caused the Upgrade function to improperly represent the date 

format under non-US systems. (Thanks to Jason)
●     Fixed bug that caused the toolbar items to render incorrect colors when using CD-ROM 

configurations. (Thanks to Wayne)
●     All the AddIns have been updated to reflect the latest changes in the code, introduced in 
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the March 9th release.

09/Mar/2002

●     DHTML Menu Builder 3.3.003 is released
●     This version accumulates the fixes that were released on the 6th and 7th of March:

●     Fixed bug introduced in 06/Mar release that caused the menus to appear 
improperly aligned on the preview.

●     Fixed a bug with the Transparent Toolbar Items AddIn that caused JavaScript 
errors.

●     Fixed a bug with the latest version of the code generated by Engine 1.2.004 that 
could cause a JavaScript error under very old releases of Navigator 4.

●     Fixed bug that caused DHTML Menu Builder to display an incorrect release date 
for the latest version available when using the Help->Upgrade feature.

●     Fixed bug that caused URLs containing a comma to be corrupted in the 
compilation process.

●     Fixed bug that caused the Preview to hang or raise an error if a group contained 
customized trigger code.

●     Here's the list of the new fixes introduced in this release:
●     Fixed bug that caused the cached list of documents used on the Install Loader 

Code dialogs to be improperly restored
●     Added a new button "Add Links" on the Install Loader Code dialog to load all the 

documents linked from the menus. This is particularly useful when using a CD-
ROM configuration and you want to install the loader code on all the documents 
linked from the items on your project. This button is not available on the Install 
Frames Loader Code dialog because this function is automatically executed when 
the dialog is loaded. This means that, by default, when you launch the Install 
Frames Loader Code dialog, all the files linked from the menu items are 
automatically added to the list.

●     All the Loader Code related dialogs display status information while they are 
working. On large projects it looked like DMB would have frozen. Now, with the 
status information you can see the progress of what DMB is doing.

●     Fixed bug that could cause the Upgrade feature to improperly represent the date 
information under systems not using the US time and date format.

●     Fixed several bugs on some functions required by the CD-ROM configuration. These bugs caused 
the links on the commands to generate invalid relative paths.

28/Feb/2002

●     DHTML Menu Builder 3.3.002 is released
●     Now the Up and Down arrow keys can be used to navigate the menu items.
●     Now the Del key can be used to delete the selected item.
●     The ColorPicker dialog initialization code has been dramatically enhanced reducing the 

loading time of the dialog to just a fraction of a second.
●     Added support to drag groups and commands between projects. Just open two instances 

of DMB and load two different projects on each instance. Then simply drag and drop a 
command or a group from one instance to the other.

●     Enhanced Upgrade dialog now shows the "What's New" information about the latest Page 154 of 181



version.
●     The tutorial for creating projects using the toolbar option has been finally included in the 

documentation.
●     Engine 1.2.004 is released

●     Fixed a serious bug that caused shared projects compiled with the FINAL optimization 
method to generate JavaScript errors.

●     Fixed several bugs that caused hotspots using the onclick event to display the menus to 
work inconsistently. Because of the changes required to fix this issue it is highly 
recommended that you re-run the HotSpots Editor to update the code on your hotspots.

●     The compression algorithm has been enhanced again providing better compression for 
projects using many images on the toolbar items.

21/Feb/2002

●     Engine 1.2.003 is released
●     Fixed bug introduced in version 1.2.002 that could cause some projects to improperly 

render all the commands at the top of the group.
●     Implemented the new technique to align commands to the toolbar items.
●     Fixed several bugs on the "Dynamic Caption Change" and "Dynamic Enable-Disable" 

AddIns.

19/Feb/2002

●     Engine 1.2.002 is released
●     Fixed bug that could cause a JavaScript error when compiling a project using a CD-ROM 

configuration.
●     Fixed bug that caused the caption of a command to loose the spaces after a "," when 

compiling the project using the FINAL optimization.
●     Improved alignment support for the caption of the menu items.
●     Enhanced compression algorithm.

18/Feb/2002

●     DHTML Menu Builder 3.3.001 is released
●     Fixed bug with the group width setting as it would reset to Auto every time the Group 

Size tab was selected.
●     Fixed bug that caused DMB to crash if trying to resize the Images dialog when no images 

were loaded.
●     Fixed bug that caused DMB to crash if the Color Picker dialog was cancelled from the 

Extract Icon tool.
●     Enhancement to the User Interface continue:

●     Expanded the visible area for the tree view of the menus by making all the 
controls flat.

●     Added the Menu's Style Properties back to the Context Menu.
●     The Map view now supports context menus.
●     Slightly increased the viewable are of the Live Preview.

●     Added the support back for typing the underscore character on the Window Name 
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parameter of the New Window Parameters dialog.
●     Some code cleaning has been done resulting in a slighter smaller EXE and faster interface.

●     Engine 1.2.001 is released
●     Fixed bug with the way Actions were being parsed.
●     Fixed bug that could cause the font size of the menus to increase every time a new page 

was loaded under Navigator 4 for the Macintosh when using frames support.
●     Fixed bug that caused the menus to generate a JavaScript error when running under 

Internet Explorer 5 for the Macintosh on documents with the strict HTML 4.0 doctype 
declaration.

●     Added a new AddIn, called AutoFrames, which should provide a great improvement in the way 
frames support is handled by DMB. Click here for more information.

12/Feb/2002

●     DHTML Menu Builder 3.3 is released
●     User Interface Enhancements and Changes:

●     The main window has been slightly redesigned to support splitting and appear 
clearer and less cluttered.

●     You can now rename an item by selecting it and then clicking it again, just like in 
Explorer.

●     The context menu for the menu items has been simplified.
●     When a color button has  the same color as the dialog's background a rectangle is 

drawn around it so it remains visible.
●     When saving a project using the File->Save As command, the project's name will 

be changed to match the file name.
●     The title bar of the application now shows the name of the project followed by the 

name of the application to comply with the document-oriented applications 
specification.

●     You can now enter percentage values on the New Window Parameters dialog to set the 
position and size of the new window.

●     Opera 5 appears to have a bug that affected the way toolbars are positioned. This 
version implements a fix that will make the toolbars appear perfectly aligned under this 
browser.

●     When attaching groups to images using the HotSpots Editor and no name is given to the 
images, the HotSpots Editor will automatically assign an image name for you.

●     Another cool feature is that you can now extract icons from applications (or libraries such 
as ICLs and DLLs) and save them as GIF images. To use this feature, which is not yet 
covered anywhere on the documentation, go the Menu->Images dialog, select to change 
any image and then click on the Extract Icon button.

●     Added support for IFRAMEs. Click here for more information.
●     Engine 1.2 is released

●     When using fully qualified URLs, these will be properly parsed even when using a 
configuration of type local as the default one.

●     The function that hides the form elements so the menus can be displayed has been 
enhanced to handle both single and multiple select lists (thanks to Dayna).

●     The menus are now positioned (z-index'ed) at a much higher level that in previous 
versions to avoid conflicts with other positioned DHTML elements.
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download any dependencies from the Internet. This should fix many problems some users were 
having but unfortunately it has increased the setup file about 2MB.

●     Fixed a bug that caused the Live Preview control to render background images incorrectly. 
(Thanks to Alexander S.)

 

05/Feb/2002

●     DHTML Menu Builder 3.2.027 is released
●     Finally!!! Fixed the bug with the FTP Publishing feature. Now it will properly publish both 

the images and the .js files.
●     Fixed bug with the Project Compiler. In versions .025 and .026 the Project Compiler 

wasn't starting when launched from the Explorer context menu.
●     Fixed bug that caused the icons of the menu items not be updated when using the Copy/

Paste feature to change the Actions of a group of items.
●     Engine 1.1.030 is released

●     Fixed bug that caused the paths of the links not to be properly generated when disabling 
the new Optimize Paths option.

●     Some enhancements have been made to the engine in order to reduce the compilation 
time.

●     The Project Compiler application has been enhanced to support command line arguments and 
perform silent/background compilations on demand. For more information double-click the dmbc.
exe program and a list of the supported command line arguments will be displayed.

28/Jan/2002

●     DHTML Menu Builder 3.2.026 is released
●     Fixed bug with the recent used colors menu on the Color Picker dialog. The color preview 

on the menu should now be properly displayed.
●     Fixed bug with the Enable-Disable AddIn.
●     Removed check for the read-only attribute on the documents when selecting a link using 

the browse button.
●     Fixed some minor user interface problems.
●     The frame names will now be checked to make sure there're no reserved names being 

used.
●     Engine 1.1.029 is released

●     This is a maintenance release.
●     Fixed some small bugs in the documentation.
●     Fixed and enhanced the Dynamic Enable-Disable AddIn.

18/Jan/2002

●     DHTML Menu Builder 3.2.025 is released
●     Fixed some minor bugs in the way the HotSpots Editor attaches the hotspots' trigger code.Page 157 of 181



●     Fixed a bug that could cause a project running on frames to generate JavaScript errors 
when the frameset is loaded for the first time.

●     Added support to monitor the available free resources and warn the user when Windows 
is running dangerously low. This system has no effect under Windows NT, 2000 or XP.

08/Jan/2002

●     DHTML Menu Builder 3.2.024 is released
●     Fixed bug that caused the toolbar's follow scrolling feature to fail under Navigator 6 and 

Mozilla.
●     Fixed bug that could cause the menus with frames support turned on to generate a 

JavaScript error under Opera 6 when a link was selected.
●     Engine 1.1.028 is released

●     Fixed bug that caused a command to do nothing when it was assigned to display a 
submenu when clicked. The bug affected Navigator 4 only.

04/Jan/2002

●     DHTML Menu Builder 3.2.023 is released
●     Fixed bug that could cause DHTML Menu Builder to crash if the the Active text option was 

chosen on a document with no hotspots.
●     When creating a new remote configuration using a local configuration as a template, the 

associated local configuration will point to the template local instead of the first local.
●     Added "Optimize Paths" option to configurations of type remote. For more information on 

this feature click here and click on the Options button.
●     The Window Name parameter on the New Window dialog will only accept letters for the 

names of the windows avoiding potential JavaScript errors.

30/Dec/2001

●     DHTML Menu Builder 3.2.022 is released
●     Fixed bug with the ColorPicker component which could crash DHTML Menu Builder if 

manually entering incorrect values.
●     Added support to warn the user if the system is running out of system resources.

12/Dec/2001

●     DHTML Menu Builder 3.2.021 is released
●     Fixed bug that caused the icons on the menus of DHTML Menu Builder to appear empty 

under Windows XP.
●     Engine 1.1.027 is released

●     Fixed bug that could cause the program to crash when trying to preview a project with an 
incorrect remote configuration setup.

●     Fixed several bugs that caused problems when using Shared Projects. The documentation 
about sharing projects has also been updated.

●     Fixed several bugs with the Delayed Submenus AddIn.
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11/Dec/2001

●     DHTML Menu Builder 3.2.020 is released
●     Improved the New Window Parameters dialog.
●     Fixed some minor cosmetic issues when running DHTML Menu Builder under Windows XP.
●     Enhanced support for importing AllWebMenus projects. (Looks like everyday we have 

more and more users switching to DMB ;)
●     Added the .jsp file extension to most of the Open dialogs.
●     Minor enhancements have been made to the HotSpots Editor to avoid conflicts with the 

names of the images assigned through the Image Name parameter.
●     Engine 1.1.026 is released

●     Fixed bug that caused toolbars under Navigator to appear randomly on the screen and 
the reposition at the designated point. The toolbar will not appear at the designated point 
with "jumping around" on the page while it loads.

●     Fixed bug that caused menus to briefly appear at the (0, 0) position and then reposition 
to the expected position under Navigator 6.

●     A new AddIn is available (Navigator 4 CLIP bug) which fixes a bug in Navigator 4 that causes the 
menus to disappear after rapidly moving the mouse over the menus.

05/Dec/2001

●     DHTML Menu Builder 3.2.017 is released
●     Fixed bug that could cause the HotSpots Editor to improperly update the ShowMenu 

function parameters when using frames.
●     Engine 1.1.025 is released 

●     Fix bug that caused the cursors on the toolbar items to appear as an I-beam cursor when 
using Navigator 6 or Mozilla.

●     The size of the compiled code has been considerably reduced on projects using a toolbar.

02/Dec/2001

●     DHTML Menu Builder 3.2.016 is released
●     Improved Registration process:

●     Users behind a firewall or proxy will now be able to ignore any errors produced 
during the two first steps of the registration process.

●     Under some situations you will be able to register without having to validate. This 
will become quite useful when upgrading your copy of DMB so by just selecting 
Register->Enter Registration Information will be enough to convert the DEMO into 
the FULL version.

●     Engine 1.1.024 is released 
●     Fixed bug that could cause the compression engine to damage the path for some images 

when using the FINAL optimization method.

29/Nov/2001

●     DHTML Menu Builder 3.2.015 is released
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●     Improved Registration process.
●     Engine 1.1.022 is released 

●     Fixed bug that affected projects compiled with the "This is a shared project" flag.
●     Fixed bug that could cause the toolbars to appear improperly aligned when using 

DOCTYPE declarations under Netscape Navigator 6
●     A new Installer is now being used to distribute DHTML Menu Builder. Among other features this 

installer is about 1.5MB smaller.

20/Nov/2001

●     DHTML Menu Builder 3.2.014 is released
●     Fixed several bugs in the HotSpots Editor. It should now be able to properly implement 

the code on highly formatted pages.
●     Engine 1.1.021 is released 

●     Fixed bug that could cause the menus to not disappear under Navigator 6 when using 
toolbars created by DMB.

09/Nov/2001

●     DHTML Menu Builder 3.2.013 is released
●     Fixed bug that could cause any group's "Open URL / Execute Script" action to become 

corrupted after running the HotSpots Editor more than once on projects using Frames 
Support.

●     Fixed several bugs that could cause the HotSpots Editor to corrupt the event code 
attached to the hotspots.

●     Added some more sample projects and images.

2/Nov/2001

●     DHTML Menu Builder 3.2.012 is released
●     Fixed bug with the Install Loader Code dialogs. The cached list of files should now be 

properly generated.
●     Fixed bug that could cause the HotSpots Editor to crash DHTML Menu Builder when 

loading some types of documents.
●     Added support to import hierMenus 4 projects (arrays).

●     Engine 1.1.021 is released
●     Fixed bug with the way some style parameters were being initialized.
●     Fixed bug that caused the engine to generate extra closing double quotes on some 

entries when using toolbars.

28/Oct/2001

●     DHTML Menu Builder 3.2.011 is released
●     Fixed bug that could cause DHTML Menu Builder to fail to retrieve the complete frameset 

structure from a manually coded HTML document.
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24/Oct/2001

●     DHTML Menu Builder 3.2.010 is released
●     This is a maintenance release that fixes many known problems with Windows XP:

●     Fixed problem with the icons displayed in the following dialogs:
●     Main menu tree
●     Copy/Paste dialogs
●     Default Browser dialog
●     Images Browser dialog
●     Validation dialog

●     Fixed problem with the size of some of dialogs. Dialogs should now be properly 
displayed without clipping any controls. This fix should also solve the problems 
caused by having the Large Font setting in the Display control panel.

●     Known bugs that still need to be fixed:
●     The icons that should be displayed the menus options such as File->Open, 

Tools->Compile, etc, are displayed as an empty box.
●     The icons that should be displayed in the Used Colors menu from the Color 

Picker dialog are displayed as empty boxes.
●     Engine 1.1.020 is released

●     Fixed bug that caused some elements to render larger that they should. Thanks to Bill 
Lanides from Intrasphere for giving us the solution!

●     Added support to display the hand cursor under Navigator 6.
●     Fixed bug in the Dreamweaver Rollover Support AddIn that could cause a JavaScript error if a 

hotspot with no group attached was selected.
●     Fixed bug that could cause DHTML Menu Builder to crash when attempting to change a property 

of a command-less group.

23/Oct/2001

●     DHTML Menu Builder 3.2.009 is released
●     Fixed bug with the HotSpots Editor's new Active Text feature that could cause 

unpredictable results when the group name was exactly the same as the text in the link.
●     Added option to launch the Help Viewer in search mode (Help->Search)

●     Engine 1.1.018 is released
●     Fixed bug in the toolbar code that caused toolbar items with images to generate a 

JavaScript error.
●     Added feature to the HelpViewer to highlight the words from a search query.

18/Oct/2001

●     DHTML Menu Builder 3.2.008 is released
●     Fixed bug that could cause an incorrect parsing of the paths in a local configuration.
●     Fixed bug that could cause the Publishing feature to crash DHTML Menu Builder if the 

FTP information was invalid.
●     Fixed bug that caused that error in the Install Loader Dialog is the paths to the files was 

in the form of \\compname\
●     Fixed bug in that caused Active Text hotspots to display a white line beside the hotspots.
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●     The browse button in besides the Action text box to select links will be unavailable 
(appeared dimmed) until some valid information is available in the local configuration.

●     Added option to remove the loader code from any file or set of files. This option is 
available under the Tools menu.

●     A new tips system has been implemented which will provide you very helpful information 
while you work on DHTML Menu Builder.

●     Engine 1.1.017 is released
●     The toolbar generated by DHTML Menu Builder now specifies a z-index position in order 

to ensure that is positioned above any element in the page.
●     Fixed bug in the DropShadow PRO AddIn that could cause the menus to remain hidden and only 

the shadow could become visible.

17/Oct/2001

●     Engine 1.1.016 is released
●     Fixed bug with several event handlers. Triggering actions to display submenus for the 

onclick and ondoubleclick events should work now.

16/Oct/2001

●     DHTML Menu Builder 3.2.007 is released
●     This is a maintenance release that improves the way complex framesets and nameless 

frames are parsed.

15/Oct/2001

●     DHTML Menu Builder 3.2.006 is released
●     This is a maintenance release that improves the new HotSpots Editor's Active Text 

feature so it works properly on HTML documents created with Microsoft Word ort that 
contain special formatting tags.

14/Oct/2001

●     DHTML Menu Builder 3.2.005 is released
●     Changed some of the messages displayed in the status bar while DHTML Menu Builder is 

compiling to better reflect what is the program doing.
●     The HotSpots Editor has been upgraded providing these new features:

●     The icon for the hotspots reflects the type of hotspot: text-based, image-based or 
active text

●     You can now implement what we call "Active Text". The Active Text features 
converts a simple text-based hotspot into an active element which makes it 
support auto-relative positioning just as the image-based hotspots do.

●     Engine 1.1.015 is released
●     Fixed bug that caused the menus to disappear if the mouse was moved over the hotspot 

that displayed the currently active menu.
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12/Oct/2001

●     DHTML Menu Builder 3.2.004 is released
●     Fixed bug that could cause DHTML Menu Builder to report a file invalid because it wasn't 

found, when the file actually existed.
●     Fixed bug in the new HotSpots Editor that could cause a hotspot not to be installed/

attached if the contents of the event handlers where empty, such as OnClick=""
●     Fixed bug in the new HotSpots Editor that could cause a hotspot to loose any none-DMB 

code.
●     Fixed bug with the sound preview button. The preview should work fine now and the 

selected audio file will be played when the play button is clicked.
●     Fixed some minor cosmetic problems when using non English language packs.
●     The cursor now changes into the hourglass cursor when the program is busy compiling.
●     Changed some of the messages displayed in the status bar while DHTML Menu Builder is 

compiling to better reflect what is the program doing.
●     Engine 1.1.014 is released

●     Fixed bug calculating the height of the commands when groups use the horizontal layout.
●     Fixed bug that avoided the background of the toolbar to be smaller than 21 pixels.

11/Oct/2001

●     DHTML Menu Builder 3.2.003 is released
●     Fixed bug that could cause DHTML Menu Builder to report a file invalid because it wasn't 

found, when the file actually existed.
●     Fixed bug with the sound preview button. The preview should work fine now and the 

selected audio file will be played when the play button is clicked.
●     Fixed some minor cosmetic problems when using non English language packs.
●     The cursor now changes into the hourglass cursor when the program is busy compiling.
●     Changed some of the messages displayed in the status bar while DHTML Menu Builder is 

compiling to better reflect what is the program doing.
●     Engine 1.1.013 is released

●     Fixed bug in the way the browser version was being calculated. This could affect the way 
some AddIns worked.

●     The compression of the compiled .js files has been enhanced providing smaller files, 
specially under Navigator 4.

09/Oct/2001

●     DHTML Menu Builder 3.2.002 is released
●     Fixed bug in the FTP configuration tab. Selecting the account information will now be 

properly saved.
●     Fixed bug with the options Tools->Install Frames Loader Code. Under some 

circumstances the option would appear not to work.
●     Added support to specify the type of menubar (horizontal or vertical) in the new HotSpots 

Editor when using frames. This new option will become available automatically when 
implementing the menus on a framed environment and after clicking the Install button in 
the HotSpots Editor.
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●     Engine 1.1.009 is released
●     Captions using special characters such as "<" or "|" should now be properly parsed to 

avoid crashing Navigator 4.
●     Different parts of the documentation have been updated to reflect the latest changes in the 

program's interface.

08/Oct/2001

●     DHTML Menu Builder 3.2.001 is released
●     Fixed bug in the Project Properties dialog that could cause unpredictable results if while 

browsing for a folder the browse button on the main dialog was clicked again.
●     Fixed bug that caused the Install button to become unavailable when trying to upgrade 

through the Help->Upgrade command.
●     Fixed some minor bugs in the Live Preview Component
●     A new HotSpots Editor has been implemented. This new version of the HotSpots Editor is 

easier to use, faster, consumes less resources and fixes many bugs found on the older 
version of the tool. 
See HotSpots Editor for more information. 
Another important improvement is that the original code of the file being modified by the 
HotSpots Editor will be preserved intact: no modification to the code, not relevant to the 
hotspots will be modified in anyway. 
Finally, this version also incorporates a couple of new features such as:

●     The ability to set the position of the menus manually (when using text-based 
hotspots)

●     Change the name of the images (when using image-based hotspots)
●     Attach the same group to different hotspots
●     And the highly requested feature of de-attaching groups.

●     The Final HTML Document parameter has been removed from the configurations as it is 
no longer required by the new HotSpots Editor.

●     A new frameset parser is now available which does not require Internet Explorer to work, 
making it faster and allowing you to use any kind of file as the "Frames Document".

●     The size of the "Open Recent" option under the "File" menu has been increased to allow 
easier reading of the entries.

●     DHTML Menu Builder will not allow you to install the Frames Loader Code into the file 
specified by the Document Containing the HotSpots. This should avoid the common 'out 
of stack' error.

●     The documentation on how to set up shared projects has been updated.
●     Added new Map View. In this mode DHTML Menu Builder will present the menus in a tree-

like display to let you examine your project's menus structure.
●     The password for the FTP account is no longer saved in the project file. Every time a 

publish operation is started you will be asked for the account's password.
●     A .log file will be created when Publishing the menus to an FTP site.
●     When creating a new project, DHTML Menu Builder will display the Project Properties 

dialog. You can disable this feature in the Preferences dialog.
●     The ColorPicker component has been updated to allow an easier setup of the RGB 

parameters.
●     In the status bar you can now see the selected default configuration.
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●     Fixed bug in the new CD-ROM configuration type that could cause incorrect paths is the 
menus where loaded from within a complex subdirectory structure through a web server. 
This configuration type is still considered to be under development.

●     Fixed bug in the way toolbar items where being rendered when using right aligned text 
and an image at the right of the caption.

●     Fixed bug that cause JavaScript errors when using Shared Projects compiled with the 
FINAL optimization mode.

●     The size of the optimized code when using the Toolbar support has been considerably 
reduced.

●     The HelpViewer application now supports sorting the search results.

25/Sep/2001

●     DHTML Menu Builder 3.2 is released
●     Fixed bug in the ColorPicker dialog where the blue text box wouldn't auto select its 

contents when selected.
●     Fixed bug in the ColorPicker dialog that could cause the selection cursor to jump around 

under some circumstances.
●     Fixed bug in the ColorPiclker component that could cause DHTML Menu Builder to crash 

when run under Windows Me.
●     Fixed bug with the Install Loader Code and Frames Loader Code functions. Complex 

directory structures should be properly retrieved now.
●     Fixed bug with the Upgrade feature. Under some Windows languages this feature could 

generate an error and fail to obtain the required information.
●     Fixed bug with the height parameter of the Group Size setting as it wouldn't accept 

manual settings.
●     Added support to add images to the borders of the groups. See the groups' Image dialog 

for more information.
●     Added support to update the location of images. See the Images Browser dialog for more 

information.
●     Added support to specify font substitutions. See the Advanced section of the Project 

Properties dialog.
●     Added support to change the value of the "DoFormsTweak" variable from the user 

interface. See the Advanced section of the Project Properties dialog.
●     Added a new configuration type: CD-ROM. This type of configuration will create relative 

paths instead of absolute paths so the menus can be used on scenarios where the root 
location can change.

●     The list of files included into the Loader Code and Frames Loader Code dialogs is now 
saved and automatically retrieved every time the dialogs are re-used.

●     Minor revision of the HotSpots Editor should make it more stable and use less system 
resources.

●     Fixed bug that could case the HotSpots Editor to freeze when closing it.
●     DHTML Menu Builder now requires about 4MB less of RAM memory to run.
●     The Compile & Update HotSpots option has been removed.
●     Projects with no commands, only groups, can now be previewed and compiled.
●     A warning will be displayed if trying to use a non-HTML file in the "Final HTML Document" 

or "Frames Document" parameters.
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●     Engine 1.1.005 is released
●     Fixed bug when parsing URL's containing login information (user name and password).
●     Fixed bug that could cause the fonts to appear excessively larger under Navigator 4 for 

the Macintosh.
●     Fixed bug that caused the menus to align improperly when using the new vertical setting 

for the Commands Layout option.
●     The size of the code generated for Navigator 4 when using toolbars has been 

considerably reduced.
●     Font names with spaces are now enclosed in double quotes preventing problems under 

Navigator 4 and 6.
●     Fixed bug in the documentation. The Remote configuration dialog wasn't being displayed.
●     Fixed bug in the documentation. The information for the Font Selection dialog was incorrect.
●     Minor compatibility fixes have been applied to the generated code to improve backwards 

compatibility with Internet Explorer 4 for Windows.
●     The speed (responsiveness) of the menus has been considerably increased resulting in a better 

experience when using slow browsers such as Navigator 6 and Internet Explorer 5 for the 
Macintosh.

●     The Dreamweaver Rollover Support AddIn has been updated to support version 4.0 of 
Macromedia® Dreamweaver™ and Fireworks™.

●     The Dropshadow PRO AddIn has been updated so the dropshadow is displayed at the same time 
as the menu fixing a cosmetic problem in previous versions.

●     Two new AddIns have been added:
●     Dynamic Enable-Disable: This AddIn allows you programmatically change the enabled 

state of any command.
●     Dynamic Caption Change: This AddIn allows you to programmatically change the caption 

of any command or toolbar item.
●     The Samples have been updated with more features. Some new samples have been also 

included.

29/Aug/2001

●     DHTML Menu Builder 3.1.001 is released
●     The Upgrade feature has been enhanced so it also compares the release date with the 

date of dmb.exe file on the system. This will allow you to know if an update is available 
even if the program hasn't changed.

●     Fixed bug with the menus offset parameters not being reset when creating a new project.
●     Engine 1.1.001 is released

●     Fixed bug that caused toolbars to generate an error under Internet Explorer 5.0 for 
Macintosh when using frames.

●     Fixed bug that caused the menus to generate JavaScript errors when using the UTF-8 
charset encoding.

●     Fixed bug in the new DropShadow PRO AddIn that caused the shadow to appear at the incorrect 
position if the menus changed position.

●     Fixed bug in the HelpViewer application that could cause an Overflow error when using the 
search function.
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AddIn
●     Added description for the Advanced Project Properties and Menus Offset dialogs.

24/Aug/2001

●     DHTML Menu Builder 3.1 is released
●     Several cosmetic enhancements have been made to the following dialogs:

●     Group and Command Color
●     Group and Command Font
●     Group and Command Image
●     Group Special Effects
●     Project Properties
●     Main program window

●     Added support to change the color of the four corners of each group independently.
●     Added Support for creating horizontally aligned menus.
●     Added support for two new border styles applicable to the Commands' Highlight Effects: 

double and bevel.
●     The Selective Copy/Paste dialogs are now resizable.
●     The shortcut to Preview is now F12.
●     The shortcut to Compile is now F9.
●     Startup speed has been increased considerably.
●     The option "Use Colored Borders" allows you to customize the base color for the selected 

Commands' Highlight Effect. In previous versions, the custom color was applied only 
when the effects were set to (none).

●     The Color Picker Dialog has been enhanced to provide easier color selection.
●     Fixed bug that was damaging the link information on items pointing to external sites 

while using a configuration of type local.
●     Fixed bug with the Groups Color dialog. The background color should now be properly 

applied.
●     Fixed bug while importing projects created with an older version.
●     Fixed bug that could cause DHTML Menu Builder to crash reporting an error on the xfxdll.

dll file.
●     Engine 1.1 is released

●     Fixed bug that was causing some problems with Internet Explorer 5 for the Macintosh.
●     Fixed bug that was causing the menus to stop working after a long period of use under 

Navigator 4.
●     Fixed bug with the Leading parameter not being applied to the spacing over separators.
●     Fixed bug with the use of images in the toolbar. Under Navigator the image for the over 

event wasn't being displayed.
●     The generated code now supports the Navigator 4 resize bug. The fix was taken from the 

excellent code created by the JavaScript gurus at DHTML Lab.
●     The engine has been enhanced to produce more accurate results based on the different 

parameters that affect the size of the menus.
●     Compilation time and memory usage have been slightly reduced.
●     The menus responsiveness to mouse actions has been considerably increased for Internet 

Explorer and Navigator 6.
●     The overall look & feel of the menus is much better across all the supported browsers.
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●     The documentation for each dialog has been updated with important crossbrowser and 
crossplatform compatibility notes.

●     Several new sections have been added to the documentation:
●     Anatomy of a Menu
●     Sharing Projects
●     Acknowledgments

●     Enhanced Live Preview now produces more accurate results, almost identical to the Internet 
Explorer browser output.

●     A new AddIn is now available. The DropShadow PRO AddIn will create gradient and semi-
transparent shadows for Internet Explorer 5.5 and above.

14/Aug/2001

●     Engine 1.0.404 is released
●     Fixed bug with the Spanning setting of the toolbars.

13/Aug/2001

●     DHTML Menu Builder 3.0.658
●     Maintenance Release

●     Engine 1.0.403 is released
●     The menus should work fine under explicit DOCTYPE declarations. A few known issues 

still exist that may cause unpredictable results.
●     Improved the Live Preview to display open accents, commonly used in French and fixed a bug 

that was producing incorrect alignment results of the selected item's caption.

09/Aug/2001

●     DHTML Menu Builder 3.0.657
●     Fixed a problem importing projects created with older versions of DHTML Menu Builder.
●     Updated the validation system which should hopefully provide a more stable connection 

to our validation servers.
●     Fixed bug with the Color Picker Dialog. Minor enhancements have also been made to 

avoid the input of invalid color codes.

08/Aug/2001

●     DHTML Menu Builder 3.0.656
●     Fixed a problem with project handling routines. Under some circumstances a project 

could not be loaded after setting up the FTP support.
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●     Fixed bug in the Validation process
●     The Help Viewer is now a separate application. Now you can view the Help while working 

on DHTML Menu Builder. This will also reduce the resources required to run DHTML Menu 
Builder.

●     Engine 1.0.401 is released
●     Maintenance Release

02/Aug/2001

●     DHTML Menu Builder 3.0.650
●     Added new options to the Compiler Options dialog:

●     Enable/Disable the compilation of code for recent browsers (IE4, 5, 5.5 and 6, 
NS6/SM and OP5)

●     Enable/Disable the compilation of code for Navigator 4
●     Enable/Disable the creation of the hRef.txt file
●     Support for Shared Projects. Enabling this option will allow you to use several 

projects on the same page.
●     Fixed bug that caused the program to crash when you tried to change the color of a 

group item when this group was the only item in the project. (The fix in version 3.0.627 
didn't completely fix the problem)

●     Engine 1.0.400 is released
●     Fixed a bug that affected the position of context menus when an offset setting for root-

level groups was being used.
●     Fixed compatibility issue with Internet Explorer 4.0. The fix applies to the template code and all 

the AddIns distributed with DHTML Menu Builder.
●     Updated some of the sample projects.

29/Jul/2001

●     DHTML Menu Builder 3.0.632 is released
●     Fixed a problem with the HotSpots Editor as it was not attaching any onclick actions to 

the hotspots.

27/Jul/2001

●     DHTML Menu Builder 3.0.631 is released
●     Fixed several problems with the HotSpots Editor

●     The HotSpots Editor should no longer freeze when closing it.
●     Fixed a bug that caused an error when implementing the code into a non-standard 

HTML file.
●     Fixed problem validating orders placed via RegNOW!

26/Jul/2001

●     DHTML Menu Builder 3.0.630 is released
●     Fixed several problems with the way the Project Properties was handling the 
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●     Working on any configuration after a configuration deletion no longer generates 
an error.

●     Changing the associated remote configuration in the FTP support tab, is now 
reflected without having to close the Project Properties dialog.

●     Tooltips on the main dialog are now properly localized.
●     Engine 1.0.395 is released

●     Fixed bug in the way the engine was encoding URLs.
●     Minor enhancements have been made to the compression algorithm resulting in smaller .

js files.
●     Minor changes have been made to this documentation.
●     The template code (and the AddIns distributed with DHTML Menu Builder 3.0) have been 

updated to overcome a compatibility issue with very old versions of Navigator 4.

24/Jul/2001

●     DHTML Menu Builder 3.0.628 is released
●     Fixed bug that caused DMB to crash while loading the frames information from a file 

located in a non existing shared resource.
●     Fixed a memory access bug that could cause DMB to crash after setting the paths 

information of a local configuration.

20/Jul/2001

●     DHTML Menu Builder 3.0.627 is released
●     Fixed bug that caused the program to crash when you tried to change the color of a 

group item when this group was the only item in the project.
●     Engine 1.0.392 is released

●     A serious bug is fixed: Toolbar items that perform some sort of action when clicked are 
not correctly compressed and generate an error under Navigator 4.

●     The setup now uses lower quality images to save space in the final installer executable.

19/Jul/2001

●     DHTML Menu Builder 3.0.626 is released
●     Fixed display problems under IE/SM/OP when using background images in the commands.
●     Fixed bug in validation process as it would not process companies with a "," in their name.

●     Engine 1.0.391 is released
●     Fixed bug in parsing URLs with an underscore.

●     Updated all the AddIns that are distributed with DHTML Menu Builder with the latest code.
●     Updated several language packs.
●     Fixed bug that left some items un-translated when switching languages packs.
●     Fixed bug that left some resources un-translated.
●     Added a Help button in the Registration dialog. Clicking on this button will provide assistance on 

the registration process.
●     Enhanced the returned information when the Validation process fails.
●     Fixed compatibility problem between the toolbar code and very old versions of Navigator 4.
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16/Jul/2001

●     Official DHTML Menu Builder 3.0 Release (3.0.625)
●     Official Engine 1.0 Release (1.0.390)

This is a list of what's new in version: 2.8.14

●     Maintenance release.

This is a list of what's new in version: 2.8.12

●     Maintenance release.

This is a list of what's new in version: 2.8.11

●     Fixed bug that caused all the commands to have a one pixel separation even when setting 
the Leading value to its minimum.

●     Added more optional values to the Border Size of the commands highlight effects, including 
the (none) parameter which will allow you to create menus that have commands stacked with 
no visible separation between them.

This is a list of what's new in version: 2.8.10

●     Maintenance release.

This is a list of what's new in version: 2.8.9

●     Enhanced the way the leading setting affects the separation of each command.
●     Enhanced the positioning of submenus. Now submenus appear perfectly aligned to their 

parent commands.
●     Fix bug with the menus under Navigator 4 that could cause a JavaScript error.
●     Improved the way DMB asks for folders preventing you from selecting files or folder from 

outside your root web.
●     Enhanced groups' background image previewing.

This is a list of what's new in version: 2.8.8

●     Fixed bug when calculating the relative path of the JS files, images and links.
●     DMB will now check for valid names when crating or renaming a group or command item.

This is a list of what's new in version: 2.8.7
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●     Maintenance release.

This is a list of what's new in version: 2.8.6

●     Fixed problem where DMB would try to save a menu's project as an HTML file.
●     Fixed bug in the ContextMenu AddIns (Thanks to NJ for making us aware of this issue).
●     Fixed error when opening a project Can't Find DLL entry point GetLongPathName in kernel32.

This is a list of what's new in version: 2.8.5

●     Maintenance release.

This is a list of what's new in version: 2.8.4

●     Fixed JavaScript error 'OpenMenus[...].SelCommand' is not an object.
●     Fixed bug that prevented DMB from correctly parsing Actions using the "mailto:" protocol.
●     When calculating the width of the commands, the "&nbsp;" parameter is no longer taken into 

consideration, fixing a problem where the menus should result too wide compare to their 
contents.

This is a list of what's new in version: 2.8.3

●     Fixed bug that was causing cascading commands to loose their target group when a group 
was deleted from the project.

●     Cosmetic improvement for file handling... no more "~" characters on the Recent File list nor 
the Project Properties dialog.

This is a list of what's new in version: 2.8.2

●     Fixed several bugs with the way DMB calculated the positioning and size of the different 
elements that compose the menu's elements.

●     Improved performance of the compiler resulting in a 7% speed increase.

This is a list of what's new in version: 2.8.1

●     Fixed bug when launching the HotSpot Editor and using an URL instead of a direct link to a 
file in the Final HTML Document setting of the Project Properties.

●     Several enhancements to the HotSpot Editor will fix a problem where you didn't get any 
errors but the trigger code got never inserted.

●     Several minor internal enhancements.

This is a list of what's new in version: 2.8

●     Minor internal enhancements to the HotSpot Editor.
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●     Enhanced engine: 
❍     When compiling commands with no caption, no code specifying text attributes will be 

generated, minimizing the size the of the scripts.
❍     Commands are now properly vertically aligned when the height of the command is 

taller than the contents it self. This fix only applies to Internet Explorer, Navigator 6 
and Opera 5

❍     Better support for Opera 5.01
●     Minor corrections to this help file

This is a list of what's new in version: 2.7.8

●     Minor maintenance release.
●     Improved detection code to detect the presence and version of Internet Explorer.

This is a list of what's new in version: 2.7.7

●     Minor maintenance release.

This is a list of what's new in version: 2.7.6

●     The HotSpot Editor will no longer add the <tbody> and </tbody> tags to the HTML 
documents.

●     Enhanced support for cascading menus under Navigator 6.
●     Enhanced code generation for Internet Explorer and Navigator 6 which produces smaller JS 

files.

This is a list of what's new in version: 2.7.5

●     Even more safety checks. This will prevent DMB from crashing when the Root Web or the 
Folder to Store Compiled paths contain invalid entries.

●     Small enhancements to the scripts.

This is a list of what's new in version: 2.7.4

●     Fixes the timeout problem with the frames detection dialog.
●     Fixes a bug introduced by the new safety checks incorporated into the HotSpot Editor by the 

2.7.3 version.

This is a list of what's new in version: 2.7.3

●     Added more safety checks to the HotSpot Editor to avoid potential problems.
●     Fixed sever problem with the Undo/Redo feature.
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●     Fixed potential problems while importing projects created with very old versions of DMB.

This is a list of what's new in version: 2.7.2

●     Changed the way the browser version is calculated.
●     Better support for Navigator 6 (which still isn't working 100% yet).
●     Added some debugging code to the HotSpot Editor to better troubleshoot some of the most 

common problems.
●     Minimized the problem that causes Navigator to issue, under some circumstances, a 

JavaScript error message about "OpenMenus[nOM]". This is still being investigated.
●     Enhanced detection code for the automatic retrieval of frames information.

This is a list of what's new in version: 2.7.1

●     Fixed bug that was causing the scripts to fail under Navigator when some scripts from 
DreamWeaver were being used on the same page.

●     Fixed bug that was causing the commands to appear slightly misplaced, with the wrong width 
and height under Navigator.

●     Fixed bug that when using the DropShadow effect, was causing the last command on the 
groups to appear larger. 

●     Fixed bug that was causing problems with the scripts when using very old versions of 
Navigator.

●     Minor enhancements to the Navigator scripts. This makes it possible to decrease the size of 
the Navigator portion of the code.

●     Minor enhancements have been made to the internal JavaScript compressor engine, 
delivering about 2% smaller JavaScript files.

●     The Command Highlight Effects setting is still not functional under Navigator, but you can use 
it to make your commands look wider and taller (similar to a margin setting). This now works 
under Navigator too.

This is a list of what's new in version: 2.7

●     Major improvements in the rendering engine. 
❍     Menus under Internet Explorer and Navigator 6 are no longer rendered using tables, 

providing a better looking menus with better crossbrowser/crossplatform compatibility.
❍     Separators are now rendered much better than in version 2.6.
❍     Submenus now appear perfectly aligned to their calling commands under Internet 

Explorer and Navigator 6.
●     Support for Navigator 6 is almost complete. Some problems still exists with submenus though.
●     Navigator now displays a one-color border based on the Light Corners color.
●     Fixed compatibility problems with Navigator for Linux (and other UNIX flavors probably).
●     Many scripts enhancements in order to keep the compiled scripts as small as possible.
●     Preliminary support for the Opera 4.02 browser when configured as "Mozilla 5.0".
●     Fixed bug that caused DHTML Menu Builder to crash when no printer was available.
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This is a list of what's new in version: 2.6.5

●     Fixes compatibility problems with Internet Explorer 5 for the Macintosh
●     Menus are automatically hidden, after a period of time, when the mouse moves away from 

the hotspot
●     Implements better menus behavior based on numerous users requests

This is a list of what's new in version: 2.6

●     Adds support for infinite cascading levels (submenus)
●     Fixes a bug in the copy/paste code
●     Increased support for frames
●     New Cursor property for each group (supported only under Internet Explorer for Windows)
●     The unfolding effects are now working for Navigator again
●     Even smaller JavaScript code generation
●     Many improvements and bug fixes have been made to the AddIn Editor. Now is easier to 

upgrade your custom AddIns
●     To install an AddIn just double-click its icon and it will be copied to the AddIns folder 

automatically
●     Huge user interface enhancements
●     Support for images in the commands has been enhanced allowing the use of two separate 

images, one to the left and the other to the right of the command's caption
●     Unlimited Undo/Redo capability. With this new feature you're no longer required to save your 

project when previewing or compiling
●     Added a list of all the used colors in the current project when working on the new Color Picker
●     Removed the Absolute Path setting in the Project Properties... it was too confusing for some 

users. Now, DHTML Menu Builder will automatically generate the correct absolute path to the 
JS files, the images used in the menus and the links

●     Added a browse button to select the target files when setting the action of a command
●     Added a new option in the Project Properties, Use Full Paths. use this option to select 

whether your menus will be viewed from a local folder or from a web server
●     Fixed a bug that caused that deleted, renamed or moved items will still preview and compile 

just as if they were never deleted, renamed or removed
●     The menus are now automatically repositioned so they don't disappear outside the browser's 

client area
●     By request, removed the CTRL+X shortcut to close the program
●     You can also use the F12 shortcut key to to start the Preview
●     You can now choose to preview to an external browser
●     Major updates have been made to the HotSpot Editor. 

It should now detect a hyperlink no matter how deep it is placed inside nested tables or other 
similar tags (such as span's, div's, etc...) 
Support for imagemaps has been removed due to the numerous problems this was causing.

●     The JavaScript template that DHTML Menu Builder uses has been rewritten almost 
completely, fixing bugs and adding new features

●     The Preview template has been completely modified
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●     The DEMO version is now capable of saving all the different parameters so you can preview. 
This way you will get a much better idea of what DHTML Menu Builder is capable of. 
The only disabled features in the DEMO version are: Compiling, the HotSpot Editor and the 
option to preview to an external browser

This is a list of what's new in version: 2.5.103

●     Frames support is finally available!
●     AddIns support and integrated AddIn Editor to expand the capabilities of the program
●     The setup will install two AddIns that show some of the potential the new feature adds to the 

program
●     The URL property has been renamed into Action. Also, this Action can be disabled so the 

command does not respond to any mouse actions... ideal to mimic disabled menu items!
●     The text is now properly aligned on the commands for Navigator
●     Better cascade menu alignment for Internet Explorer
●     The Java Script part of DHTML Menu Builder has been rewritten almost entirely
●     Lines, or command separators, now support coloring
●     The Project Properties dialog has been enhanced to show the project file location, support for 

frames and support to select an AddIn.
●     The two optimization options have been renamed to better reflect what they actually do and 

what are they for
●     The Preview, Compile and HotSpot Editor menu options have been moved from the File menu 

to a new menu called Tools
●     New Color Picker will let you use the common Windows Dialog to choose colors, enter your 

colors manually in Hex format or use a color picker to choose from any color on the screen
●     When using the optimization method, the compiled JS files are now even smaller! 

Even when the program now produces more lines of code (and much larger lines due to the 
new features that have been added) the JS files can be up to 10% smaller than those 
compiled with version 2.4!

●     This documentation has been updated to reflect all the new features of this version
●     Builds 112, 115, 121, 125 and 126 are maintenance releases to improve the frames support 

and Macintosh compatibility

This is a list of what's new in version: 2.4

●     New Effects: 
❍     Raised/Sunken effect for the commands of a group
❍     Transparency effect for a group
❍     Drop shadow effect for a group

●     Enhanced Upgrade function. Now you can see the download progress and the amount of 
bytes downloaded. You can also stop the operation at any time.
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●     The compilation time has been reduced dramatically!
●     Several bug fixes for the compilation engine
●     Cascading menus no longer overlap their parents

This is a list of what's new in version: 2.3

●     The Position Agent tool is no longer available because it has been merged with the HotSpot 
Editor

●     The HotSpot Editor has been improved 
❍     Now is a graphical / WYSIWYG tool
❍     It attaches the code to the hotspots, sets the position of the menus and also 

implements the loader code... no more manual (copy/paste) editing is need it!!!!
●     Improved compatibility for Internet Explorer 5.0 for the Macintosh
●     The JS files, when compiled with the "for Size & Speed" setting, are now about 30% smaller.
●     Images are correctly displayed and aligned on the commands
●     A new option, Help->Upgrade, is available for easier upgrading of the program
●     The commands are correctly spaced, vertically, under Navigator
●     The documentation has been updated to reflect the changes in this new version
●     The Windows's Common Color Dialog is now correctly updated with the currently selected 

color
●     The background image property of the groups is now functional when the menus are viewed 

with Navigator
●     Several cosmetic enhancements
●     And as always... several bug fixes

This is a list of what's new in version: 2.2

●     The Leading property is now functional when the menus are viewed with Navigator
●     The Frame border size property is now functional when the menus are viewed with Navigator
●     The menus, when viewed under Navigator, are rendered much better, resulting in a much 

better cross-browser compatibility
●     Under Navigator, the flickering of the commands when moving the mouse pointer is now no 

longer perceptible
●     The width and height values of the menus is now calculated in much better way, resulting in 

more accurate results
●     When a cascade menu is displayed, the parent menu is closed properly
●     This documentation has been updated according to the changes in the program
●     The "Size & Speed" optimization method can now be used on ASP pages
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This is a list of what's new in version: 2.0

●     Main Window is now resizable
●     Both, the main window and the preview window remember last position/size
●     Added support for random unfolding effect
●     Minor UI enhancements
●     Added support for background image in menu groups
●     Now, when adding a command is inserted it after the selected one, instead of putting it at the 

end of the list
●     New Auto function on the Color Properties dialog sets an appropriate combination of colors 

for the Mouse Over event
●     All the properties dialogs reflect all the other properties on the sample label
●     New property has been added to support per command alignment
●     Enhanced Copy / Paste dialog, now gives even more flexibility
●     Hot Spot Editor lets you select where to place the "trigger" code on the target HTML 

document
●     Option to change the generated code optimization for either: 

❍     Easier implementation (same as v1.5)
❍     Smaller file size (up to 60% decrease!)

●     Faster loading and compilation times
●     Enhanced compilation code: 

❍     Fonts size under Navigator should look better
●     The Project property Relative Path has been changed to Absolute Path
●     The help documentation has been revised and updated with all the new features
●     Context sensitive help has been implemented on almost every displayed dialog

This is a list of what's new in version: 1.5 (final release)

●     Frames support has 
been removed. 
Anyway, we're 
currently working to 
release an update 
which will have full 
support for frames. 
There's no release 
date, yet. Check our 
web site for more 
information.

●     Fixed problem that was 
causing, on some 
configuration, to show 
two menus at the same 
time.
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●     Fixed the annoying 
runtime error 5! 
Thanks Matthew!!!

●     The shareware version 
is no longer shareware, 
but a demo. 
The limitations are: 

❍     You can not 
customize the 
font 
properties of 
the commands

❍     You can not 
customize the 
color 
properties of 
the commands

❍     You can not 
customize the 
image 
properties of 
the commands

You can, however, set 
the default font and 
color properties of 
every command using 
the Color and Font 
properties settings of 
its parent group. Click 
here to know how to 
do this.

I'm really sorry for this, but 
its the only way I had to 
fight piracy. Version 1.5.80 
(which was beta 3/4) was 
being pirated, and there 
were two cracks from two 
different groups available all 
over the Internet! 
I just don't think is fair to 
crack a US$25.00 program! 
(1.0 and 1.5 beta versions 
were available at US$25.00) 
So don't blame me... and 
blame it on Syndicate and 
LASH.p

●     Fixed the problem with 
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the disabled OK button 
in the Browse For 
Folder dialog, when 
DHTML Menu Builder 
was being run under a 
non-English Windows 
version.

●     The documentation has 
been revised and 
updated with all the 
information that covers 
the new functions and 
options of version 1.5. 
I've also included a 
couple of sample pages 
to illustrate the 
implementation of the 
menus.

●     Many bug fixes! As 
usual.

●     The price has increased. 
Why? Well, because the 
engine was upgraded to 
support Navigator. 
Ok, Navigator may be a 
great browser, but its worst 
than a nightmare to the 
developers due to the huge 
limitations and the poor 
implementations of DHTML 
and CSS standards plus the 
limited document object 
model flexibilities. 
It took me about 2 weeks to 
code version 1.0... and it 
took me near three months 
to crate an acceptable 
engine that was capable of 
generating Navigator 
compatible code... go figure!

This is a list of what's new in version: 1.5 (beta 3, 4 and RC1)

●     Preliminary frames support! 
This feature has been added for testing purposes only, but will probably be removed by the final release, since 
there's no time to finish the necessary modifications to make it work with Navigator

●     Fixed problem with the menus unexpectedly stop working under Navigator when using 
unfolding effects
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●     Better height calculation of the menu groups under Navigator
●     Fixed a problem that was causing DMB to generate invalid code when using URLs with 

parameters, such as 
http://domain.com/page.asp?type=user

●     The documentation is almost finished...
●     The Copy Color command, when used against groups, now copies the frame settings too
●     Fixed? Problem with the hyperlinks in the About dialog
●     Fixed some problems with the image handling code

This is a list of what's new in version: 1.5 (beta 2 second release)

●     Support for Netscape is about 95% complete
●     New Leading option lets you set the spacing between each menu command
●     Image support for the menu commands is finished
●     New project property, Relative Path added
●     Now, DMBuilder will check for invalid groups and commands names
●     It will also check for invalid characters in the URL and Status fields
●     The help document has been slightly updated
●     A couple of bugs have been fixed
●     A couple of UI enhancements

This is a list of what's new in version: 1.5 (beta 1)

●     Preliminary support for Netscape browser
●     The new Position Agent, lets you position your menus in a WYSIWYG interface
●     Support for one level cascading menus
●     Recent projects list to access your projects faster
●     Preliminary support to add images in the menu commands
●     New toolbar lets you access more options faster
●     Some shortcut keys have been changed
●     Unfolding pulldown menus effects lets you add fancy effects to your menus when they are 

shown, a-la-Office!
●     New help system, using the compiled HTML Help System, which is now common to many 

Windows applications
●     A couple of bugs have been fixed
●     A couple of UI enhancements

This is a list of what's new in version: 1.0

●     First release of DHTML Menu Builder, never made public.
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