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This tutorial focuses on the basic steps involved in creating an attractive, functional 
website. In using this tutorial you will learn to design a site layout, insert images and 
text, create links, and how to upload your site to the Internet. This tutorial offers 
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Before you get started, it is important that you have a space to upload your Web site 
When it is completed. BGSU offers 15 MB of free personal Web space for each 
student, so you can use this space to upload your project.  

To activate your personal Web space, follow these steps:  

1. Log onto your MyBGSU Account.  
2. Scroll to the bottom of the page to find the My Computer Accounts box (Fig. 1).  
3. Click the Add Server Account button.  
4. In BGSU Server Account Registration window, check the box next to Personal 

(Fig. 2).  
5. Click the Submit button. Now your Web space is activated.  
 
NOTE: An email will be sent when your account is activated  

Fig. 1. My Computer 
Accounts window  

Fig. 2. BGSU Server Account Registration  
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CREATING YOUR LOCAL ROOT FOLDER  

First, you need to decide what you want to put on your website: images, buttons, 
videos, PDF documents, PowerPoint presentations, etc. To create and maintain an 
organized website, you need to establish a hierarchy of folders that contain all of the 
components that make up your site. This folder is called your Local root folder. This 
folder is important because this is where Dreamweaver looks for all your files.  

To create a root folder, follow these steps:  

1. Create a new folder on your desktop. On a Mac, click File > New Folder. On a 
PC, right-click and choose New Folder.  

2. Give the folder a brief, but descriptive name. Do not use capital letters, spaces, 
or special characters when naming folders and files for your website. All of your 
pages will be saved within this folder.  

3. Open the folder, and create another new folder inside. Name this folder images. 
Put all of your images, buttons, movie files, etc. inside the images folder.  

 
NOTE: Make sure that all your pages and images are saved in your root folder, or 
they will not appear the next time your website is opened.  

MANAGING YOUR SITES  

Now you are ready to launch Dreamweaver CS4. On a Mac, click the Dreamweaver 
CS3 icon from the Dock. On a PC, click Start > Programs > Macromedia 
Dreamweaver CS4.  

The most important step you need to take every time you launch Dreamweaver CS4 
is to define your Local Info. The local root folder is the name for the folder where 
you are storing all of your website’s contents.  

To define a site, follow these steps:  

1. Click Site > Manage Sites.  

NOTE: If you are using Dreamweaver CS4, go to Site > New Site.  

1. Click New > Site.  
2. Select the Advanced tab.  
3. Enter a name for the site in the Site Name text field (Fig. 3). (This name will be 

for your use only – it will not be published with your site.)  
4. Click the small folder icon next to the Local Root Folder text field.  
5. Navigate through the folders on the computer and/or disk and locate the folder 

that you have designated for your website project (local root folder).  
6. Select the designated folder and click the Choose button.  
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Fig. 3: Local Info tab.  
 
 
Follow the same steps above to choose your Default Images Folder, which is 
located in your Local Root Folder.  

Next, every time you launch Dreamweaver, you have to define your Remote Info. 
The Remote Info tab is used to tell Dreamweaver where to put your files when you 
are ready to upload them to the web. If you are using the BGSU personal server 
space, use the diagram below (Fig. 3) to fill out the information. (If you are using any 
other server you will need to know the host name.)  

To define the remote info, do the following:  

1. Click on the Remote Info (Fig. 4) tab located on the left side of the toolbar.  
2. Select FTP in the Access field.  
3. Type in personal.bgsu.edu for FTP host.  
4. Type in public_html for Host directory.  
5. Type in your webmail username for Login.  
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6. Type in your webmail password for Password.  
7. Make sure the Use passive FTP box is checked.  
8. Click Test to make sure it connects to the server correctly.  
9. Click OK.  
10. Select your site name and click Done.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Fig.4: Remote Info tab  
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To create a Web page, follow these guidelines:  

1. To add a new page go to File > New and choose a basic HTML page. Save this 
page by clicking File > Save As. Name the first page index.html. This will be the 
first page that users encounter when they visit your site. Save this file to your 
local root folder as index.html. Naming the homepage index.html tells the Web 
browser that this is the first page it should open when someone visits your site.  

2. After your homepage index.html is created, you can use this page as a template 
layout for all the other pages in your site. Simply hit Save As and name the file 
whatever you wish, but be sure to keep the name is simple, for example 
history.html, resume.html, etc. Remember not to use capital letters or spaces 
when naming files, this will make it easier for web browsers to find your files.  

3. To save the pages of your site simply click File > Save for each page. Make sure 
your homepage is named index.html, and save all of your files in the folder you 
chose when you defined your site, i.e. in your local root folder.  

 
NOTE: This process will save your files to your local site. You can transfer each 
file separately to the remote site or transfer the entire site once you have finished 
working on it.  
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Even if you are creating only a simple Website, you should begin by sketching out 
the layout of your site. Decide where you want titles, images, navigation buttons, 
and text to appear on the screen.  

Most web sites have the same design characteristics on every page. For example, 
Website titles are usually in the top left or top center, while navigation buttons usually 
appear vertically on the left or horizontally below the title. In addition to sketching out 
a layout for each page, you should determine how many pages you will need for the 
Website. Thorough planning is essential to good web design.  

In order to get your text, navigation buttons, and images to appear where you want 
them on the Web page; you need to use tables to format content of each page. 
Everything on each page of your Website should fit within one large table.  

Using your layout sketches, you can determine what your table needs to look 
like. Fig. 5 shows a simple layout sketch. Fig. 6 shows the same layout, with 
table borders drawn in. Fig. 7 and Fig. 8 show how the table can be 
implemented in Dreamweaver.  

Now, simply create a table in Dreamweaver that has the same characteristics as 
the borders drawn on the page. The next chapter will teach you how to insert 
your table.  

Fig. 5: Simple layout sketch                                         Fig.6: Simple layout sketch with borders  
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Fig.7: Common Layout with Columns                      Fig.8: Common Layout without Columns     
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WHY USE TABLES  

Tables help you divide the space on your page. They are similar to tables in Word or 
Excel but can be used in much more flexible ways. Tables give you the option of 
making your page a fixed size or making it fit to the user's window the best it can. 
Tables also guarantee that the location of your text and images does not change 
when seen on screen with different resolutions or in different Web browsers.  

HOW TO INSERT A TABLE  

To insert a table, follow these steps:  

1. In the main menu, click Insert > Table.  
2. Insert the amount of Table Rows and Columns (Fig. 9).  
3. Set Table width to between 600 and 800 pixels.  
4. Set Border thickness. To have a visible border type in 1 or higher, to have no 

border type in 0.  
5. Cell padding adds room inside of a cell. Enter 0 for no space or a number to 

Increase the space.  
6. Cell spacing adds space between cells. Enter 0 for no space or a number to 

Increase the space.  
7. Click OK.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                                    Fig.9: Table window  
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PROPERTIES OF TABLES  
 
If you click on one of the table borders, you can view your table properties in the 
Properties window.  

(Fig.10: Table Properties Window) 
 
In the top section of this window (Fig.10) you can:  
 
• name your table;  
• change the number of rows and columns in the table;  
• change the width and height of the table,  

• using percent: this will make the table expand and contract as the 
user changes the size of the window,  
• using pixels: this will make the table a set number of pixels no  
matter what size the user's window is (there are 72 pixels/inch);  

• change the Cell Pad: this is the number of pixels that come between the 
border of cells and the content of cells.  

• change the Cell Space: this is the number of pixels that come between the 
borders of each cell.  

• change the alignment: this is the position of the table on the left or right edge, 
or in the center of the page.  

• change the border: this is the number of pixels that make up the thickness of 
cell borders. 
 

In the bottom section of this window (Fig.10) you can:  
 
• Clear and convert table widths and heights.  
• Change the background color of the whole table.  
• Insert a background image for the whole table.  
• Change the border color.  
 

Properties of Cells Inside Table  

Once the properties of the table have been set, you can also adjust the properties of 
individual cells within the table by clicking inside the cell (Fig.11).  

In the top section of this window you can format the text inside the table cell. In the 
bottom section of this window you can:  
 

• Merge and split cells (this will be explained in the layout section).  
• Change the alignment of the content horizontally and vertically.  
• Change the width and the height of the cell (numbers alone represent 

pixels, add a percent sign to make the cell a certain percentage of the 
whole table).  
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• Use Wrap.  
• Insert Header;  
• Insert a background image for the single cell.  
• Change the background color for the single cell.  
• Change the border color for the single cell.  

 

Fig.11: Table Format window  

Here is an example of a page with a background color selected for the page, for each 
table, and for some specific cells in each table (Fig.13).  

Fig.13: Background color, table color, cell color  

CREATING YOUR DESIRED LAYOUT  

To create the traditional layout, follow the directions below:  
 
1. Insert a table with 3 rows and 3 columns that takes up 100% of the page.  
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2. Highlight the first row of cells by placing your cursor in either far left or far right 
cell and dragging to the other side. 

3. Use the bottom section of the Properties window to merge the cells you have 
selected (use the button right under the word "Cell"). This section will be used for 
the title of your page.  

4. Highlight and merge the bottom row. This section will be used for information 
such as your contact info and the date the site was last updated.  

5. Highlight and merge the middle and right cells in the middle row. This section will 
be used for your main content, and the leftover cell will be used for links.  
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6. Now you can adjust the table by clicking and dragging on the handles to make 
the table look more like a familiar webpage (if you have problems dragging the 
handles you can use the Properties window to manually insert the number of 
pixels or percent of the table for the width and height of the cell).  

 

 
From here you can insert additional tables into any of the cells you want. This will let 
you place your text and images exactly where you want them within each section.  
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ADDING TEXT  

To insert text simply click inside a cell and type in your content. When you click 
ENTER, Dreamweaver automatically adds paragraph spacing. To add a line space, 
click SHIFT + ENTER.  

INSERTING IMAGES  

To insert an image, follow these steps:  

1. Click in the cell where you want the image to appear.  
2. Click Insert > Image.  
3. Locate the image you want to insert.  

      NOTE: All of your images should be saved in the "images" folder that you established 
when you started.  

4. Click Choose to insert the image.  
 
Click on the image to view its properties in the Image Properties Inspector 
window (Fig.14).  

Fig.14: Image Properties Inspector window  

IMAGE PROPERTIES INSPECTOR 

The top half of the Image Properties Inspector allows you to:  
 

• Name the image (far left).  
• Change the size of the image (W&H).  
• See where the image file is located (Src).  
• Link the image to a file or a site (Link).  
• Edit the image (Edit).  
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The bottom half of the Image Properties Inspector allows you to:  

• Add a hotspot over the image (Rectangular, Oval, and Polygon 
Hotspot  

• Select target if you made your image a link (Target);  
• Add a border to your image (Border).  
• Change alignment (Align).  

 

(Fig.15: Page Properties Window )  

FORMATTING PAGE PROPERTIES  

To change the background color of your pages or other overall properties of your 
website, go to Modify > Page Properties. Here, in the Page Properties window, 
you can set the default font, text size, text color, and background for all of your pages 
(Fig.15).  
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Fig.15: Page Properties Appearance window To modify the properties of links, click 
on the Links tab under Category. Here you can Dreamweaver CS4 18 set link font, 
size, link color, color of active, rollover, and visited links, as well as link style (Fig.16).  

Fig.16: Page Properties Links window  
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TO PREVIEW IN A BROWSER 

You can preview your Web pages in a browser in many ways:  
 
1. Choose File > Preview in Browser.  
2. Hit F12.  
3. Click on the world icon located on the toolbar at the top of your page (Fig.17).  
 

Fig.17: Preview in a browser.  

TO ADD A NEW BROWSER  

If you want to add a browser to the list, follow these steps:  

1. Click the plus button to add a browser to your list.  
2. Select the browser in which you would like to view the document. If there is not 

another browser listed, choose Edit Browser List under the Preview in Browser 
option and add browsers.  

3. Click OK (Fig.18).  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig.18: Add browser in Preferences window  
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A hyperlink or link, is an object or text that, when clicked, takes the users to 
another webpage or opens a file. The various types of hyperlinks are 
explained below.  

INTERNAL LINKS  

Internal links are used to connect users to other pages within the same website. 
Before linking to other pages, you must make sure that the other pages are saved 
in your local root folder and contain the file extension .htm or .html.  

To create an internal link, follow these steps:  

1. Select the text or image you would like to make a hyperlink.  
2. Click on the small folder next to the Link field in the Properties Inspector 

(Fig.19 and 20).  
3. Browse through the files, and select the page you would like to link.  
4. Click Choose.  
 

Fig.19: Text Properties Inspector  

Fig.20: Image Properties Inspector  

EXTERNAL LINKS  
 
External links are used to connect the users to pages from other websites.  
 
To create an external link, do the following:  
 
1. Select a text or an image you want to make a hyperlink.  
2. Click the cursor inside of the link text field in the Properties Inspector.  
3. Type the complete URL (web address) of the website you want to link  
   (e.g. http://www.bgsu.edu).  
4. Select the Target type as -blank.  
 
NOTE: If you select the Target type as -blank, it will open the link in a new window 
while keeping your website open in another window. Doing this is good practice 
because it will prevent the user from being frustrated and leaving your site.  
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LINKS TO FILES  

Sometimes you may need to link a file such as a PDF, a Word document, or a 
PowerPoint presentation. When the user clicks the hyperlink, the files will either 
automatically open up in its original program, or the browser will prompt the user to 
save the file on their hard drive.  

To create a link to a file, follow these steps:  

1. Make sure that the file you want to link is saved in your root folder.  
2. Select a text or an image you would like to make a hyperlink.  
3. Click on the small folder next to the Link field in the Properties Inspector 

(Figure 22).  
4. Browse through the files, and select the file you would like to link.  
5. Click Choose.  
6. Select the Target type as -blank.  
 
NOTE: To embed a PowerPoint presentation, go to the Inserting Special Media 
page for instructions.  

Back to top  

BASIC EMAIL LINK  

E-mail links are links that will automatically open the user's default email program 
with a blank e-mail addressed to the specified e-mail link.  

There are two ways to create an email link. You can:  

1. Click on the Insert menu at the top of the screen and select Email Link.  
2. Type in text for the hyperlink name or label, for example: My Email or Click here 

to email me (Fig.21).  
3. Type in your email address, i.e. where the email is to be sent.  
4. Click OK.  

 

Fig.21: E-mail Link  window  
 
OR, you can:  
 
1. Select the text you want to be your email link.  
2. In the Properties window in the Links field, type in mail to: 

yourusername@bgnet.bgsu.edu, or any other email address you want to use as 
your contact (Fig.22).  
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3. Select Target type as -blank. NOTE: You can type in only one email address.  
 

 

Fig. 22: E-mail Link in Properties window  
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Fig.23: Rollover Image window  

ROLLOVER IMAGES   
 
Rollover images allow you to have a graphic change to a different graphic when the 
mouse rolls over it. To insert a rollover image, do the following:  

1. Click on Insert > Image Objects > Rollover Images.  
2. In the Insert Rollover Image dialog box under Original Image, browse for the 

image that is to be seen before the mouse rolls over it (Fig.23).  
3. Under Rollover Image browse for the image to be seen when the mouse rolls 

over it.  
4. In the When clicked. Go to URL field, you can enter a link by typing in the web 

address or browsing to a file.  
5. Click OK.  
 
QUICKTIME MOVIE  
 
To insert a movie, follow these simple steps:  
 
1. Click on Insert > Media > Plug-in.  
2. Navigate to the desired file.  
3. Click Choose. NOTE: By default the QuickTime is viewed in a very small 

window; to make the window larger, click on it once and drag one of the corners 
to the desired size. Make sure the movie file is located in your local root folder.  
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EMBEDDING A POWERPOINT PRESENTATION  

To insert a Power Point Presentation, do the following:  
1.  Open a project in PowerPoint.  
2.  Click Save as Web Page.  

      3.  Put both the .html and the folder of files created in PowerPoint into your local root   
           folder.  
 
      NOTE: The file .html is now your PowerPoint embedded into a Web page; you can 

double-click on it to open it in a browser.  
 

4. Insert a link to your PowerPoint .html file. Now if the user clicks on the link, your 
presentation will open.  
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To upload your site to the Web successfully, you must make sure that you defined 
your Local Info and Remote Info before you did anything else in Dreamweaver. If 
you are working on a different computer and forgot to define your site, follow the 
steps on Getting Started page. You will have to create a new site and enter all the 
information in the Local Info and Remote Info tabs. If you are sure that you defined 
your Remote Info, but uploading is not working, go back and check your Remote 
Info. Go to Site > Manage Sites > Your Site Name. If the name of the site is not 
there, follow the steps on Getting Started page.  

UPLOADING YOUR FILES  

To upload your files to the Web, complete this process:  

1. Make sure your Files panel is open. If not, go to Window > Files.  
2. Click the Connect button. This button connects Dreamweaver to your server 

space (see Fig.24).  
3. Make sure your toolbar displays Local View and your files can be seen in the 

panel. The Local View shows everything in the Files panel that is on the 
computer in your local root folder.  

4. Select your local root folder and click on the Put button (See Fig.24).  
 
NOTE: If you make changes, be sure to upload your entire folder and replace the old 
version to keep all files linked properly.  

1. In the toolbar, switch your view from Local to Remote View. You should now see 
your files under Remote as well. The Remote View shows you all of the files 
uploaded on your server space.  

2. Check your site in a browser by typing in your Web site address. If you are using 
the BGSU personal web space your Web address is: http://personal.bgsu. 
edu/~(your username).  

 
NOTE: We recommend that you save a backup of your local root folder on something 
semi permanent such as a CD, a zip disk, or a flash drive (Do not use a floppy disk!) 
in order to save you time and energy when you need to update the site.  

 
 
 
 
 
 
 
 
 
 
 
 

 
Fig.24: Local View  
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DEFINING REMOTE INFO  

Dreamweaver allows you to connect to your main server space and retrieve stored 
folders located on your site. This feature will only be necessary if you need to update 
a currently uploaded website and you no longer have the local root folder for the site.  

To download a file from the server, you will need to know the Remote Info (Figure 
1). The Remote Info you entered when you uploaded your site tells Dreamweaver 
where to find your currently uploaded files.  

Fig.25: Remote Info window  

NOTE: If you are using a personal BGSU web account, you can find the remote 
information on the Getting Started page of this tutorial.  

DOWNLOADING YOUR FILES  

To download files, complete the following process:  

1. Click the Connect button (Fig.26).  
2. Change the toolbar so it displays Remote View and the files associated with your 

site appear on the screen (Fig.26).  
3. Select the folder where all of the files are located, and click on the Get button.  
4. You will see a dialog box asking “Are you sure you want to get the entire site?” 

Click OK.  
5. You should see the files being downloaded, and when it is completed your 

uploaded Web site should appear under Local View in the toolbar.  
6. Go to File > Save to save your project before you make changes to it.  
 

Fig.26: Remote View  

NOTE: If this process does not work, go back 
and check your Remote Info under Sites > 
Manage Site > your site name.  

 


