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I. GETTING S TARTED 
 
First, you need to decide what you want to put on your website: images, files, videos, 
PDF documents, PowerPoint presentations, etc. To create and maintain an organized 
website, you need to establish a hierarchy of folders that contain all of the components 
that make up your site. This folder is called your Local root folder. It is important 
because this is where Dreamweaver looks for all your files. 
 
To create a root folder, follow these steps: 
 
1. Create a new folder on your desktop or personal partition. On the desktop, right-click 
and choose New Folder. 
 
2. Give the folder a brief, but descriptive name. Do not use capital letters, spaces, or 
special characters when naming folders and files for your website. All of your pages will 
be saved within this folder. 
 
3. Open the folder, and create another new folder inside. Name this folder images. Put 
all of your images, buttons, movie files, etc. inside the images folder.  
 
4. Make sure that all your pages and images are saved in your root folder, or they 
will not appear the next time your website is opened. 
 
5. Now you are ready to launch Dreamweaver CS3. Click the Dreamweaver CS3 icon 
from Start > Programs > Macromedia Dreamweaver CS3. Or use the Adobe 
Dreamweaver CS3 Icon on your desktop. 
 
N.B: The most important step you need to take every time you launch Dreamweaver 
CS3 is to define your Local Info. The "local root folder" is the name for the folder where 
you are storing all of your website’s contents. 
 

II. CREATING A WEBPAGE 
 
To create a Web page, follow these guidelines: 
 
1. Choose a page to be the homepage of your Web site. This will be the first page that 
users encounter when they visit your site. Save this file to your local root folder as 
home.html. Naming the homepage home.html tells the Web browser that this is the first 
page it should open when someone visits your site.  
 
2. To add a new page go to File > New and choose a basic HTML page. Save this page 
by clicking File > Save As. Name the first page home.html 
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3. After your homepage is created, you can use this page as a template layout for all the 
other pages in your site. Simply hit Save As and name the file whatever you wish, but be 
sure to keep the name simple, for example CV.html, resume.html, pictures. etc. 
Remember not to use capital letters or spaces when naming files; this will make it easier 
for web browsers to find your files. 
 
4. To save the pages of your site simply click File > Save for each page. Make sure your 
homepage is named home.html, and save all of your files in the folder you chose when 
you defined your site, i.e. in your local root folder. 
 
NOTE: This process will save your files to your local site. You can transfer each file 
separately to the remote site or transfer the entire site once you have finished working 
on it. 
 

III. DESIGN AND LAYOUT 
 
Even if you are creating only a simple Web site, you should begin by sketching out the 
layout of your site. Decide where you want titles, images, navigation buttons, and text to 
appear on the screen. Most web sites have the same design characteristics on every page. 
For example, Web site titles are usually in the top left or top center, while navigation 
buttons usually appear vertically on the left or horizontally below the title. In addition to 
sketching out a layout for each page, you should determine how many pages you will 
need for the Web site. Thorough planning is essential to good web design. 
 
In order to get your text, navigation buttons, and images to appear where you want them 
on the Web page; you need to use tables to format content of each page. Everything on 
each page of your Web site should fit within one large table. 
 
Using your layout sketches, you can determine what your table needs to look like. 
Fig. 1 shows a simple layout sketch. 
Fig. 2 shows the same layout, with table borders drawn in. 
 

             
       Fig. 1:  Simple layout sketch  Fig.2: Simple layout sketch with borders 
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IV. INSERTING AND USING TABLES 
 

A. WHY USE TABLES 
 
Tables help you divide the space on your page. They are similar to tables in Word or 
Excel but can be used in much more flexible ways. Tables give you the option of making 
your page a fixed size or making it fit to the user's window the best it can. Tables also 
guarantee that the location of your text and images does not change when seen on screen 
with different resolutions or in different Web browsers. 

B. HOW TO INSERT A TABLE 
 
To insert a table, follow these steps: 
 
1. In the main menu, click Insert > Table. (See Fig. 3) 
2. Insert the amount of Table Rows and Columns 
3. Set Table width to between 600 and 800 pixels. 
4. Set Border thickness. To have a visible border type in 1 or higher, to have no 
border type in 0. 
5. Cell padding adds room inside of a cell. Enter 0 for no space or a number to 
Increase the space. 
6. Cell spacing adds space between cells. Enter 0 for no space or a number to 
Increase the space. 
7. Click OK. 
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Fig. 3: Table window 

 

C. PROPERTIES OF TABLES 
 

Properties of a Table Itself 
 
If you click on one of the table borders, you can view your table properties in the 
Properties window. 
 

 
Fig. 4: Table Properties window 
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In the top section of this window (Fig.4) you can: 
 
• name your table; 
• change the number of rows and columns in the table; 
• change the width and height of the table, 
• Change the Cell Pad: this is the number of pixels that come between the border 
of cells and the content of cells. 
• Change the Cell Space: this is the number of pixels that come between the 
borders of each cell. 
• Change the alignment: this is the position of the table on the left or right edge, or 
in the center of the page. 
• Change the border: this is the number of pixels that make up the thickness of cell 
borders. 
 
In the bottom section of this window (Fig. 4 above) you can: 
 
• Clear and convert table widths and heights. 
• Change the background color of the whole table. 
• Insert a background image for the whole table. 
• Change the border color. 
 

Properties of Cells Inside Table 
 
Once the properties of the table have been set, you can also adjust the properties of 
individual cells within the table by clicking inside the cell (Fig.5). 
 

 
Fig.5: Table Format window 

 
 
In the top section of this window you can format the text inside the table cell. 
In the bottom section of this window you can: 
• Change the alignment of the content horizontally and vertically. 
• Change the width and the height of the cell 
• Use Wrap. 
• Insert Header 
• Insert a background image for the single cell. 
• Change the background color for the single cell. 
• Change the border color for the single cell. 
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D. CREATING YOUR DESIRED LAYOUT 
 
To create the traditional layout, follow the directions below: 
 
1. Insert a table with 3 rows and 3 columns that takes up 100% of the page. 
 

 
 
2. Highlight the first row of cells by placing your cursor in either far left or far right cell 
and dragging to the other side. 
 

 
 
3. Use the bottom section of the Properties window to merge the cells you have 
selected (use the button right under the word “Cell”). This section will be used for the 
title of your page. 
 

 
 
4. Highlight and merge the bottom row. This section will be used for information such as 
your contact info and the date the site was last updated. 
 

 
 

 
 
5. Highlight and merge the middle and right cells in the middle row. This section will be 
used for your main content, and the leftover cell will be used for links. 
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6. Now you can adjust the table by clicking and dragging on the handles to make the 
table look more like a familiar webpage (if you have problems dragging the handles you 
can use the Properties window to manually insert the number of pixels or percent of the 
table for the width and height of the cell). 
 

 
From here you can insert additional tables into any of the cells you want. This will let you 
place your text and images exactly where you want them within each section. 
 

V. ADDING DESIGN E LEMENTS 

A. ADDING TEXT 
To insert text simply click inside a cell and type in your content. When you click 
ENTER, Dreamweaver automatically adds paragraph spacing. To add a line space, click 
SHIFT + ENTER. 

B. INSERTING IMAGES 
To insert an image, follow these steps: 
1. Click in the cell where you want the image to appear. 
2. Click Insert > Image. 
3. Locate the image you want to insert. 
 
NOTE: All of your images should be saved in the "images" folder that you established 
when you started. 
 
4. Click Choose to insert the image. 
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Click on the image to view its properties in the Image Properties Inspector window 
(Fig. 6). 
 

 
Fig.6: Image Properties Inspector window 

 

C. IMAGE PROPERTIES INSPECTOR 
 
The top half of the Image Properties Inspector allows you to: 
• Name the image (far left). 
• Change the size of the image (W & H). 
• See where the image file is located (Src). 
• Link the image to a file or a site (Link). 
• Edit the image (Edit). 
 

 

 
 

D. FORMATTING PAGE PROPERTIES 

o change the background color of your pages or other overall properties of your 
 

 
T
website, go to Modify > Page Properties. Here, in the Page Properties window, you
can set the default font, text size, text color, and background for all of your pages (Fig.7). 
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Fig.7: Page Properties Appearance window 

 
To modify the properties of links, click on the Links tab under Category. Here you can 
set link font, size, link color, color of active, rollover, and visited links, as well as link 
style (Fig. 8). 
 

 
Fig. 8: Page Properties Links window 

 

VI. PREVIEWING IN BROWSER 
 
You can preview your Web pages in a browser in many ways: 
 
1. Choose File > Preview in Browser. 
2. Hit F12. 
3. Click on the world icon located on the toolbar at the top of your page (Fig.1). 
 

VII. CREATING HYPERLINKS 
 
A hyperlink or link, is an object or text that, when clicked, takes the users to another 
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webpage or opens a file. The various types of hyperlinks are explained below. 

A. INTERNAL LINKS 
Internal links are used to connect users to other pages within the same website. Before 
linking to other pages, you must make sure that the other pages are saved in your local 
root folder and contain the file extension .html. 
 
To create an internal link, follow these steps: 
 
1. Select the text or image you would like to make a hyperlink. 
2. Click on the small folder next to the Link field in the Properties Inspector 3 (Fig 9 and 
Fig. 10). Browse through the files, and select the page you would like to link. 
4. Click OK. 
 

 
Fig. 9: Text Properties Inspector 

 

 
Fig.10: Image Properties Inspector 

 

B. EXTERNAL LINKS 
 
External links are used to connect the users to pages from other websites. 
To create an external link, do the following: 
 
1. Select a text or an image you want to make a hyperlink. 
2. Click the cursor inside of the link text field in the Properties Inspector. 
3. Type the complete URL (web address) of the website you want to link 
(e.g., http://www.aui.ma). 
4. Select the Target type as -blank. 
 
NOTE: If you select the Target type as -blank, it will open the link in a new window 
while keeping your website open in another window. Doing this is good practice because 
it will prevent the user from being frustrated and leaving your site. 

C. BASIC EMAIL LINK 
 
E-mail links are links that will automatically open the user's default email program with a 

Adapted from www.bgsu.edu/downloads/cio/file17760.pdf 
 

 



 

Adapted from www.bgsu.edu/downloads/cio/file17760.pdf 
 

12

 

blank e-mail addressed to the specified e-mail link. There are two ways to create an email 
link. You can: 
 
1. Click on the Insert menu at the top of the screen and select Email Link. 
2. Type in text for the hyperlink name or label, for example: My Email or Click here to 
email me (Fig.11). 
3. Type in your email address, i.e. where the email is to be sent. 
4. Click OK. 
 

 
Fig. 11: E-mail Link window 

VIII. A FEW TIPS ON WEB DESGN   
(From Designing for the Web: A tutorial by Mike Markel) 

 
1. Aim for simplicity  
2. Make the text easy to read and understand 
3. Create informative headers and footers 
4. Help readers navigate the site 
5. Create clear, graceful links 
6. Avoid web clichés 
7. Include extra features your readers might need 

IX. TESTING YOUR WEBSITE 
 
Once all your pages are competed, you need to test your site to make sure that all pages 
are functional. The following tips can help you avoid unwanted surprises: 
 
1. When creating pages, work with a 1024 by 768 screen resolution 
2. Test your website on different browsers (e.g., Microsoft Internet Explorer, 

Netscape Navigator) 
3. Test your website using a variety of screen sizes since the size of the monitor can 

dramatically alter the appearance of your site. 
4. Testing should be done frequently in order to fix broken links and detect other 

glitches.  

X. UPLOADING YOUR WEBSITE TO THE AUI SERVER 
 
To upload your site to the AUI server, follow the instructions in this document: 
http://www.aui.ma/personal/~H.Belhiah/pdf%20files/ftp_instructions.pdf 
 

http://bcs.bedfordstmartins.com/techcomm8e/tutorials/designforweb/2_home.html
http://www.aui.ma/personal/%7EH.Belhiah/pdf%20files/ftp_instructions.pdf
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